# Unable to start elasticsearch as service

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch-as-service/178440>\
**Category:** Elasticsearch\
**Created:** [April 25, 2019, 11:29am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-as-service/178440 "2019-04-25T11:29:22Z")\
**Posts on this page:** 1\
**Showing post:** 6

<div class="post-metadata">

**Author:** ![harshbajaj16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/harshbajaj16/32/44970_2.png) [@harshbajaj16](https://discuss.elastic.co/u/harshbajaj16)\
**Post date:** [April 26, 2019, 5:37am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-as-service/178440/6 "2019-04-26T05:37:11Z")

</div>

Hi @Kajol_Nimesh,

Access denied exception is showing for the path /var/lib/elasticsearch. could you please check the access permission for this path.

> [@](#):
>
> Caused by: java.nio.file.AccessDeniedException: /var/lib/elasticsearch/nodes/0/node.lock

If you see below error it clearly show that not writable and multiple nodes were started. Please check and let me know if you still facing any issue.

> [@](#):
>
> failed to obtain node locks, tried [[/var/lib/elasticsearch]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max\_local\_storage\_nodes] (was [1])? at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:297) ~[elasticsearch-7.0.0.jar:7.0.0]

Regards,  
Harsh Bajaj

---

_[View the full topic](https://discuss.elastic.co/t/unable-to-start-elasticsearch-as-service/178440)._
