# Unable to start Elasticsearch Error with exit code

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch-error-with-exit-code/157630>\
**Category:** Elasticsearch\
**Created:** [November 21, 2018, 6:46am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-error-with-exit-code/157630 "2018-11-21T06:46:57Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Bishwadeep\_Kc](https://avatars.discourse-cdn.com/v4/letter/b/f6c823/32.png) [@Bishwadeep\_Kc](https://discuss.elastic.co/u/Bishwadeep_Kc)\
**Post date:** [November 21, 2018, 6:46am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-error-with-exit-code/157630/1 "2018-11-21T06:46:57Z")

</div>

Hi,

I installed Elasticsearch version 5.6.13 on my ubuntu system. When I try to start the Elasticsearch service, it wont run. I updated my elasticsearch.yml file(configuration added below) . I have added the output of the command "service elasticsearch status" below and I have also included the last lines of the elasticsearch.log file. Please let me know if you need more information.

* * *

elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Wed 2018-11-21 17:12:16 AEDT; 29min ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 1783 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p {PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs={LOG\_DIR} -Ed  
Process: 1779 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 1783 (code=exited, status=1/FAILURE)

Nov 21 17:12:13 ip-172-31-35-135 systemd[1]: Starting Elasticsearch...  
Nov 21 17:12:13 ip-172-31-35-135 systemd[1]: Started Elasticsearch.  
Nov 21 17:12:16 ip-172-31-35-135 systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE  
Nov 21 17:12:16 ip-172-31-35-135 systemd[1]: elasticsearch.service: Unit entered failed state.  
Nov 21 17:12:16 ip-172-31-35-135 systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

* * *

elasticsearch.yml file  
\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
# ======================== Elasticsearch Configuration =========================  
#  
# NOTE: Elasticsearch comes with reasonable defaults for most settings.  
# Before you set out to tweak and tune the configuration, make sure you  
# understand what are you trying to accomplish and the consequences.  
#  
# The primary way of configuring a node is via this file. This template lists  
# the most important settings you may want to configure for a production cluster.  
#  
# Please consult the documentation for further information on configuration options:  
# [https://www.elastic.co/guide/en/elasticsearch/reference/index.html](https://www.elastic.co/guide/en/elasticsearch/reference/index.html)  
#  
# ---------------------------------- Cluster -----------------------------------  
#  
# Use a descriptive name for your cluster:  
#  
#cluster.name: my-application  
#  
# ------------------------------------ Node ------------------------------------  
#  
# Use a descriptive name for the node:  
#  
#node.name: node-1  
#  
# Add custom attributes to the node:  
#  
#node.attr.rack: r1  
#  
# ----------------------------------- Paths ------------------------------------  
#  
# Path to directory where to store the data (separate multiple locations by comma):  
#  
#path.data: /path/to/data  
#  
# Path to log files:  
#  
#path.logs: /path/to/logs  
#  
# ----------------------------------- Memory -----------------------------------  
#  
# Lock the memory on startup:  
#  
bootstrap.memory\_lock: true  
#  
# Make sure that the heap size is set to about half the memory available  
# on the system and that the owner of the process is allowed to use this  
# limit.  
#  
# Elasticsearch performs poorly when the system is swapping the memory.  
#  
# ---------------------------------- Network -----------------------------------  
#  
# Set the bind address to a specific IP (IPv4 or IPv6):  
#  
network.host: localhost  
#  
# Set a custom port for HTTP:  
#  
http.port: 9200  
#  
# For more information, consult the network module documentation.  
#  
# --------------------------------- Discovery ----------------------------------  
#  
# Pass an initial list of hosts to perform discovery when new node is started:  
# The default list of hosts is ["127.0.0.1", "[::1]"]  
#  
#discovery.zen.ping.unicast.hosts: ["host1", "host2"]  
#  
# Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):  
#  
#discovery.zen.minimum\_master\_nodes: 3  
#  
# For more information, consult the zen discovery module documentation.  
#  
# ---------------------------------- Gateway -----------------------------------  
#  
# Block initial recovery after a full cluster restart until N nodes are started:  
#  
#gateway.recover\_after\_nodes: 3  
#  
# For more information, consult the gateway module documentation.  
#  
# ---------------------------------- Various -----------------------------------  
#  
# Require explicit names when deleting indices:  
#  
#action.destructive\_requires\_name: true

```
**************************************************************

```

Elasticsearch log file:

* * *

4 errors  
at org.elasticsearch.common.inject.internal.Errors.throwCreationExceptionIfErrorsExist(Errors.java:361) ~[elasticsearch-5.6.13.jar:5.6.13]  
at org.elasticsearch.common.inject.InjectorBuilder.injectDynamically(InjectorBuilder.java:164) ~[elasticsearch-5.6.13.jar:5.6.13]  
at org.elasticsearch.common.inject.InjectorBuilder.build(InjectorBuilder.java:96) ~[elasticsearch-5.6.13.jar:5.6.13]  
at org.elasticsearch.common.inject.Guice.createInjector(Guice.java:96) ~[elasticsearch-5.6.13.jar:5.6.13]  
at org.elasticsearch.common.inject.Guice.createInjector(Guice.java:70) ~[elasticsearch-5.6.13.jar:5.6.13]  
at org.elasticsearch.common.inject.ModulesBuilder.createInjector(ModulesBuilder.java:42) ~[elasticsearch-5.6.13.jar:5.6.13]  
at org.elasticsearch.node.Node.(Node.java:499) ~[elasticsearch-5.6.13.jar:5.6.13]  
at org.elasticsearch.node.Node.(Node.java:245) ~[elasticsearch-5.6.13.jar:5.6.13]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:233) ~[elasticsearch-5.6.13.jar:5.6.13]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:233) ~[elasticsearch-5.6.13.jar:5.6.13]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:342) ~[elasticsearch-5.6.13.jar:5.6.13]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132) ~[elasticsearch-5.6.13.jar:5.6.13]

* * *

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 21, 2018, 6:52am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-error-with-exit-code/157630/2 "2018-11-21T06:52:24Z")

</div>

Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 19, 2018, 6:58am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-error-with-exit-code/157630/3 "2018-12-19T06:58:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
