# Unable to start elasticsearch on centos 7 server

**URL:** https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos-7-server/254276
**Category:** Elasticsearch
**Created:** [November 4, 2020, 1:49pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos-7-server/254276 "2020-11-04T13:49:22Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![valsaraj\_pv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/valsaraj_pv/32/43572_2.png) [@valsaraj\_pv](https://discuss.elastic.co/u/valsaraj_pv)
#### Post date: [November 4, 2020, 1:49pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos-7-server/254276/1 "2020-11-04T13:49:22Z")

</div>

After installation, we got following error when started the service:

> [2020-11-04T07:20:12,233][WARN][o.e.b.Natives] [test] unable to load JNA native support library, native methods will be disabled.  
> java.lang.UnsatisfiedLinkError: /tmp/elasticsearch-16982199008150233397/jna17827281711253842809.tmp: /tmp/elasticsearch-16982199008150233397/jna17827281711253842809.tmp: failed to map segment from shared object: Operation not permitted
> 
> Applied the following fix:  
> vim /etc/sysconfig/elasticsearch  
> ES\_TMPDIR=/var/lib/elasticsearch/tmp
> 
> vim /etc/elasticsearch/jvm.options
> 
> ## JVM temporary directory
> 
> -Djava.io.tmpdir=${ES\_TMPDIR}  
> -Djna.tmpdir=/var/lib/elasticsearch/tmp
> 
> Then got the following error on elasticsearch service start:
> 
> Nov 4 08:10:17 test systemd: Starting Elasticsearch...  
> Nov 4 08:10:17 test systemd-entrypoint: future versions of Elasticsearch will require Java 11; your Java version from [/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.262.b10-0.el7\_8.x86\_64/jre] does not meet this requirement  
> Nov 4 08:10:17 test systemd-entrypoint: future versions of Elasticsearch will require Java 11; your Java version from [/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.262.b10-0.el7\_8.x86\_64/jre] does not meet this requirement  
> Nov 4 08:10:19 test systemd-entrypoint: #  
> Nov 4 08:10:19 test systemd-entrypoint: # A fatal error has been detected by the Java Runtime Environment:  
> Nov 4 08:10:19 test systemd-entrypoint: #  
> Nov 4 08:10:19 test systemd-entrypoint: # SIGSEGV (0xb) at pc=0x00007f6768e34c95, pid=194820, tid=0x00007f67d144b700  
> Nov 4 08:10:19 test systemd-entrypoint: #  
> Nov 4 08:10:19 test systemd-entrypoint: # JRE version: OpenJDK Runtime Environment (8.0\_262-b10) (build 1.8.0\_262-b10)  
> Nov 4 08:10:19 test systemd-entrypoint: # Java VM: OpenJDK 64-Bit Server VM (25.262-b10 mixed mode, sharing linux-amd64 compressed oops)  
> Nov 4 08:10:19 test systemd-entrypoint: # Problematic frame:  
> Nov 4 08:10:19 test systemd-entrypoint: # C [jna3377815825213492039.tmp+0x12c95] ffi\_prep\_closure\_loc+0x15  
> Nov 4 08:10:19 test systemd-entrypoint: #  
> Nov 4 08:10:19 test systemd-entrypoint: # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again  
> Nov 4 08:10:19 test systemd-entrypoint: #  
> Nov 4 08:10:19 test systemd-entrypoint: # An error report file with more information is saved as:  
> Nov 4 08:10:19 test systemd-entrypoint: # /var/log/elasticsearch/hs\_err\_pid194820.log  
> Nov 4 08:10:19 test systemd-entrypoint: #  
> Nov 4 08:10:19 test systemd-entrypoint: # If you would like to submit a bug report, please visit:  
> Nov 4 08:10:19 test systemd-entrypoint: # [Crash Report](http://bugreport.java.com/bugreport/crash.jsp)  
> Nov 4 08:10:19 test systemd-entrypoint: # The crash happened outside the Java Virtual Machine in native code.  
> Nov 4 08:10:19 test systemd-entrypoint: # See problematic frame for where to report the bug.  
> Nov 4 08:10:19 test systemd-entrypoint: #  
> Nov 4 08:10:19 test systemd-entrypoint: 2020-11-04 13:10:19,805768 UTC [195028] ERROR CLogger.cc@310 Cannot log to named pipe /var/lib/elasticsearch/tmp/controller\_log\_194820 as it could not be opened for writing  
> Nov 4 08:10:19 test systemd-entrypoint: 2020-11-04 13:10:19,805841 UTC [195028] INFO Main.cc@103 Parent process died - ML controller exiting

Environment Details:  
echo $JAVA\_HOME  
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.262.b10-0.el7\_8.x86\_64

```
CentOS Linux release 7.7.1908 (Core)
elasticsearch-7.9.0-1.x86_64

```

Any idea?

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [November 4, 2020, 11:30pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos-7-server/254276/2 "2020-11-04T23:30:15Z")

</div>

What do your actual Elasticsearch logs show?

---

<div class="post-metadata">

### Author: ![valsaraj\_pv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/valsaraj_pv/32/43572_2.png) [@valsaraj\_pv](https://discuss.elastic.co/u/valsaraj_pv)
#### Post date: [November 5, 2020, 5:06am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos-7-server/254276/3 "2020-11-05T05:06:37Z")

</div>

Elasticsearch logs are empty. The service start fails and the system log shows the error that I added in description.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [November 5, 2020, 9:41pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos-7-server/254276/4 "2020-11-05T21:41:58Z")

</div>

It specifically mentions `/var/log/elasticsearch/hs_err_pid194820.log`, does that not exist?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 3, 2020, 9:42pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos-7-server/254276/5 "2020-12-03T21:42:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
