# Unable to start elasticsearch on CentOs

**URL:** https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos/64107
**Category:** Elasticsearch
**Created:** [October 27, 2016, 7:45am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos/64107 "2016-10-27T07:45:32Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![umir](https://avatars.discourse-cdn.com/v4/letter/u/45deac/32.png) [@umir](https://discuss.elastic.co/u/umir)
#### Post date: [October 27, 2016, 7:45am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos/64107/1 "2016-10-27T07:45:32Z")

</div>

initially elastic search was working but due to some update its stop working and giving such error message while checking status.

```
systemctl status elasticsearch.service
● elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2016-10-27 11:26:43 PKT; 21min ago
     Docs: http://www.elastic.co
  Process: 10038 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -Des.pidfile=${PID_DIR}/elasticsearch.pid -Des.default.path.home=${ES_HOME} -Des.default.path.logs=${LOG_DIR} -Des.default.path.data=${DATA_DIR} -Des.default.path.conf=${CONF_DIR} (code=exited, status=1/FAILURE)
  Process: 10032 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)
 Main PID: 10038 (code=exited, status=1/FAILURE)

Oct 27 11:26:43 ELK-*** elasticsearch[10038]: #
Oct 27 11:26:43 ELK-UMIR elasticsearch[10038]: # Block initial recovery after a full cluster restart until N nodes are started:
Oct 27 11:26:43 ELK-UMIR elasticsearch[10038]: #
Oct 27 11:26:43 ELK-UMIR elasticsearch[10038]: # gateway.recover_after_nodes: 3
Oct 27 11:26:43 ELK-UMIR elasticsearch[10038]: #
Oct 27 11:26:43 ELK-UMIR elasticsearch[10038]: # For more information, see the documentation at:
Oct 27 11:26:43 ELK-UMIR elasticsearch[10038]: # <http://www.elastic.co/guide/en/elasticsearch/reference/current/modules-gateway.html>
Oct 27 11:26:43 ELK-UMIR systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE
Oct 27 11:26:43 ELK-UMIR systemd[1]: Unit elasticsearch.service entered failed state.
Oct 27 11:26:43 ELK-UMIR systemd[1]: elasticsearch.service failed.
```

---

<div class="post-metadata">

### Author: ![xavierfacq](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xavierfacq/32/8744_2.png) [@xavierfacq](https://discuss.elastic.co/u/xavierfacq)
#### Post date: [October 27, 2016, 7:57am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos/64107/2 "2016-10-27T07:57:00Z")

</div>

Hi, can you provide the end of the Elasticsearch log ?

Something like :  
tail -f /var/log/elasticsearch/your\_cluster\_name.log

---

<div class="post-metadata">

### Author: ![umir](https://avatars.discourse-cdn.com/v4/letter/u/45deac/32.png) [@umir](https://discuss.elastic.co/u/umir)
#### Post date: [October 27, 2016, 8:35am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos/64107/3 "2016-10-27T08:35:05Z")

</div>

on tail -f /var/log/elasticsearch/elasticsearch.log

```
 java.lang.IllegalArgumentException: invalid port range: localhost
            at java.net.SocketPermission.init(SocketPermission.java:436)
            at java.net.SocketPermission.<init>(SocketPermission.java:291)
            at org.elasticsearch.bootstrap.Security.addBindPermissions(Security.java:277)
            at org.elasticsearch.bootstrap.Security.createPermissions(Security.java:213)
            at org.elasticsearch.bootstrap.Security.configure(Security.java:118)
            at org.elasticsearch.bootstrap.Bootstrap.setupSecurity(Bootstrap.java:212)
            at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:183)
            at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:286)
            at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)
```

---

<div class="post-metadata">

### Author: ![xavierfacq](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xavierfacq/32/8744_2.png) [@xavierfacq](https://discuss.elastic.co/u/xavierfacq)
#### Post date: [October 27, 2016, 8:37am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos/64107/4 "2016-10-27T08:37:47Z")

</div>

I seems that there is something wrong in your configuration file, lool at /etc/elasticsearch/elasticsearch.yml

check transport.tcp.port or http.port

---

<div class="post-metadata">

### Author: ![umir](https://avatars.discourse-cdn.com/v4/letter/u/45deac/32.png) [@umir](https://discuss.elastic.co/u/umir)
#### Post date: [October 27, 2016, 8:49am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos/64107/5 "2016-10-27T08:49:10Z")

</div>

elasticsearch.yml

 ![](https://us1.discourse-cdn.com/elastic/original/2X/b/b077643f7eed8c135c052e50418ac44da5550e8c.png) ![](https://us1.discourse-cdn.com/elastic/original/2X/d/d0fa927ecf8362815d19006aa4b19bfad68627dc.png) ![](https://us1.discourse-cdn.com/elastic/original/2X/a/aef0bc98f3fe7afb23fda6b1dce488e0de35fdfb.png)

I try to do some settings for nginx from then it's stop working btw

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [October 27, 2016, 8:54am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos/64107/6 "2016-10-27T08:54:28Z")

</div>

`localhost` is not a valid port number for the `http.port` setting. Comment this out to use the default 9200 port.

---

<div class="post-metadata">

### Author: ![xavierfacq](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xavierfacq/32/8744_2.png) [@xavierfacq](https://discuss.elastic.co/u/xavierfacq)
#### Post date: [October 27, 2016, 8:56am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos/64107/7 "2016-10-27T08:56:24Z")

</div>

> [@xavierfacq](#):
>
> http.port

Your error :  
http.port = localhost

set:  
http.port: 9200

---

<div class="post-metadata">

### Author: ![umir](https://avatars.discourse-cdn.com/v4/letter/u/45deac/32.png) [@umir](https://discuss.elastic.co/u/umir)
#### Post date: [October 27, 2016, 9:36am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos/64107/8 "2016-10-27T09:36:17Z")

</div>

Thanks! its working now.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:09pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-centos/64107/9 "2017-07-05T22:09:08Z")

</div>


