# Unable to start elasticsearch on Ubuntu 18

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-ubuntu-18/176738>\
**Category:** Elasticsearch\
**Created:** [April 13, 2019, 4:04pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-ubuntu-18/176738 "2019-04-13T16:04:38Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![johndowe](https://avatars.discourse-cdn.com/v4/letter/j/3ab097/32.png) [@johndowe](https://discuss.elastic.co/u/johndowe)\
**Post date:** [April 13, 2019, 4:04pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-ubuntu-18/176738/1 "2019-04-13T16:04:38Z")

</div>

I have installed Elasticsearch 7 on Ubuntu VERSION="18.04.2 LTS (Bionic Beaver)" and I am unable to start the service after attempting a million options I always get the same error :  
root@PiEKStack:/var/log/elasticsearch# service elasticsearch status  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Sat 2019-04-13 17:57:50 CEST; 31s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 2195 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=78)  
Main PID: 2195 (code=exited, status=78)

I believe it could be a GC issue from the logs but still unable to resolve it so far.Service starts and switches off after a few seconds

Anyone had the same issue?

---

<div class="post-metadata">

**Author:** ![staodd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/staodd/32/24509_2.png) [@staodd](https://discuss.elastic.co/u/staodd)\
**Post date:** [April 13, 2019, 6:53pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-ubuntu-18/176738/2 "2019-04-13T18:53:51Z")

</div>

Might be better if you post the logs instead of just your theory...

---

<div class="post-metadata">

**Author:** ![johndowe](https://avatars.discourse-cdn.com/v4/letter/j/3ab097/32.png) [@johndowe](https://discuss.elastic.co/u/johndowe)\
**Post date:** [April 13, 2019, 8:08pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-ubuntu-18/176738/3 "2019-04-13T20:08:05Z")

</div>

I have solved this.. Issue was with bootstrap checks:  
[https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 11, 2019, 8:08pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-on-ubuntu-18/176738/4 "2019-05-11T20:08:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
