# "unable to start elasticsearch"

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch/136857>\
**Category:** Elasticsearch\
**Created:** [June 21, 2018, 12:37pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/136857 "2018-06-21T12:37:34Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![satish\_k\_y18](https://avatars.discourse-cdn.com/v4/letter/s/b2d939/32.png) [@satish\_k\_y18](https://discuss.elastic.co/u/satish_k_y18)\
**Post date:** [June 21, 2018, 12:37pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/136857/1 "2018-06-21T12:37:34Z")

</div>

error /usr/share/elasticsearch/bin/elasticsearch-env: line 70: /etc/default/elasticsearch: Permission denied

Note : Line 70 is "source /etc/default/elasticsearch " in elasticsearch-env

ls -dl /etc/default/  
drw-r--r-- 2 root root 4096 Jun 21 11:52 /etc/default/

ls -l /etc/default/elasticsearch  
-rw-r--r-- 1 elasticsearch elasticsearch 101 Jun 21 11:52 /etc/default/elasticsearch

but when i am giving chown o+x /etc/default/ it start working .

---

<div class="post-metadata">

**Author:** ![cbuescher](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cbuescher/32/60402_2.png) [@cbuescher](https://discuss.elastic.co/u/cbuescher)\
**Post date:** [June 29, 2018, 11:13am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/136857/2 "2018-06-29T11:13:28Z")

</div>

Might be this issue [https://github.com/elastic/ansible-elasticsearch/issues/424](https://github.com/elastic/ansible-elasticsearch/issues/424) which seems to be fixed in 6.2.2?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 27, 2018, 11:13am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/136857/3 "2018-07-27T11:13:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
