# Unable to Start Elasticsearch

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch/250625>\
**Category:** Elasticsearch\
**Created:** [October 1, 2020, 8:59am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/250625 "2020-10-01T08:59:01Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![muthug](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/muthug/32/82555_2.png) [@muthug](https://discuss.elastic.co/u/muthug)\
**Post date:** [October 1, 2020, 8:59am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/250625/1 "2020-10-01T08:59:01Z")

</div>

OS:- RHEL 7  
ES Version: 6.7  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Thu 2020-10-01 10:47:08 CEST; 23s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 116535 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 116535 (code=exited, status=1/FAILURE)

Oct 01 10:47:08 FRAKHRPL105 elasticsearch[116535]: 2020-10-01 10:47:08,151 main ERROR Unable to locate appender "rolling" for logger config "root"  
Oct 01 10:47:08 FRAKHRPL105 elasticsearch[116535]: 2020-10-01 10:47:08,152 main ERROR Unable to locate appender "index\_indexing\_slowlog\_rolling" for logger config "index.indexing.slowlog.index"  
Oct 01 10:47:08 FRAKHRPL105 elasticsearch[116535]: 2020-10-01 10:47:08,152 main ERROR Unable to locate appender "audit\_rolling" for logger config "org.elasticsearch.xpack.security.audit.logfile.LoggingAuditTrail"  
Oct 01 10:47:08 FRAKHRPL105 elasticsearch[116535]: 2020-10-01 10:47:08,152 main ERROR Unable to locate appender "index\_search\_slowlog\_rolling" for logger config "index.search.slowlog"  
Oct 01 10:47:08 FRAKHRPL105 elasticsearch[116535]: 2020-10-01 10:47:08,152 main ERROR Unable to locate appender "deprecated\_audit\_rolling" for logger config "org.elasticsearch.xpack.security.audit.logfile.DeprecatedLoggingAuditTrail"  
Oct 01 10:47:08 FRAKHRPL105 elasticsearch[116535]: 2020-10-01 10:47:08,153 main ERROR Unable to locate appender "deprecation\_rolling" for logger config "org.elasticsearch.deprecation"

---

<div class="post-metadata">

**Author:** ![Steve\_Mushero](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steve_mushero/32/22441_2.png) [@Steve\_Mushero](https://discuss.elastic.co/u/Steve_Mushero)\
**Post date:** [October 2, 2020, 7:42am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/250625/2 "2020-10-02T07:42:24Z")

</div>

> [@muthug](#):
>
> ERROR Unable to locate appender "rolling" for logger config "root"

Do you have a valid logging config in your /etc/elasticsearch? Should have been installed with the RPM unless you installed this in some odd way.

---

<div class="post-metadata">

**Author:** ![muthug](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/muthug/32/82555_2.png) [@muthug](https://discuss.elastic.co/u/muthug)\
**Post date:** [October 3, 2020, 10:36am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/250625/3 "2020-10-03T10:36:25Z")

</div>

I have used RPM setup file and by the way i found the solution.

/var/lib/ellasticsearch/node --\> i removed this and reinstalled again its worked:)

Thanks for your reply

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 31, 2020, 10:36am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/250625/4 "2020-10-31T10:36:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
