# Unable to start elasticsearch

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch/264313>\
**Category:** Elasticsearch\
**Created:** [February 15, 2021, 12:54pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/264313 "2021-02-15T12:54:00Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Aniket\_Salvi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aniket_salvi/32/45433_2.png) [@Aniket\_Salvi](https://discuss.elastic.co/u/Aniket_Salvi)\
**Post date:** [February 15, 2021, 12:54pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/264313/1 "2021-02-15T12:54:00Z")

</div>

Hi,

I am unable to start Elasticsearch on docker. Refer following screenshot for error.

 ![Screenshot from 2021-02-15 17-15-55](https://us1.discourse-cdn.com/elastic/original/3X/c/f/cfff85e4d1e578f068aa34e3f1eeb450b709a9b1.jpeg)

Can anyone help me to solve this error.  
Elasticsearch version - 6.4.3

Thanks

---

<div class="post-metadata">

**Author:** ![Julien](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julien/32/19688_2.png) [@Julien](https://discuss.elastic.co/u/Julien)\
**Post date:** [February 15, 2021, 10:13pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/264313/2 "2021-02-15T22:13:20Z")

</div>

Best to copy/paste the text of the error, it seems the error mentions two causes and this most likely cause from incorrect definition on docker side with the volume used for data folder:

1. `/usr/share/elasticsearch/data` is read-only
2. `/usr/share/elasticsearch/data` is already used/locked by another node (another docker container)

Can you check both those points

1. `docker inspect <container_id>` would show if a read-only volume is used (or just check with the docker CLI options you used, or docker-compose service defintion for example...)
2. Secondly you should check that the volume is only used by a single container. For example just use a different/new volume for that container and check if the error goes away

Thanks

---

<div class="post-metadata">

**Author:** ![Aniket\_Salvi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aniket_salvi/32/45433_2.png) [@Aniket\_Salvi](https://discuss.elastic.co/u/Aniket_Salvi)\
**Post date:** [February 16, 2021, 5:51am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/264313/3 "2021-02-16T05:51:34Z")

</div>

Hi @Julien ,

Thanks for reply.

I am able to solve issue by deleting **node.lock** file.

Thanks & Regards

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 16, 2021, 5:52am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch/264313/4 "2021-03-16T05:52:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
