# Unable to start Enterprise search service

**URL:** <https://discuss.elastic.co/t/unable-to-start-enterprise-search-service/325243>\
**Category:** Elastic Search\
**Tags:** elastic-app-search\
**Created:** [February 10, 2023, 10:56am UTC](https://discuss.elastic.co/t/unable-to-start-enterprise-search-service/325243 "2023-02-10T10:56:02Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nishad\_Angre](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nishad_angre/32/83788_2.png) [@Nishad\_Angre](https://discuss.elastic.co/u/Nishad_Angre)\
**Post date:** [February 10, 2023, 10:56am UTC](https://discuss.elastic.co/t/unable-to-start-enterprise-search-service/325243/1 "2023-02-10T10:56:02Z")

</div>

Getting this log while starting service.

[2023-02-10T10:48:58.588+00:00][29933][4004][app-server][WARN]: [pre-flight] Failed to connect to Elasticsearch backend. Make sure it is running and healthy.  
[2023-02-10T10:48:58.589+00:00][29933][4004][app-server][INFO]: [pre-flight] Error: /home/ec2-user/enterprise-search-8.6.1/lib/war/shared\_togo/lib/shared\_togo/elasticsearch\_checks.class:179: Connect to 10.0.3.249:9200 [/10.0.3.249] failed: Connection refused (Faraday::ConnectionFailed)

Have added below config in enterprise-search.yml as per [Download Elastic Enterprise Search | Elastic](https://www.elastic.co/downloads/enterprise-search)

secret\_management.encryption\_keys: ["sdfsdf/B?sdfdsf(G+KbPeShVmY"]  
allow\_es\_settings\_modification: true  
elasticsearch.host: [https://10.0.3.249:9200](https://10.0.3.249:9200)  
elasticsearch.username: elastic  
elasticsearch.password: dffdsfdsf  
elasticsearch.ssl.enabled: true  
elasticsearch.ssl.certificate\_authority: /home/ec2-user/enterprise-search-8.6.1/config/ca.pem  
elasticsearch.ssl.verify: true  
kibana.host: [https://10.0.3.249:5601/](https://10.0.3.249:5601/)  
kibana.external\_url: [https://10.0.3.249:5601/](https://10.0.3.249:5601/)

Please help me identify the issue. No idea what is that I am missing. The ES cluster has HTTP and TLS security. Kibana has HTTP security. All have same CA.

---

<div class="post-metadata">

**Author:** ![Sean\_Story](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sean_story/32/69987_2.png) [@Sean\_Story](https://discuss.elastic.co/u/Sean_Story)\
**Post date:** [February 10, 2023, 2:16pm UTC](https://discuss.elastic.co/t/unable-to-start-enterprise-search-service/325243/2 "2023-02-10T14:16:07Z")

</div>

Looks like you're using AWS EC2 as your hosting provider. Have you set up the security groups to allow traffic from the host with Enterprise Search to the host with Elasticsearch? Is your Elasticsearch server up and running?

The first troubleshooting step I'd take is to attempt to connect to Elasticsearch from the host where you'd installed Enterprise Search using a tool like CURL.

```bash
curl -v -k -u elastic:dffdsfdsf https://10.0.3.249:9200

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 10, 2023, 2:16pm UTC](https://discuss.elastic.co/t/unable-to-start-enterprise-search-service/325243/3 "2023-03-10T14:16:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
