# Unable to Start ES Cluster using docker-compose on M1 Mac

**URL:** <https://discuss.elastic.co/t/unable-to-start-es-cluster-using-docker-compose-on-m1-mac/345406>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [October 19, 2023, 4:41pm UTC](https://discuss.elastic.co/t/unable-to-start-es-cluster-using-docker-compose-on-m1-mac/345406 "2023-10-19T16:41:41Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![lance.zukel](https://avatars.discourse-cdn.com/v4/letter/l/dbc845/32.png) [@lance.zukel](https://discuss.elastic.co/u/lance.zukel)\
**Post date:** [October 19, 2023, 4:41pm UTC](https://discuss.elastic.co/t/unable-to-start-es-cluster-using-docker-compose-on-m1-mac/345406/1 "2023-10-19T16:41:41Z")

</div>

Need to set up a 3 node cluster using docker on my M1 Mac, using docker desktop/docker-compose.  
I am getting the following error:

```auto
2023-10-19 10:33:05 ERROR: [1] bootstrap checks failed. You must address the points described in the following [1] lines before starting Elasticsearch.
2023-10-19 10:33:05 bootstrap check failure [1] of [1]: max file descriptors [64000] for elasticsearch process is too low, increase to at least [65535]

```

I have followed the documentation to try and set the vm.max\_map\_count setting to no avail.  
Have tried using screen, there is no tty session to connect to.  
Have tried using docker-machine ssh - There are no docker-machines to connect to

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 19, 2023, 4:59pm UTC](https://discuss.elastic.co/t/unable-to-start-es-cluster-using-docker-compose-on-m1-mac/345406/2 "2023-10-19T16:59:03Z")

</div>

I'm wondering if you should do something like this: [Install Elasticsearch with Docker | Elasticsearch Guide [8.10] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/docker.html#_increase_ulimits_for_nofile_and_nproc)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 16, 2023, 4:59pm UTC](https://discuss.elastic.co/t/unable-to-start-es-cluster-using-docker-compose-on-m1-mac/345406/3 "2023-11-16T16:59:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
