# Unable to start ES on Ubuntu 16.04.5 LTS

**URL:** <https://discuss.elastic.co/t/unable-to-start-es-on-ubuntu-16-04-5-lts/143910>\
**Category:** Elasticsearch\
**Created:** [August 10, 2018, 4:57pm UTC](https://discuss.elastic.co/t/unable-to-start-es-on-ubuntu-16-04-5-lts/143910 "2018-08-10T16:57:54Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![mawinkattiv](https://avatars.discourse-cdn.com/v4/letter/m/eada6e/32.png) [@mawinkattiv](https://discuss.elastic.co/u/mawinkattiv)\
**Post date:** [August 10, 2018, 4:57pm UTC](https://discuss.elastic.co/t/unable-to-start-es-on-ubuntu-16-04-5-lts/143910/1 "2018-08-10T16:57:55Z")

</div>

I am trying to install Elastic Search in Ubuntu 16.04.5 LTS but getting following errors. Please help.

root@vmawinkatti:/opt/elasticsearch-6.3.2/logs# /opt/elasticsearch-6.3.2/bin/elasticsearch  
warning: ignoring JAVA\_OPTS=-Djava.io.tmpdir=/tmp; pass JVM parameters via ES\_JAVA\_OPTS  
Exception in thread "main" 2018-08-10 22:26:53,454 main ERROR No log4j2 configuration file found. Using default configuration: logging only errors to the console. Set system property 'log4j2.debug' to show Log4j2 internal initialization logging.  
SettingsException[Failed to load settings from [elasticsearch.yml]]; nested: ParsingException[Failed to parse object: expecting token of type [START\_OBJECT] but found [VALUE\_STRING]];  
at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1192)  
at org.elasticsearch.common.settings.Settings$Builder.loadFromPath(Settings.java:1165)  
at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:100)  
at org.elasticsearch.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:95)  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)  
at org.elasticsearch.cli.Command.main(Command.java:90)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86)  
Caused by: ParsingException[Failed to parse object: expecting token of type [START\_OBJECT] but found [VALUE\_STRING]]  
at org.elasticsearch.common.xcontent.XContentParserUtils.ensureExpectedToken(XContentParserUtils.java:78)  
at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:672)  
at org.elasticsearch.common.settings.Settings.access$500(Settings.java:84)  
at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1188)  
... 8 more

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 10, 2018, 8:50pm UTC](https://discuss.elastic.co/t/unable-to-start-es-on-ubuntu-16-04-5-lts/143910/2 "2018-08-10T20:50:25Z")

</div>

Please share your config file.

Please also format things using the `</>` button.

---

<div class="post-metadata">

**Author:** ![mawinkattiv](https://avatars.discourse-cdn.com/v4/letter/m/eada6e/32.png) [@mawinkattiv](https://discuss.elastic.co/u/mawinkattiv)\
**Post date:** [August 14, 2018, 2:29am UTC](https://discuss.elastic.co/t/unable-to-start-es-on-ubuntu-16-04-5-lts/143910/3 "2018-08-14T02:29:12Z")

</div>

Thanks for your reply Mark,

Please find the yml file below.

root@vmawinkatti:/opt/elasticsearch-6.3.2/config# cat /opt/elasticsearch-6.3.2/config/elasticsearch.yml

# ======================== Elasticsearch Configuration =========================

# 

# NOTE: Elasticsearch comes with reasonable defaults for most settings.

# Before you set out to tweak and tune the configuration, make sure you

# understand what are you trying to accomplish and the consequences.

# 

# The primary way of configuring a node is via this file. This template lists

# the most important settings you may want to configure for a production cluster.

# 

# Please consult the documentation for further information on configuration options:

# [https://www.elastic.co/guide/en/elasticsearch/reference/index.html](https://www.elastic.co/guide/en/elasticsearch/reference/index.html)

# 

# ---------------------------------- Cluster -----------------------------------

# 

# Use a descriptive name for your cluster:

# 

#cluster.name: my-application

# 

# ------------------------------------ Node ------------------------------------

# 

# Use a descriptive name for the node:

# 

#node.name: node-1

# 

# Add custom attributes to the node:

# 

#node.attr.rack: r1

# 

# ----------------------------------- Paths ------------------------------------

# 

# Path to directory where to store the data (separate multiple locations by comma):

# 

#path.data: /path/to/data

# 

# Path to log files:

# 

#path.logs: /path/to/logs

# 

# ----------------------------------- Memory -----------------------------------

# 

# Lock the memory on startup:

# 

#bootstrap.memory\_lock: true

# 

# Make sure that the heap size is set to about half the memory available

# on the system and that the owner of the process is allowed to use this

# limit.

# 

# Elasticsearch performs poorly when the system is swapping the memory.

# 

# ---------------------------------- Network -----------------------------------

# 

# Set the bind address to a specific IP (IPv4 or IPv6):

# 

#network.host: 192.168.0.1

# 

# Set a custom port for HTTP:

# 

#http.port: 9200

# 

# For more information, consult the network module documentation.

# 

# --------------------------------- Discovery ----------------------------------

# 

# Pass an initial list of hosts to perform discovery when new node is started:

# The default list of hosts is ["127.0.0.1", "[::1]"]

# 

#discovery.zen.ping.unicast.hosts: ["host1", "host2"]

# 

# Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):

# 

#discovery.zen.minimum\_master\_nodes:

# 

# For more information, consult the zen discovery module documentation.

# 

# ---------------------------------- Gateway -----------------------------------

# 

# Block initial recovery after a full cluster restart until N nodes are started:

# 

#gateway.recover\_after\_nodes: 3

# 

# For more information, consult the gateway module documentation.

# 

# ---------------------------------- Various -----------------------------------

# 

# Require explicit names when deleting indices:

# 

#action.destructive\_requires\_name: true  
ES\_JAVA\_OPTS="-Djna.tmpdir=/var/lib/elasticsearch/tmp"

---

<div class="post-metadata">

**Author:** ![mawinkattiv](https://avatars.discourse-cdn.com/v4/letter/m/eada6e/32.png) [@mawinkattiv](https://discuss.elastic.co/u/mawinkattiv)\
**Post date:** [August 14, 2018, 2:30am UTC](https://discuss.elastic.co/t/unable-to-start-es-on-ubuntu-16-04-5-lts/143910/4 "2018-08-14T02:30:02Z")

</div>

If I am unable to reply in the format you are looking for, please help me how can I expedite it. I'll share the details again.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 11, 2018, 2:30am UTC](https://discuss.elastic.co/t/unable-to-start-es-on-ubuntu-16-04-5-lts/143910/5 "2018-09-11T02:30:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
