# Unable to start filebeat agent

**URL:** <https://discuss.elastic.co/t/unable-to-start-filebeat-agent/142904>\
**Category:** Elasticsearch\
**Created:** [August 3, 2018, 12:12pm UTC](https://discuss.elastic.co/t/unable-to-start-filebeat-agent/142904 "2018-08-03T12:12:50Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![subbu5678](https://avatars.discourse-cdn.com/v4/letter/s/7c8e57/32.png) [@subbu5678](https://discuss.elastic.co/u/subbu5678)\
**Post date:** [August 3, 2018, 12:12pm UTC](https://discuss.elastic.co/t/unable-to-start-filebeat-agent/142904/1 "2018-08-03T12:12:50Z")

</div>

Hi team,

I am unable to start filebeat service on a centos 7 server.

Here is my filebeat.yml file

## filebeat: ~ level: Error logging: files: keepfiles: 7 name: filebeat.log path: /var/log/filebeat rotateeverybytes: 10485760 to\_files: true to\_syslog: false output: logstash: hosts: - "xxxxx" prospectors:

```
input_type: log
paths: 
  - /var/log/messages

```

registry\_file: /var/lib/filebeat/registry  
tail\_files: true

error:

● filebeat.service - filebeat  
Loaded: loaded (/usr/lib/systemd/system/filebeat.service; disabled; vendor preset: disabled)  
Active: failed (Result: start-limit) since Fri 2018-08-03 07:13:35 EDT; 1h 3min ago  
Docs: [https://www.elastic.co/guide/en/beats/filebeat/current/index.html](https://www.elastic.co/guide/en/beats/filebeat/current/index.html)  
Process: 2878 ExecStart=/usr/share/filebeat/bin/filebeat -c /etc/filebeat/filebeat.yml -path.home /usr/share/filebeat -path.config /etc/filebeat -path.data /var/lib/filebeat -path.logs /var/log/filebeat (code=exited, status=1/FAILURE)  
Main PID: 2878 (code=exited, status=1/FAILURE)

Kindly help

Thanks,  
Subbu

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 31, 2018, 12:12pm UTC](https://discuss.elastic.co/t/unable-to-start-filebeat-agent/142904/2 "2018-08-31T12:12:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
