# Unable to start FileBeat Due to Restrictions

**URL:** <https://discuss.elastic.co/t/unable-to-start-filebeat-due-to-restrictions/182650>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [May 24, 2019, 1:00pm UTC](https://discuss.elastic.co/t/unable-to-start-filebeat-due-to-restrictions/182650 "2019-05-24T13:00:35Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![premkumar](https://avatars.discourse-cdn.com/v4/letter/p/e99b99/32.png) [@premkumar](https://discuss.elastic.co/u/premkumar)\
**Post date:** [May 24, 2019, 1:00pm UTC](https://discuss.elastic.co/t/unable-to-start-filebeat-due-to-restrictions/182650/1 "2019-05-24T13:00:35Z")

</div>

Hi Team,

I have been trying to start the file beat but getting the following error while starting.

Exiting: error loading config file: config file ("filebeat.yml") can only be writable by the owner but the permissions are "-rwxrwx---" (to fix the permissions use: 'chmod go-w /home/dev/Desktop/filebeat-7.1.0-linux-x86\_64.tar/filebeat-7.1.0-linux-x86\_64/filebeat.yml')

Please find the access for the file  
[dev@devlinux filebeat-7.1.0-linux-x86\_64]$ ls -al filebeat.yml  
-rwxrwx--- 1 dev dev 7779 May 24 07:20 filebeat.yml

Please help in starting the file beat.

---

<div class="post-metadata">

**Author:** ![BennyInc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bennyinc/32/21751_2.png) [@BennyInc](https://discuss.elastic.co/u/BennyInc)\
**Post date:** [May 24, 2019, 1:04pm UTC](https://discuss.elastic.co/t/unable-to-start-filebeat-due-to-restrictions/182650/2 "2019-05-24T13:04:30Z")

</div>

Did you try the chmod like the error permission suggested?  
The dev group currently has write permission on filebeat.yml, which filebeat doesn't allow.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 21, 2019, 1:15pm UTC](https://discuss.elastic.co/t/unable-to-start-filebeat-due-to-restrictions/182650/3 "2019-06-21T13:15:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
