# Unable to start Kibana after upgrade to 8.17.0

**URL:** https://discuss.elastic.co/t/unable-to-start-kibana-after-upgrade-to-8-17-0/373015
**Category:** Elastic Security
**Created:** [January 9, 2025, 3:57pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-after-upgrade-to-8-17-0/373015 "2025-01-09T15:57:20Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![jheaton](https://avatars.discourse-cdn.com/v4/letter/j/ecc23a/32.png) [@jheaton](https://discuss.elastic.co/u/jheaton)
#### Post date: [January 9, 2025, 3:57pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-after-upgrade-to-8-17-0/373015/1 "2025-01-09T15:57:20Z")

</div>

Following an upgrade of Kibana the Kibana service keeps shutting down and restarting and the web interface is unavailable.

The current issue appears to be permission related on an index called ".kibana\_task\_manager\_8.7.1\_001". The index is write blocked.

Trying to update the index to remove the write block results in "action [indices:admin/settings/update] is unauthorized for user [elastic] with effective roles [superuser] on restricted indices [.kibana\_task\_manager\_8.7.1\_001], this action is granted by the index privileges [manage,all]"

The query I have ran:  
Query:

```auto
curl -u "elastic:xxxxxxxxx" -k -X PUT "https://172.16.1.90:9200/.kibana_task_manager_8.7.1_001/_settings?pretty" -H 'Content-Type: application/json' -d'
{
 "index": {
  "blocks": {
   "write" : false
   }
  }
}
'

```

result:

```auto
{
  "error" : {
    "root_cause" : [
      {
        "type" : "security_exception",
        "reason" : "action [indices:admin/settings/update] is unauthorized for user [elastic] with effective roles [superuser] on restricted indices [.kibana_task_manager_8.7.1_001], this action is granted by the index privileges [manage,all]"
      }
    ],
    "type" : "security_exception",
    "reason" : "action [indices:admin/settings/update] is unauthorized for user [elastic] with effective roles [superuser] on restricted indices [.kibana_task_manager_8.7.1_001], this action is granted by the index privileges [manage,all]"
  },
  "status" : 403
}

```

Can anyone show me how I can add the appropriate permissions to the appropriate role or an alternative way to fix the write block please?

Cheers

---

<div class="post-metadata">

### Author: ![jheaton](https://avatars.discourse-cdn.com/v4/letter/j/ecc23a/32.png) [@jheaton](https://discuss.elastic.co/u/jheaton)
#### Post date: [January 9, 2025, 4:44pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-after-upgrade-to-8-17-0/373015/2 "2025-01-09T16:44:03Z")

</div>

Kibana logs (with debug):

```auto
{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.11.0"},"@timestamp":"2025-01-09T16:28:16.785+00:00","message":"[.kibana_task_manager] TRANSFORMED_DOCUMENTS_BULK_INDEX RESPONSE","log":{"level":"DEBUG","logger":"savedobjects-service"},"process":{"pid":344,"uptime":20.1497312},"trace":{"id":"daecd25631a45a70d4d92883df53e1f0"},"transaction":{"id":"c47c0154e6b9d61d"}}
{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.11.0"},"@timestamp":"2025-01-09T16:28:16.786+00:00","message":"TRANSFORMED_DOCUMENTS_BULK_INDEX received unexpected action response: {\"type\":\"target_index_had_write_block\"}","error":{"message":"TRANSFORMED_DOCUMENTS_BULK_INDEX received unexpected action response: {\"type\":\"target_index_had_write_block\"}","type":"Error","stack_trace":"Error: TRANSFORMED_DOCUMENTS_BULK_INDEX received unexpected action response: {\"type\":\"target_index_had_write_block\"}\n at throwBadResponse (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-migration-server-internal\\src\\model\\helpers.js:56:9)\n at model (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-migration-server-internal\\src\\model\\model.js:1337:39)\n at E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-migration-server-internal\\src\\migrations_state_action_machine.js:52:24\n at stateActionMachine (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-migration-server-internal\\src\\state_action_machine.js:68:22)\n at processTicksAndRejections (node:internal/process/task_queues:95:5)\n at migrationStateActionMachine (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-migration-server-internal\\src\\migrations_state_action_machine.js:48:24)\n at async Promise.all (index 2)\n at SavedObjectsService.start (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-server-internal\\src\\saved_objects_service.js:199:7)\n at Server.start (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-root-server-internal\\src\\server.js:393:31)\n at Root.start (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-root-server-internal\\src\\root\\index.js:66:14)\n at bootstrap (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-root-server-internal\\src\\bootstrap.js:119:5)\n at Command.<anonymous> (E:\\apps\\kibana\\kibana-8.17.0\\src\\cli\\serve\\serve.js:234:5)"},"log":{"level":"ERROR","logger":"savedobjects-service"},"process":{"pid":344,"uptime":20.1531979},"trace":{"id":"daecd25631a45a70d4d92883df53e1f0"},"transaction":{"id":"c47c0154e6b9d61d"}}
{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.11.0"},"@timestamp":"2025-01-09T16:28:16.789+00:00","message":"Kibana is shutting down","log":{"level":"INFO","logger":"root"},"process":{"pid":344,"uptime":20.1536065},"trace":{"id":"daecd25631a45a70d4d92883df53e1f0"},"transaction":{"id":"c47c0154e6b9d61d"}}
{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.11.0"},"@timestamp":"2025-01-09T16:28:16.790+00:00","message":"Reason: Unable to complete saved object migrations for the [.kibana_task_manager] index. Error: TRANSFORMED_DOCUMENTS_BULK_INDEX received unexpected action response: {\"type\":\"target_index_had_write_block\"}\n[Error: TRANSFORMED_DOCUMENTS_BULK_INDEX received unexpected action response: {\"type\":\"target_index_had_write_block\"}\n at throwBadResponse (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-migration-server-internal\\src\\model\\helpers.js:56:9)\n at model (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-migration-server-internal\\src\\model\\model.js:1337:39)\n at E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-migration-server-internal\\src\\migrations_state_action_machine.js:52:24\n at stateActionMachine (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-migration-server-internal\\src\\state_action_machine.js:68:22)\n at processTicksAndRejections (node:internal/process/task_queues:95:5)\n at migrationStateActionMachine (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-migration-server-internal\\src\\migrations_state_action_machine.js:48:24)\n at async Promise.all (index 2)\n at SavedObjectsService.start (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-saved-objects-server-internal\\src\\saved_objects_service.js:199:7)\n at Server.start (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-root-server-internal\\src\\server.js:393:31)\n at Root.start (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-root-server-internal\\src\\root\\index.js:66:14)\n at bootstrap (E:\\apps\\kibana\\kibana-8.17.0\\node_modules\\@kbn\\core-root-server-internal\\src\\bootstrap.js:119:5)\n at Command.<anonymous> (E:\\apps\\kibana\\kibana-8.17.0\\src\\cli\\serve\\serve.js:234:5)]","log":{"level":"FATAL","logger":"root"},"process":{"pid":344,"uptime":20.1545131},"trace":{"id":"daecd25631a45a70d4d92883df53e1f0"},"transaction":{"id":"c47c0154e6b9d61d"}}
{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.11.0"},"@timestamp":"2025-01-09T16:28:16.791+00:00","message":"stopping server","log":{"level":"DEBUG","logger":"server"},"process":{"pid":344,"uptime":20.1547631},"trace":{"id":"daecd25631a45a70d4d92883df53e1f0"},"transaction":{"id":"c47c0154e6b9d61d"}}
{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.11.0"},"@timestamp":"2025-01-09T16:28:16.792+00:00","message":"stopping http server","log":{"lev

```

---

<div class="post-metadata">

### Author: ![Maxim\_Palenov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/maxim_palenov/32/122504_2.png) [@Maxim\_Palenov](https://discuss.elastic.co/u/Maxim_Palenov)
#### Post date: [January 9, 2025, 4:50pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-after-upgrade-to-8-17-0/373015/3 "2025-01-09T16:50:42Z")

</div>

Hi @jheaton ,

Did you follow [Upgrade Kibana](https://www.elastic.co/guide/en/kibana/current/upgrade.html) documentation recommendations?

From what version are you upgrading?

---

<div class="post-metadata">

### Author: ![jheaton](https://avatars.discourse-cdn.com/v4/letter/j/ecc23a/32.png) [@jheaton](https://discuss.elastic.co/u/jheaton)
#### Post date: [January 10, 2025, 9:47am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-after-upgrade-to-8-17-0/373015/4 "2025-01-10T09:47:46Z")

</div>

I upgraded from 8.13.4.

I did not perform a snapshot as I don't have the space.

The cluster was a healthy green.

---

<div class="post-metadata">

### Author: ![jheaton](https://avatars.discourse-cdn.com/v4/letter/j/ecc23a/32.png) [@jheaton](https://discuss.elastic.co/u/jheaton)
#### Post date: [January 10, 2025, 3:11pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-after-upgrade-to-8-17-0/373015/5 "2025-01-10T15:11:52Z")

</div>

Hi @Maxim_Palenov

Thanks for your help. From the link you provided I was led to this page:  
[https://www.elastic.co/guide/en/kibana/current/resolve-migrations-failures.html](https://www.elastic.co/guide/en/kibana/current/resolve-migrations-failures.html)

Which detailed how to add a a role to grant access to the kibana indices (step 1), create a temp superuser with the new role added (step 2) . I was then able to reset the write block on all the indices that had them following (step 3). I did not have to delete anything (step4).

On initial restart of the kibana service the login page came up but would not allow any user to log in. I stopped the kibana service to amend the logging from debug back to info and when I restarted it I was able to log in and access everything as normal. The cluster status was initially red but went to green after approx 5 mins.

The issue is now resolved.

Cheers!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 7, 2025, 3:12pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-after-upgrade-to-8-17-0/373015/6 "2025-02-07T15:12:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
