# Unable to start kibana in a cluster

**URL:** <https://discuss.elastic.co/t/unable-to-start-kibana-in-a-cluster/249245>\
**Category:** Kibana\
**Created:** [September 20, 2020, 9:22am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-in-a-cluster/249245 "2020-09-20T09:22:50Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Gauti](https://avatars.discourse-cdn.com/v4/letter/g/cdc98d/32.png) [@Gauti](https://discuss.elastic.co/u/Gauti)\
**Post date:** [September 20, 2020, 9:22am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-in-a-cluster/249245/1 "2020-09-20T09:22:50Z")

</div>

Hi All,

I have installed elasticsearch version 7.6.4 have installed and configured all the settings and started elasticsearch service and was able to start the service, i have verified it by logging in to console also  
clustser : 2 nodes  
url : [https://dnsname:9200](https://dnsname:9200)

When i start kibana service it says service started, but when i try to login to console i'm not getting the login screen at all, while checking kibana logs it says no living connection

I tried with [http://dnsname:5601](http://dnsname:5601) and also [http://dnsname:5601](http://dnsname:5601)  
both didnt work.

Any advice where i'm makaing mistake?

Thanks  
Gautham

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 20, 2020, 9:19pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-in-a-cluster/249245/2 "2020-09-20T21:19:39Z")

</div>

Can you post the actual error you are seeing?  
Is there anything in the browser dev tools console?

---

<div class="post-metadata">

**Author:** ![Gauti](https://avatars.discourse-cdn.com/v4/letter/g/cdc98d/32.png) [@Gauti](https://discuss.elastic.co/u/Gauti)\
**Post date:** [September 21, 2020, 12:53pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-in-a-cluster/249245/4 "2020-09-21T12:53:06Z")

</div>

@warkolm Here is the log file, and this issue have started after i enabled TLS/SSL for elasticsearch cluster.

```
"@timestamp":"2020-09-21T12:49:01Z","tags":["warning","elasticsearch","admin"],"pid":31533,"message":"No living connections"}
    "@timestamp":"2020-09-21T12:49:03Z","tags":["warning","elasticsearch","admin"],"pid":31533,"message":"Unable to revive connection: https://1.5.5.2:9200/"}
    "@timestamp":"2020-09-21T12:49:03Z","tags":["warning","elasticsearch","admin"],"pid":31533,"message":"Unable to revive connection: https://1.5.5.3:9200/"}
    "@timestamp":"2020-09-21T12:49:03Z","tags":["warning","elasticsearch","admin"],"pid":31533,"message":"No living connections"}
    "@timestamp":"2020-09-21T12:49:06Z","tags":["warning","elasticsearch","admin"],"pid":31533,"message":"Unable to revive connection: https://1.5.5.2:9200/"}
    "@timestamp":"2020-09-21T12:49:06Z","tags":["warning","elasticsearch","admin"],"pid":31533,"message":"Unable to revive connection: https://1.5.5.3:9200/"}
    "@timestamp":"2020-09-21T12:49:06Z","tags":["warning","elasticsearch","admin"],"pid":31533,"message":"No living connections"}

```

Thanks  
Gautham

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 21, 2020, 8:39pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-in-a-cluster/249245/5 "2020-09-21T20:39:04Z")

</div>

> [@Gauti](#):
>
> `https://1.5.5.3:9200`

Can you curl your Elasticsearch at that URL?

---

<div class="post-metadata">

**Author:** ![Gauti](https://avatars.discourse-cdn.com/v4/letter/g/cdc98d/32.png) [@Gauti](https://discuss.elastic.co/u/Gauti)\
**Post date:** [September 22, 2020, 4:31am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-in-a-cluster/249245/6 "2020-09-22T04:31:35Z")

</div>

@warkolm  
While running curl i'm getting an error

```
 curl --cacert /etc/elasticsearch/certs/elastic-stack-ca.p12 -u elastic:password https://1.5.5.3:9200
curl: (77) Problem with the SSL CA cert (path? access rights?)

```

Below is the file permission

```
 ll | grep elastic-stack
-rwxr-xr-x 1 root elasticsearch 2527 Sep 20 19:15 elastic-stack-ca.p12

```

Not sure where i'm missing.

Thanks  
Gautham

---

<div class="post-metadata">

**Author:** ![Gauti](https://avatars.discourse-cdn.com/v4/letter/g/cdc98d/32.png) [@Gauti](https://discuss.elastic.co/u/Gauti)\
**Post date:** [September 24, 2020, 3:54am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-in-a-cluster/249245/7 "2020-09-24T03:54:21Z")

</div>

Got this resolved, all you need to do is follow the documents properly. I had misplaced the certificates.

FYI : [https://www.elastic.co/blog/elasticsearch-security-configure-tls-ssl-pki-authentication](https://www.elastic.co/blog/elasticsearch-security-configure-tls-ssl-pki-authentication)

Thanks  
Gautham

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 22, 2020, 3:54am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-in-a-cluster/249245/8 "2020-10-22T03:54:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
