# Unable to start kibana: Request timeout

**URL:** <https://discuss.elastic.co/t/unable-to-start-kibana-request-timeout/213288>\
**Category:** Kibana\
**Created:** [December 29, 2019, 3:50pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-request-timeout/213288 "2019-12-29T15:50:02Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ajay\_Verma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ajay_verma/32/60057_2.png) [@Ajay\_Verma](https://discuss.elastic.co/u/Ajay_Verma)\
**Post date:** [December 29, 2019, 3:50pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-request-timeout/213288/1 "2019-12-29T15:50:02Z")

</div>

I am unabel to start kibana on my windows 10 using CMD. I was following the installation steps and as per the step i had to use the kibana.bat file to start kibana but it is throwing me an error unable to connect elastic search. Error: Time out after 300ms

logs:  
log [15:47:39.418] [info][plugins-system] Setting up [15] plugins: [licensing,security,code,timelion,features,spaces,translations,inspector,newsfeed,uiActions,embeddable,advancedUiActions,expressions,data,eui\_utils]  
log [15:47:39.425] [info][licensing][plugins] Setting up plugin  
log [15:47:39.428] [info][plugins][security] Setting up plugin  
log [15:47:39.429] [warning][config][plugins][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml  
log [15:47:39.430] [warning][config][plugins][security] Session cookies will be transmitted over insecure connections. This is not recommended.  
log [15:47:39.438] [info][code][plugins] Setting up plugin  
log [15:47:39.439] [info][plugins][timelion] Setting up plugin  
log [15:47:39.440] [info][features][plugins] Setting up plugin  
log [15:47:39.441] [info][plugins][spaces] Setting up plugin  
log [15:47:39.445] [info][plugins][translations] Setting up plugin  
log [15:47:39.446] [info][data][plugins] Setting up plugin  
log [15:47:51.362] [warning][legacy-plugins] Skipping non-plugin directory at D:\Softwares\kibana-7.5.1-windows-x86\_64\kibana-7.5.1-windows-x86\_64\src\legacy\core\_plugins\visualizations  
log [15:47:52.912] [info][plugins-system] Starting [8] plugins: [licensing,security,code,timelion,features,spaces,translations,data]  
log [15:47:52.921] [info][licensing][plugins] Imported changed license information from Elasticsearch for the [data] cluster: type: basic | status: active  
log [15:47:52.931] [info][migrations] Creating index .kibana\_task\_manager\_1.  
log [15:47:52.935] [info][migrations] Creating index .kibana\_1.  
log [15:48:22.934] [warning][migrations] Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms

---

<div class="post-metadata">

**Author:** ![mancharagopan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mancharagopan/32/60266_2.png) [@mancharagopan](https://discuss.elastic.co/u/mancharagopan)\
**Post date:** [December 30, 2019, 2:28am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-request-timeout/213288/2 "2019-12-30T02:28:44Z")

</div>

Where is your elasticsearch installed? same machine or different?

---

<div class="post-metadata">

**Author:** ![Ajay\_Verma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ajay_verma/32/60057_2.png) [@Ajay\_Verma](https://discuss.elastic.co/u/Ajay_Verma)\
**Post date:** [December 30, 2019, 3:42am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-request-timeout/213288/3 "2019-12-30T03:42:54Z")

</div>

Same machine

---

<div class="post-metadata">

**Author:** ![mancharagopan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mancharagopan/32/60266_2.png) [@mancharagopan](https://discuss.elastic.co/u/mancharagopan)\
**Post date:** [December 30, 2019, 7:11am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-request-timeout/213288/4 "2019-12-30T07:11:25Z")

</div>

Can you share your Kibana configuration and Elasticsearch configuration?

---

<div class="post-metadata">

**Author:** ![mverbeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mverbeek/32/101709_2.png) [@mverbeek](https://discuss.elastic.co/u/mverbeek)\
**Post date:** [December 30, 2019, 7:52am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-request-timeout/213288/5 "2019-12-30T07:52:53Z")

</div>

It looks like there is something wrong with your Elasticsearch, make sure its instance is running and check that the 'elasticsearch.host' in Kibana is correct.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 27, 2020, 7:52am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-request-timeout/213288/6 "2020-01-27T07:52:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
