# Unable to start kibana server\[6.4.2\] using yarn in development mode

**URL:** <https://discuss.elastic.co/t/unable-to-start-kibana-server-6-4-2-using-yarn-in-development-mode/161130>\
**Category:** Kibana\
**Created:** [December 17, 2018, 11:45am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-server-6-4-2-using-yarn-in-development-mode/161130 "2018-12-17T11:45:22Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![mandritac](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mandritac/32/38996_2.png) [@mandritac](https://discuss.elastic.co/u/mandritac)\
**Post date:** [December 17, 2018, 11:45am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-server-6-4-2-using-yarn-in-development-mode/161130/1 "2018-12-17T11:45:23Z")

</div>

Hi,

I have followed documentation - to setup kibana development environment for creating custom plugin. However the server crashes due to following error -  
[oracle@obdcnode7 kibana] yarn start yarn run v1.10.1 sh ./bin/kibana --dev  
watching for changes (1740 files)  
log [11:25:40.913] [info][server] starting basepath proxy server at [http://172.18.27.86:5601/ywz](http://172.18.27.86:5601/ywz)  
server log [11:25:47.641] [info][status][plugin:kibana@6.4.4] Status changed from uninitialized to green - Ready  
server log [11:25:47.672] [info][status][plugin:elasticsearch@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:47.675] [info][status][plugin:xpack\_main@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:47.680] [info][status][plugin:searchprofiler@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:47.683] [info][status][plugin:ml@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:47.735] [info][status][plugin:tilemap@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:47.738] [info][status][plugin:watcher@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:47.753] [info][status][plugin:license\_management@6.4.4] Status changed from uninitialized to green - Ready  
server log [11:25:47.756] [info][status][plugin:index\_management@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:49.038] [info][status][plugin:timelion@6.4.4] Status changed from uninitialized to green - Ready  
server log [11:25:49.040] [info][status][plugin:graph@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:49.050] [info][status][plugin:monitoring@6.4.4] Status changed from uninitialized to green - Ready  
server log [11:25:49.058] [warning][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml  
server log [11:25:49.061] [warning][security] Session cookies will be transmitted over insecure connections. This is not recommended.  
server log [11:25:49.069] [info][status][plugin:security@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:49.091] [info][status][plugin:grokdebugger@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:49.095] [info][status][plugin:dashboard\_mode@6.4.4] Status changed from uninitialized to green - Ready  
server log [11:25:49.097] [info][status][plugin:logstash@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:49.113] [info][status][plugin:apm@6.4.4] Status changed from uninitialized to green - Ready  
server log [11:25:49.119] [info][status][plugin:console@6.4.4] Status changed from uninitialized to green - Ready  
server log [11:25:49.121] [info][status][plugin:console\_extensions@6.4.4] Status changed from uninitialized to green - Ready  
server log [11:25:49.126] [info][status][plugin:notifications@6.4.4] Status changed from uninitialized to green - Ready  
server log [11:25:49.129] [info][status][plugin:metrics@6.4.4] Status changed from uninitialized to green - Ready  
server log [11:25:49.848] [warning][reporting] Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart, please set xpack.reporting.encryptionKey in kibana.yml  
server log [11:25:49.850] [info][status][plugin:reporting@6.4.4] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
server log [11:25:49.868] [warning] You're running Kibana 6.4.4 with some different versions of Elasticsearch. Update Kibana or Elasticsearch to the same version to prevent compatibility issues: v6.4.2 @ 172.18.27.101:9200 (172.18.27.101)  
server log [11:25:49.877] [info][status][plugin:elasticsearch@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.912] [info][license][xpack] Imported license information from Elasticsearch for the [data] cluster: mode: basic | status: active  
server log [11:25:49.915] [info][status][plugin:xpack\_main@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.916] [info][status][plugin:searchprofiler@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.916] [info][status][plugin:ml@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.917] [info][status][plugin:tilemap@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.917] [info][status][plugin:watcher@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.918] [info][status][plugin:index\_management@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.918] [info][status][plugin:graph@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.919] [info][status][plugin:grokdebugger@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.920] [info][status][plugin:logstash@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.920] [info][status][plugin:reporting@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.921] [info][kibana-monitoring][monitoring-ui] Starting monitoring stats collection  
server log [11:25:49.924] [info][status][plugin:security@6.4.4] Status changed from yellow to green - Ready  
server log [11:25:49.962] [info][license][xpack] Imported license information from Elasticsearch for the [monitoring] cluster: mode: basic | status: active  
server error [11:25:50.754] [fatal] Error: self signed certificate in certificate chain  
at TLSSocket. (\_tls\_wrap.js:1105:38)  
at emitNone (events.js:106:13)  
at TLSSocket.emit (events.js:208:7)  
at TLSSocket.\_finishInit (\_tls\_wrap.js:639:8)  
at TLSWrap.ssl.onhandshakedone (\_tls\_wrap.js:469:38)  
FATAL { Error: self signed certificate in certificate chain  
at TLSSocket. (\_tls\_wrap.js:1105:38)  
at emitNone (events.js:106:13)  
at TLSSocket.emit (events.js:208:7)  
at TLSSocket.\_finishInit (\_tls\_wrap.js:639:8)  
at TLSWrap.ssl.onhandshakedone (\_tls\_wrap.js:469:38) code: 'SELF\_SIGNED\_CERT\_IN\_CHAIN' }  
server crashed with status code 1  
optmzr log [11:26:28.841] [info][optimize] Optimization success in 41.60 seconds  
optmzr log [11:26:35.207] [info][optimize] Optimization success in 5.21 seconds

As a result I am not able to connect to kibana UI.  
Environment - Redhat Linux 7  
Yarn - 1.10.1  
Node - 8.11.4

Thanks.

---

<div class="post-metadata">

**Author:** ![mandritac](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mandritac/32/38996_2.png) [@mandritac](https://discuss.elastic.co/u/mandritac)\
**Post date:** [December 20, 2018, 7:03am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-server-6-4-2-using-yarn-in-development-mode/161130/2 "2018-12-20T07:03:56Z")

</div>

Any help on this anybody?

Thanks.

---

<div class="post-metadata">

**Author:** ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)\
**Post date:** [December 20, 2018, 1:25pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-server-6-4-2-using-yarn-in-development-mode/161130/3 "2018-12-20T13:25:46Z")

</div>

Looks like an error from the TLS certificate. But for development you can just disable SSL and security so that you don't have to create a new certificate.

---

<div class="post-metadata">

**Author:** ![mandritac](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mandritac/32/38996_2.png) [@mandritac](https://discuss.elastic.co/u/mandritac)\
**Post date:** [December 20, 2018, 1:55pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-server-6-4-2-using-yarn-in-development-mode/161130/4 "2018-12-20T13:55:07Z")

</div>

I am able to start the server using yarn start -oss flag. Is there any other option to disable ssl?  
Also how can we resolve this issue?

Thanks.

---

<div class="post-metadata">

**Author:** ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)\
**Post date:** [December 24, 2018, 8:24am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-server-6-4-2-using-yarn-in-development-mode/161130/5 "2018-12-24T08:24:58Z")

</div>

By default there shouldn't be any certificate setting, but you can use `yarn start --ssl` in order to use Kibana's self-signed certificate and this should remove any errors. Otherwise, just check if you have modifications done in the `config/kibana.dev.yml` file.

---

<div class="post-metadata">

**Author:** ![mandritac](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mandritac/32/38996_2.png) [@mandritac](https://discuss.elastic.co/u/mandritac)\
**Post date:** [December 24, 2018, 9:04am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-server-6-4-2-using-yarn-in-development-mode/161130/6 "2018-12-24T09:04:38Z")

</div>

Hi,

I tried starting kibana using -ssl flag but server crashed with error -  
server error [08:57:52.128] [fatal] Error: getaddrinfo ENOTFOUND [github.com](http://github.com) [github.com:443](http://github.com:443)  
at errnoException (dns.js:50:10)  
at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:92:26)  
FATAL { Error: getaddrinfo ENOTFOUND [github.com](http://github.com) [github.com:443](http://github.com:443)

I got this same error when yarn tried installing geckodriver.Also my installation doesn't contain any kibana.dev.yml file but contains only kibana.yml file which have not being modified with any ssl related setting.

Thanks.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 21, 2019, 9:04am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-server-6-4-2-using-yarn-in-development-mode/161130/7 "2019-01-21T09:04:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
