# Unable to start kibana.service

**URL:** <https://discuss.elastic.co/t/unable-to-start-kibana-service/207489>\
**Category:** Kibana\
**Created:** [November 12, 2019, 10:34am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-service/207489 "2019-11-12T10:34:52Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Praveen\_Yallala](https://avatars.discourse-cdn.com/v4/letter/p/bb73d2/32.png) [@Praveen\_Yallala](https://discuss.elastic.co/u/Praveen_Yallala)\
**Post date:** [November 12, 2019, 10:34am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-service/207489/1 "2019-11-12T10:34:52Z")

</div>

I have installed Kibana and elastic search in Linux (RHEL). I am able to run both kibana and elastic search manually. I want to start the service. Unfortunately, I am unable to find kibana.service file anywhere. I have tried to create kibana.service file and start it. But, I am not able to do.

Below it the error msg I get

● kibana.service - Kibana  
Loaded: loaded (/etc/systemd/system/kibana.service; disabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Tue 2019-11-12 11:17:32 CET; 6min ago  
Docs: [https://www.elastic.co/guide](https://www.elastic.co/guide)  
Process: 12822 ExecStart=/opt/ELK\_Stack/Kibana/kibana-6.8.0/bin/kibana -c /etc/kibana/kibana.yml (code=exited, status=1/FAILURE)  
Main PID: 12822 (code=exited, status=1/FAILURE)

Nov 12 11:17:30 \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* systemd[1]: Started Kibana.  
Nov 12 11:17:32 \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE  
Nov 12 11:17:32 \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* systemd[1]: Unit kibana.service entered failed state.  
Nov 12 11:17:32 \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* systemd[1]: kibana.service failed.

Kibana.service

# 

# Kibana systemd service

# 

[Unit]  
Description=Kibana  
Documentation=https://www.elastic.co/guide  
After=network.target

[Service]  
Type=simple  
EnvironmentFile= /etc/default/kibana  
User=kibana  
Group=kibana  
ExecStart= /opt/ELK\_Stack/Kibana/kibana-6.8.0/bin/kibana "-c /etc/kibana/kibana.yml"

[Install]  
WantedBy=multi-user.target

Kindly help me in this.

---

<div class="post-metadata">

**Author:** ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)\
**Post date:** [November 18, 2019, 8:21pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-service/207489/2 "2019-11-18T20:21:19Z")

</div>

The service file should be created directly by the RPM distro of Kibana. [https://www.elastic.co/guide/en/kibana/current/rpm.html](https://www.elastic.co/guide/en/kibana/current/rpm.html)  
Did you use that or did you use the tar.gz distros?

---

<div class="post-metadata">

**Author:** ![Praveen\_Yallala](https://avatars.discourse-cdn.com/v4/letter/p/bb73d2/32.png) [@Praveen\_Yallala](https://discuss.elastic.co/u/Praveen_Yallala)\
**Post date:** [November 19, 2019, 5:03am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-service/207489/3 "2019-11-19T05:03:23Z")

</div>

Earlier I have used tar.gz. Later on I have uninstalled everything tried installing using RPM. Now service file is created automatically.

Now I have another issue. I have got SSL certificates. I want to configure it. Could you please guide how to do it. Kibana is installed in Linux RHEL 7.

Thanks in advance

---

<div class="post-metadata">

**Author:** ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)\
**Post date:** [November 19, 2019, 5:05am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-service/207489/4 "2019-11-19T05:05:01Z")

</div>

You can follow these guides for that:  
[https://www.elastic.co/guide/en/kibana/current/configuring-tls.html](https://www.elastic.co/guide/en/kibana/current/configuring-tls.html)

> **[Configuring SSL, TLS, and HTTPS to secure Elasticsearch, Kibana, Beats, and...](https://www.elastic.co/blog/configuring-ssl-tls-and-https-to-secure-elasticsearch-kibana-beats-and-logstash)**
>
> Feeling insecure about your Elastic Stack security? Run through these step-by-step instructions for setting up TLS encryption and https on Elasticsearch, Kibana, Logstash, and Beats to shore up your stack's defenses. Highly recommended for end-to-end...

The blog post is the more detailed one.

---

<div class="post-metadata">

**Author:** ![Praveen\_Yallala](https://avatars.discourse-cdn.com/v4/letter/p/bb73d2/32.png) [@Praveen\_Yallala](https://discuss.elastic.co/u/Praveen_Yallala)\
**Post date:** [November 19, 2019, 5:21am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-service/207489/5 "2019-11-19T05:21:44Z")

</div>

Thanks for the help Marius. I have got SSL certificate using Servers Host name. Can I use the same certificate for both Elasticsearch and Kibana?

---

<div class="post-metadata">

**Author:** ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)\
**Post date:** [November 19, 2019, 12:19pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana-service/207489/6 "2019-11-19T12:19:43Z")

</div>

if they are both hosted on the same server, yes.

---

<div class="post-metadata">

**Author:** ![Praveen\_Yallala](https://avatars.discourse-cdn.com/v4/letter/p/bb73d2/32.png) [@Praveen\_Yallala](https://discuss.elastic.co/u/Praveen_Yallala)\
**Post date:** [November 21, 2019, 9:14am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-service/207489/7 "2019-11-21T09:14:45Z")

</div>

Hi Marius. Thank you for helping me out. I could add SSL certificate to Kibana and it is working. I am trying the same for elasticsearch. The guide says about enabling xpack sevurity. But, I could not see xpack settings in elasticsearch.yml file. Kindly suggest me in this regard.

I have installed elasticsearch 6.8.4 in Linux RHEL using RPM.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 19, 2019, 9:14am UTC](https://discuss.elastic.co/t/unable-to-start-kibana-service/207489/8 "2019-12-19T09:14:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
