# Unable to start Kibana

**URL:** https://discuss.elastic.co/t/unable-to-start-kibana/46093
**Category:** Kibana
**Created:** [April 1, 2016, 8:05pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana/46093 "2016-04-01T20:05:06Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![boreal](https://avatars.discourse-cdn.com/v4/letter/b/cab0a1/32.png) [@boreal](https://discuss.elastic.co/u/boreal)
#### Post date: [April 1, 2016, 8:05pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana/46093/1 "2016-04-01T20:05:06Z")

</div>

Hi,  
I have Kibana 4.4. Today, I installed most of the Kibana plugins from this site:

> **[elastic/kibana](https://github.com/elastic/kibana/wiki/Known-Plugins)**
>
> kibana - :bar\_chart: Kibana analytics and search dashboard for Elasticsearch

However, I have not been able to start Kibana since. I removed Timeline and Sankey from Kibana but that didn't help. Here are the lines from the log. Anyone knows why this is happening? Thanks!!

{"type":"log","@timestamp":"2016-04-01T19:55:50+00:00","tags":["info","optimize"],"pid":5290,"message":"Optimizing and caching bundles for kibana and statusPage. This may take a few minutes"}  
{"type":"log","@timestamp":"2016-04-01T19:56:46+00:00","tags":["fatal"],"pid":5290,"level":"fatal","message":"EACCES, open '/opt/kibana/optimize/bundles/3.3.bundle.js'","error":{"message":"EACCES, open '/opt/kibana/optimize/bundles/3.3.bundle.js'","name":"Error","stack":"Error: EACCES, open '/opt/kibana/optimize/bundles/3.3.bundle.js'\n at Error (native)","code":"EACCES"}}

---

<div class="post-metadata">

### Author: ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)
#### Post date: [April 1, 2016, 8:13pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana/46093/2 "2016-04-01T20:13:27Z")

</div>

Have you checked the file permissions? I would also recommend installing the plugins as you need them.

---

<div class="post-metadata">

### Author: ![boreal](https://avatars.discourse-cdn.com/v4/letter/b/cab0a1/32.png) [@boreal](https://discuss.elastic.co/u/boreal)
#### Post date: [April 1, 2016, 11:24pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana/46093/3 "2016-04-01T23:24:10Z")

</div>

Thanks Tyler, I modified the permission on the "kibana" user and Kibana is up now. Not sure why this wasn't an issue before.

However, now I'm getting this error on elasticsearch  
[2016-04-01 18:12:36,119][INFO][rest.suppressed] /myindex/cols/\_count Params: {}  
ElasticsearchSecurityException[unable to authenticate user [myuser] for REST request [/myindex/cols/\_count]]

I am using Shield and authentication was working fine until now. I removed the user, added it back, but still can no longer access this particular node via CURL. Other node is working fine with same user/password. Can Kibana issue cause this? Thanks a lot!

---

<div class="post-metadata">

### Author: ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)
#### Post date: [April 2, 2016, 1:11am UTC](https://discuss.elastic.co/t/unable-to-start-kibana/46093/4 "2016-04-02T01:11:21Z")

</div>

What version of Kibana are you upgrading from? Did you also upgrade ElasticSearch? If so from what version did you upgrade to?

---

<div class="post-metadata">

### Author: ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)
#### Post date: [April 2, 2016, 1:15am UTC](https://discuss.elastic.co/t/unable-to-start-kibana/46093/5 "2016-04-02T01:15:51Z")

</div>

It sounds like this issue might happen if plugins are installed before Kibana has successfully been started for the first time.

Try this:

`chown kibana:kibana /opt/kibana/optimize/.babelcache.json`

---

<div class="post-metadata">

### Author: ![boreal](https://avatars.discourse-cdn.com/v4/letter/b/cab0a1/32.png) [@boreal](https://discuss.elastic.co/u/boreal)
#### Post date: [April 2, 2016, 2:58am UTC](https://discuss.elastic.co/t/unable-to-start-kibana/46093/6 "2016-04-02T02:58:55Z")

</div>

Thanks Tyler,  
I am using 4.4, I didn't upgrade. I just wanted to install those plugins and tried to restart kibana after installing them. Yes, chown kibana:kibana on entire "opt" folder helped with the initial issue but now I am suddenly facing auth issue with elasticsearch. The node has been running for a month with basic auth without any problem until today. I'm not sure if kibana problem will break it.

I am thinking to just launch another node and shut down this one though.

Thanks!  
B

---

<div class="post-metadata">

### Author: ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)
#### Post date: [April 2, 2016, 5:56am UTC](https://discuss.elastic.co/t/unable-to-start-kibana/46093/7 "2016-04-02T05:56:10Z")

</div>

What do you have for your kabana.yml? Do you have elasticsearch.username and elasticsearch.password set?

---

<div class="post-metadata">

### Author: ![boreal](https://avatars.discourse-cdn.com/v4/letter/b/cab0a1/32.png) [@boreal](https://discuss.elastic.co/u/boreal)
#### Post date: [April 2, 2016, 6:26am UTC](https://discuss.elastic.co/t/unable-to-start-kibana/46093/8 "2016-04-02T06:26:26Z")

</div>

Yes I do. I filled configs below out. It's been working fine for a month now until today.  
elasticsearch.username: "putUsername\_Here"  
elasticsearch.password: "putPasswordHere"

Thanks a lot!  
B

---

<div class="post-metadata">

### Author: ![boreal](https://avatars.discourse-cdn.com/v4/letter/b/cab0a1/32.png) [@boreal](https://discuss.elastic.co/u/boreal)
#### Post date: [April 2, 2016, 5:12pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana/46093/9 "2016-04-02T17:12:29Z")

</div>

I ended up taking down that node and added another one. Thanks for all of the help though!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:57pm UTC](https://discuss.elastic.co/t/unable-to-start-kibana/46093/10 "2017-07-06T13:57:04Z")

</div>


