# Unable to start logstash getting error

**URL:** https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093
**Category:** Logstash
**Created:** [March 29, 2018, 12:55pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093 "2018-03-29T12:55:09Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![Shiv\_Gupta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiv_gupta/32/29716_2.png) [@Shiv\_Gupta](https://discuss.elastic.co/u/Shiv_Gupta)
#### Post date: [March 29, 2018, 12:55pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/1 "2018-03-29T12:55:09Z")

</div>

Hello All, could you please help me to solve the below error getting in logstash while starting.  
earlier it was working fine , suddenly started getting below-

[ERROR] 2018-03-29 17:47:09.503 [main] Logstash - java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (LoadError) load error: jopenssl/load -- java.lang.NoClassDefFoundError: org/bouncycastle/operator/OperatorException

Any help much appreciated.

---

<div class="post-metadata">

### Author: ![yaauie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yaauie/32/23363_2.png) [@yaauie](https://discuss.elastic.co/u/yaauie)
#### Post date: [March 29, 2018, 9:46pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/2 "2018-03-29T21:46:00Z")

</div>

Related? [Exception while starting Logstash [LoadError: load error: jopenssl/load -- java.lang.VerifyError: class org.bouncycastle.asn1.ASN1Primitive overrides final method equals]](https://discuss.elastic.co/t/exception-while-starting-logstash-loaderror-load-error-jopenssl-load-java-lang-verifyerror-class-org-bouncycastle-asn1-asn1primitive-overrides-final-method-equals/51024)

- What version of Logstash?
- How did you install Logstash (e.g., package from [elastic.co](http://elastic.co), from source, deb or rpm package etc)?
- What is your operating system?
- What is your `$JAVA_HOME`?

```auto
echo $JAVA_HOME

```

- What version of Java are you running?

```auto
java -version

```

---

<div class="post-metadata">

### Author: ![Shiv\_Gupta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiv_gupta/32/29716_2.png) [@Shiv\_Gupta](https://discuss.elastic.co/u/Shiv_Gupta)
#### Post date: [April 2, 2018, 12:26pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/3 "2018-04-02T12:26:00Z")

</div>

What version of Logstash - 6.2.2  
How did you install Logstash - package from [elastic.co](http://elastic.co)  
What is your operating system - Win  
What is your $JAVA\_HOME- C:\Program Files\Java\jdk1.8.0\_162  
What version of Java are you running-1.8

---

<div class="post-metadata">

### Author: ![Suman\_Reddy1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/suman_reddy1/32/27303_2.png) [@Suman\_Reddy1](https://discuss.elastic.co/u/Suman_Reddy1)
#### Post date: [April 2, 2018, 3:09pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/4 "2018-04-02T15:09:01Z")

</div>

Can you post us your config file

---

<div class="post-metadata">

### Author: ![Shiv\_Gupta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiv_gupta/32/29716_2.png) [@Shiv\_Gupta](https://discuss.elastic.co/u/Shiv_Gupta)
#### Post date: [April 2, 2018, 3:47pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/5 "2018-04-02T15:47:39Z")

</div>

below is the config file-

input{  
file{  
path =\> "C:\ELK\logstash-6.2.2\bin\dilip\util\atg.log"  
type =\> "atg"  
start\_position =\> "beginning"  
sincedb\_path =\> "/dev/null"  
}  
file{  
path =\> "C:\ELK\logstash-6.2.2\bin\dilip\util\access.log"  
type =\> "apache"  
start\_position =\> "beginning"  
sincedb\_path =\> "/dev/null"  
}  
file{  
path =\> "C:\ELK\logstash-6.2.2\bin\dilip\prod1\atg.log"  
type =\> "atg"  
start\_position =\> "beginning"  
sincedb\_path =\> "/dev/null"  
}  
file{  
path =\> "C:\ELK\logstash-6.2.2\bin\dilip\prod1\access.log"  
type =\> "apache"  
start\_position =\> "beginning"  
sincedb\_path =\> "/dev/null"  
}  
file{  
path =\> "C:\ELK\logstash-6.2.2\bin\dilip\prod2\atg.log"  
type =\> "atg"  
start\_position =\> "beginning"  
sincedb\_path =\> "/dev/null"  
}  
file{  
path =\> "C:\ELK\logstash-6.2.2\bin\dilip\prod2\access.log"  
type =\> "apache"  
start\_position =\> "beginning"  
sincedb\_path =\> "/dev/null"  
}  
file{  
path =\> "C:\ELK\logstash-6.2.2\bin\dilip\endeca\endeca.log"  
type =\> "endeca"  
start\_position =\> "beginning"  
sincedb\_path =\> "/dev/null"  
}  
}

# You can also remove multiple fields at once:

filter {  
if [type] == "apache" {  
grok { match =\> {"path" =\> "%{GREEDYDATA}/%{GREEDYDATA:type}"} }  
grok { match =\> { "message" =\> "%{COMMONAPACHELOG}" } }  
}  
else if [type] == "atg" {  
grok{ match =\> {  
"path" =\> "%{GREEDYDATA}/%{GREEDYDATA:type}"  
"message" =\> "%{WORD:severity} %{DAY:day} %{MONTH:month} %{MONTHDAY:monthday} %{TIME:time} %{TZ:timezone} %{YEAR:year}%{GREEDYDATA:logMessage}"  
}  
}  
}  
else if [type] == "endeca" {  
grok{ match =\> {"path" =\> "%{GREEDYDATA}/%{GREEDYDATA:type}"} }  
}

```
# rename type to sourcetype
mutate {
remove_field => ["@version","tags","_score"]
rename => { "path" => "source" }
rename => { "type" => "sourcetype" }
remove_tag => ["_grokparsefailure"]

```

}  
}

output{  
elasticsearch{  
hosts =\> ["localhost:9200"]  
user =\> elastic  
password =\> elastic  
index =\> "ascenalogpoc"  
document\_type =\> "ASCENA RETAIL GROUP INC."  
}  
stdout {}  
}

---

<div class="post-metadata">

### Author: ![Suman\_Reddy1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/suman_reddy1/32/27303_2.png) [@Suman\_Reddy1](https://discuss.elastic.co/u/Suman_Reddy1)
#### Post date: [April 2, 2018, 3:49pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/6 "2018-04-02T15:49:33Z")

</div>

try commenting elastisearch output.

---

<div class="post-metadata">

### Author: ![Shiv\_Gupta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiv_gupta/32/29716_2.png) [@Shiv\_Gupta](https://discuss.elastic.co/u/Shiv_Gupta)
#### Post date: [April 2, 2018, 3:52pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/7 "2018-04-02T15:52:16Z")

</div>

do you want me to remove complete output plugin from config?

---

<div class="post-metadata">

### Author: ![Shiv\_Gupta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiv_gupta/32/29716_2.png) [@Shiv\_Gupta](https://discuss.elastic.co/u/Shiv_Gupta)
#### Post date: [April 2, 2018, 3:53pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/8 "2018-04-02T15:53:44Z")

</div>

No luck , i did remove output plugin from config file but the same error occurred.

---

<div class="post-metadata">

### Author: ![Suman\_Reddy1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/suman_reddy1/32/27303_2.png) [@Suman\_Reddy1](https://discuss.elastic.co/u/Suman_Reddy1)
#### Post date: [April 2, 2018, 3:59pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/9 "2018-04-02T15:59:52Z")

</div>

I have never tried SSL with Logstash, but from your initial posts it referring to opessl. Try checking that.  
Yes, just remove Elastisearch output keep stdout

---

<div class="post-metadata">

### Author: ![Shiv\_Gupta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiv_gupta/32/29716_2.png) [@Shiv\_Gupta](https://discuss.elastic.co/u/Shiv_Gupta)
#### Post date: [April 2, 2018, 4:06pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/10 "2018-04-02T16:06:19Z")

</div>

did samething as you suggested but again no luck, not sure few days it was working and now suddenly started throwing above error.

---

<div class="post-metadata">

### Author: ![Suman\_Reddy1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/suman_reddy1/32/27303_2.png) [@Suman\_Reddy1](https://discuss.elastic.co/u/Suman_Reddy1)
#### Post date: [April 2, 2018, 5:30pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/11 "2018-04-02T17:30:19Z")

</div>

Same config file works for me.  
Logstash 6.2.2  
Elastic 6.2.1

---

<div class="post-metadata">

### Author: ![Shiv\_Gupta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiv_gupta/32/29716_2.png) [@Shiv\_Gupta](https://discuss.elastic.co/u/Shiv_Gupta)
#### Post date: [April 2, 2018, 7:35pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/12 "2018-04-02T19:35:06Z")

</div>

ohh ok, anyway thanks for your inputs.😀

---

<div class="post-metadata">

### Author: ![Suman\_Reddy1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/suman_reddy1/32/27303_2.png) [@Suman\_Reddy1](https://discuss.elastic.co/u/Suman_Reddy1)
#### Post date: [April 3, 2018, 1:01pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/13 "2018-04-03T13:01:12Z")

</div>

Could please provide below.  
How you are starting Logstash?  
Paste your Logstash process details.  
Kindly give full log of logstash startup.

It should b somethig related to your environment. The same config file is working without any issues.  
And what I would suggest is, try starting logstash with bare minimal configuration

> ```
> input {
> stdin {
> id => "my_plugin_id"
> }
> }
> output {
> stdout {}
> }
> 
> ```

Lets hope for the best

---

<div class="post-metadata">

### Author: ![Shiv\_Gupta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiv_gupta/32/29716_2.png) [@Shiv\_Gupta](https://discuss.elastic.co/u/Shiv_Gupta)
#### Post date: [April 3, 2018, 6:55pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/14 "2018-04-03T18:55:23Z")

</div>

Suman,

the below i am using in order to start logstash-

logstash -f test.config

and getting below error..apart from this no nothing logs

[ERROR] 2018-03-29 17:47:09.503 [main] Logstash - java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (LoadError) load error: jopenssl/load -- java.lang.NoClassDefFoundError: org/bouncycastle/operator/OperatorException

---

<div class="post-metadata">

### Author: ![Suman\_Reddy1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/suman_reddy1/32/27303_2.png) [@Suman\_Reddy1](https://discuss.elastic.co/u/Suman_Reddy1)
#### Post date: [April 4, 2018, 12:55am UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/15 "2018-04-04T00:55:37Z")

</div>

> [@Shiv\_Gupta](#):
>
> logstash -f test.config

logstash -f test.config --debug try this

---

<div class="post-metadata">

### Author: ![camarar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/camarar/32/20476_2.png) [@camarar](https://discuss.elastic.co/u/camarar)
#### Post date: [April 4, 2018, 11:45pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/16 "2018-04-04T23:45:19Z")

</div>

Hi Shiv\_Gupta,

I used this config file with Logstash 6.2.2 and it is running success.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/8/4/8430e798b02b2e32bf561bb555ad02e0317e2460.png)

Could you please upload in this forum your test.config ( to search for wrong enconde or hid caracter inside the file) and your logstash.yml(logstash-6.2.2\config) file?

---

<div class="post-metadata">

### Author: ![Shiv\_Gupta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiv_gupta/32/29716_2.png) [@Shiv\_Gupta](https://discuss.elastic.co/u/Shiv_Gupta)
#### Post date: [April 5, 2018, 11:57am UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/17 "2018-04-05T11:57:12Z")

</div>

Hello Camarar,

my config file is already posted above and below is logstash.yml

# Settings file in YAML

# 

# Settings can be specified either in hierarchical form, e.g.:

# 

# pipeline:

# batch:

# size: 125

# delay: 5

# 

# Or as flat keys:

# 

# pipeline.batch.size: 125

# pipeline.batch.delay: 5

# 

# ------------ Node identity ------------

# 

# Use a descriptive name for the node:

# 

# node.name: test

# 

# If omitted the node name will default to the machine's host name

# 

# ------------ Data path ------------------

# 

# Which directory should be used by logstash and its plugins

# for any persistent needs. Defaults to LOGSTASH\_HOME/data

# 

# path.data:

# 

# ------------ Pipeline Settings --------------

# 

# The ID of the pipeline.

# 

# pipeline.id: main

# 

# Set the number of workers that will, in parallel, execute the filters+outputs

# stage of the pipeline.

# 

# This defaults to the number of the host's CPU cores.

# 

# pipeline.workers: 2

# 

# How many events to retrieve from inputs before sending to filters+workers

# 

# pipeline.batch.size: 125

# 

# How long to wait in milliseconds while polling for the next event

# before dispatching an undersized batch to filters+outputs

# 

# pipeline.batch.delay: 50

# 

# Force Logstash to exit during shutdown even if there are still inflight

# events in memory. By default, logstash will refuse to quit until all

# received events have been pushed to the outputs.

# 

# WARNING: enabling this can lead to data loss during shutdown

# 

# pipeline.unsafe\_shutdown: false

# 

# ------------ Pipeline Configuration Settings --------------

# 

# Where to fetch the pipeline configuration for the main pipeline

# 

# path.config:

# 

# Pipeline configuration string for the main pipeline

# 

# config.string:

# 

# At startup, test if the configuration is valid and exit (dry run)

# 

# config.test\_and\_exit: false

# 

# Periodically check if the configuration has changed and reload the pipeline

# This can also be triggered manually through the SIGHUP signal

# 

# config.reload.automatic: false

# 

# How often to check if the pipeline configuration has changed (in seconds)

# 

# config.reload.interval: 3s

# 

# Show fully compiled configuration as debug log message

# NOTE: --log.level must be 'debug'

# 

# config.debug: false

# 

# When enabled, process escaped characters such as \n and " in strings in the

# pipeline configuration files.

# 

# config.support\_escapes: false

# 

# ------------ Module Settings ---------------

# Define modules here. Modules definitions must be defined as an array.

# The simple way to see this is to prepend each `name` with a `-`, and keep

# all associated variables under the `name` they are associated with, and

# above the next, like this:

# 

# modules:

# - name: MODULE\_NAME

# var.PLUGINTYPE1.PLUGINNAME1.KEY1: VALUE

# var.PLUGINTYPE1.PLUGINNAME1.KEY2: VALUE

# var.PLUGINTYPE2.PLUGINNAME1.KEY1: VALUE

# var.PLUGINTYPE3.PLUGINNAME3.KEY1: VALUE

# 

# Module variable names must be in the format of

# 

# var.PLUGIN\_TYPE.PLUGIN\_NAME.KEY

# 

# modules:

# 

# ------------ Cloud Settings ---------------

# Define Elastic Cloud settings here.

# Format of cloud.id is a base64 value e.g. dXMtZWFzdC0xLmF3cy5mb3VuZC5pbyRub3RhcmVhbCRpZGVudGlmaWVy

# and it may have an label prefix e.g. staging:dXMtZ...

# This will overwrite 'var.elasticsearch.hosts' and 'var.kibana.host'

# cloud.id:

# 

# Format of cloud.auth is: :

# This is optional

# If supplied this will overwrite 'var.elasticsearch.username' and 'var.elasticsearch.password'

# If supplied this will overwrite 'var.kibana.username' and 'var.kibana.password'

# cloud.auth: elastic:

# 

# ------------ Queuing Settings --------------

# 

# Internal queuing model, "memory" for legacy in-memory based queuing and

# "persisted" for disk-based acked queueing. Defaults is memory

# 

# queue.type: memory

# 

# If using queue.type: persisted, the directory path where the data files will be stored.

# Default is path.data/queue

# 

# path.queue:

# 

# If using queue.type: persisted, the page data files size. The queue data consists of

# append-only data files separated into pages. Default is 64mb

# 

# queue.page\_capacity: 64mb

# 

# If using queue.type: persisted, the maximum number of unread events in the queue.

# Default is 0 (unlimited)

# 

# queue.max\_events: 0

# 

# If using queue.type: persisted, the total capacity of the queue in number of bytes.

# If you would like more unacked events to be buffered in Logstash, you can increase the

# capacity using this setting. Please make sure your disk drive has capacity greater than

# the size specified here. If both max\_bytes and max\_events are specified, Logstash will pick

# whichever criteria is reached first

# Default is 1024mb or 1gb

# 

# queue.max\_bytes: 1024mb

# 

# If using queue.type: persisted, the maximum number of acked events before forcing a checkpoint

# Default is 1024, 0 for unlimited

# 

# queue.checkpoint.acks: 1024

# 

# If using queue.type: persisted, the maximum number of written events before forcing a checkpoint

# Default is 1024, 0 for unlimited

# 

# queue.checkpoint.writes: 1024

# 

# If using queue.type: persisted, the interval in milliseconds when a checkpoint is forced on the head page

# Default is 1000, 0 for no periodic checkpoint.

# 

# queue.checkpoint.interval: 1000

# 

# ------------ Dead-Letter Queue Settings --------------

# Flag to turn on dead-letter queue.

# 

# dead\_letter\_queue.enable: false

# If using dead\_letter\_queue.enable: true, the maximum size of each dead letter queue. Entries

# will be dropped if they would increase the size of the dead letter queue beyond this setting.

# Default is 1024mb

# dead\_letter\_queue.max\_bytes: 1024mb

# If using dead\_letter\_queue.enable: true, the directory path where the data files will be stored.

# Default is path.data/dead\_letter\_queue

# 

# path.dead\_letter\_queue:

# 

# ------------ Metrics Settings --------------

# 

# Bind address for the metrics REST endpoint

# 

# http.host: "127.0.0.1"

# 

# Bind port for the metrics REST endpoint, this option also accept a range

# (9600-9700) and logstash will pick up the first available ports.

# 

# http.port: 9600-9700

# 

# ------------ Debugging Settings --------------

# 

# Options for log.level:

# \* fatal

# \* error

# \* warn

# \* info (default)

# \* debug

# \* trace

# 

# log.level: info

# path.logs:

# 

# ------------ Other Settings --------------

# 

# Where to find custom plugins

# path.plugins: []

---

<div class="post-metadata">

### Author: ![yaauie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yaauie/32/23363_2.png) [@yaauie](https://discuss.elastic.co/u/yaauie)
#### Post date: [April 5, 2018, 7:53pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/18 "2018-04-05T19:53:39Z")

</div>

@Shiv_Gupta it looks like we may have lost a bit in the markdown auto-formatting; if you edit your post to include code fences around your config, the forums won't auto-format it, which will make it a lot easier to read (and won't strip out the leading `#` from each line indicating that it is commented out and inactive).

code-blocks can be fenced with `~~~` lines and look like this:

```markdown
Your normal post body

~~~
preformatted code
~~~

Additional body

```

---

<div class="post-metadata">

### Author: ![camarar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/camarar/32/20476_2.png) [@camarar](https://discuss.elastic.co/u/camarar)
#### Post date: [April 5, 2018, 8:10pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/19 "2018-04-05T20:10:45Z")

</div>

@Shiv_Gupta, It is necessary the file as is with comments "#".

It is possible to upload the file...

---

<div class="post-metadata">

### Author: ![Shiv\_Gupta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiv_gupta/32/29716_2.png) [@Shiv\_Gupta](https://discuss.elastic.co/u/Shiv_Gupta)
#### Post date: [April 6, 2018, 12:19pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093/20 "2018-04-06T12:19:57Z")

</div>

![logstash108](https://us1.discourse-cdn.com/elastic/original/3X/5/4/540e5bbb3b33dc2232ca606a1ef5d1d0438b94ab.jpg) ![logstashend](https://us1.discourse-cdn.com/elastic/original/3X/5/9/595df9293ae0b627136ed03d0412188e7b967587.jpg) ![logstash161](https://us1.discourse-cdn.com/elastic/original/3X/3/6/367597b179c9db603a6053e65499d2659393fea3.jpg) ![logstash54](https://us1.discourse-cdn.com/elastic/original/3X/6/d/6dc4a360588497fa264dd7968c83c8753aee4565.jpg)

logstash.yml attached , i haven't changes anything in this file.

[Next page](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093.md?page=2)
