# Unable to start logstash in putty

**URL:** <https://discuss.elastic.co/t/unable-to-start-logstash-in-putty/127606>\
**Category:** Elasticsearch\
**Created:** [April 11, 2018, 10:06am UTC](https://discuss.elastic.co/t/unable-to-start-logstash-in-putty/127606 "2018-04-11T10:06:50Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![sreddy4](https://avatars.discourse-cdn.com/v4/letter/s/6f9a4e/32.png) [@sreddy4](https://discuss.elastic.co/u/sreddy4)\
**Post date:** [April 11, 2018, 10:06am UTC](https://discuss.elastic.co/t/unable-to-start-logstash-in-putty/127606/1 "2018-04-11T10:06:50Z")

</div>

Starting logstash rpm using below command

Using Command: "sudo service logstash start"

But, am unable to start logstash through this command.

Error: unrecognized service

So, kindly suggest me what is the command for logstash.

---

<div class="post-metadata">

**Author:** ![NerdSec](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nerdsec/32/22056_2.png) [@NerdSec](https://discuss.elastic.co/u/NerdSec)\
**Post date:** [April 11, 2018, 1:14pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-in-putty/127606/2 "2018-04-11T13:14:42Z")

</div>

Hi sadashiv,

The topic should be posted in logstash category ideally.

What version of rhel do you use?

Try running the following and post the output.  
`systemctl start logstash`  
`systemctl status logstash`

Regards,  
N

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 9, 2018, 1:15pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-in-putty/127606/3 "2018-05-09T13:15:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
