# Unable to start logstash on Amazon EC2 with Windows Server 2022

**URL:** https://discuss.elastic.co/t/unable-to-start-logstash-on-amazon-ec2-with-windows-server-2022/328986
**Category:** Logstash
**Tags:** windows
**Created:** [March 30, 2023, 11:57pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-on-amazon-ec2-with-windows-server-2022/328986 "2023-03-30T23:57:27Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![xavier76](https://avatars.discourse-cdn.com/v4/letter/x/71c47a/32.png) [@xavier76](https://discuss.elastic.co/u/xavier76)
#### Post date: [March 30, 2023, 11:57pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-on-amazon-ec2-with-windows-server-2022/328986/1 "2023-03-30T23:57:27Z")

</div>

The erorr I'm getting is below.

[2023-03-30T23:40:36,465][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"8.6.2", "jruby.version"=\>"jruby 9.3.10.0 (2.6.8) 2023-02-01 107b2e6697 OpenJDK 64-Bit Server VM 17.0.6+10 on 17.0.6+10 +indy +jit [x86\_64-mswin32]"}  
[2023-03-30T23:40:36,484][INFO][logstash.runner] JVM bootstrap flags: [-Xms1g, -Xmx1g, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djruby.compile.invokedynamic=true, -XX:+HeapDumpOnOutOfMemoryError, -Djava.security.egd=file:/dev/urandom, -Dlog4j2.isThreadContextMapInheritable=true, -Djruby.regexp.interruptible=true, -Djdk.io.File.enableADS=true, --add-exports=jdk.compiler/com.sun.tools.javac.api=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.file=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.parser=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.tree=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.util=ALL-UNNAMED, --add-opens=java.base/java.security=ALL-UNNAMED, --add-opens=java.base/java.io=ALL-UNNAMED, --add-opens=java.base/java.nio.channels=ALL-UNNAMED, --add-opens=java.base/sun.nio.ch=ALL-UNNAMED, --add-opens=java.management/sun.management=ALL-UNNAMED]  
[2023-03-30T23:40:36,547][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2023-03-30T23:40:37,483][INFO][logstash.config.source.local.configpathloader] No config files found in path {:path=\>"D:/logstash-8.6.2-windows-x86\_64/logstash-8.6.2/logstash-8.6.2-windows-x86\_64/logstash\_xavier.conf"}  
[2023-03-30T23:40:37,518][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.  
[2023-03-30T23:40:37,612][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600, :ssl\_enabled=\>false}  
[2023-03-30T23:40:37,624][INFO][logstash.runner] Logstash shut down.  
[2023-03-30T23:40:37,631][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit  
org.jruby.exceptions.SystemExit: (SystemExit) exit  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:790) ~[jruby.jar:?]  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:753) ~[jruby.jar:?]  
at D\_3a\_.logstash\_minus\_8\_dot\_6\_dot\_2\_minus\_windows\_minus\_x86\_64.logstash\_minus\_8\_dot\_6\_dot\_2.lib.bootstrap.environment.(D:\logstash-8.6.2-windows-x86\_64\logstash-8.6.2\lib\bootstrap\environment.rb:91) ~[?:?]

---

<div class="post-metadata">

### Author: ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)
#### Post date: [March 31, 2023, 5:01am UTC](https://discuss.elastic.co/t/unable-to-start-logstash-on-amazon-ec2-with-windows-server-2022/328986/2 "2023-03-31T05:01:58Z")

</div>

> [2023-03-30T23:40:37,518][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.  
> It seems your LS cannot find .conf file.  
> Is this path `D:/logstash-8.6.2-windows-x86_64/logstash-8.6.2/logstash-8.6.2-windows-x86_64/logstash_xavier.conf` correct? You have same directories.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 28, 2023, 5:02am UTC](https://discuss.elastic.co/t/unable-to-start-logstash-on-amazon-ec2-with-windows-server-2022/328986/3 "2023-04-28T05:02:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
