# Unable to start logstash Pipeline - Error registering Plugin

**URL:** https://discuss.elastic.co/t/unable-to-start-logstash-pipeline-error-registering-plugin/101298
**Category:** Logstash
**Created:** [September 21, 2017, 9:18am UTC](https://discuss.elastic.co/t/unable-to-start-logstash-pipeline-error-registering-plugin/101298 "2017-09-21T09:18:22Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Aarthy.Krishnamurthy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aarthy.krishnamurthy/32/80330_2.png) [@Aarthy.Krishnamurthy](https://discuss.elastic.co/u/Aarthy.Krishnamurthy)
#### Post date: [September 21, 2017, 9:18am UTC](https://discuss.elastic.co/t/unable-to-start-logstash-pipeline-error-registering-plugin/101298/1 "2017-09-21T09:18:22Z")

</div>

Hi there,

I am currently using Logstash 5.5, and when I start the plugin I am encountering the following error :

[2017-09-21T14:39:25,535][ERROR][logstash.pipeline] Error registering plugin {:plugin=\>"#\<LogStash::OutputDelegator:0x852d86a @namespaced\_metric=#\<LogStash::Instrument::NamespacedMetric:0x7f86f730 @metric=#\<LogStash::Instrument::Metric:0x734937a6 @collector=#\<LogStash::Instrument::Collector:0x6efe61ff @agent=nil, @metric\_store=#\<LogStash::Instrument::MetricStore:0x70f175c2 @store=#\<Concurrent:🗺0x000000000634e0 entries=2 default\_proc=nil\>, @structured\_lookup\_mutex=#Mutex:0x3886239b, @fast\_lookup=#\<Concurrent:🗺0x000000000634e4 entries=50 default\_proc=nil\>\>\>\>, @namespace\_name=[:stats, :pipelines, :main, :plugins, :outputs, :"dedfbfed5c89bb7d190b704562aee8ecf4fd3d77-3"]\>, @metric=#\<LogStash::Instrument::NamespacedMetric:0x1f24bf05 @metric=#\<LogStash::Instrument::Metric:0x734937a6 @collector=#\<LogStash::Instrument::Collector:0x6efe61ff @agent=nil, @metric\_store=#\<LogStash::Instrument::MetricStore:0x70f175c2 @store=#\<Concurrent:🗺0x000000000634e0 entries=2 default\_proc=nil\>, @structured\_lookup\_mutex=#Mutex:0x3886239b, @fast\_lookup=#\<Concurrent:🗺0x000000000634e4 entries=50 default\_proc=nil\>\>\>\>, @namespace\_name=[:stats, :pipelines, :main, :plugins, :outputs]\>, @logger=#\<LogStash::Logging::Logger:0x6d13eba6 @logger=#Java::OrgApacheLoggingLog4jCore::Logger:0x31f11743\>, @strategy=#\<LogStash::OutputDelegatorStrategies::Shared:0x13405e1f @output=\<LogStash::Outputs::ElasticSearch hosts=\>[[//localhost:9200](https://localhost:9200)], index=\>"auditTrail\_9\_13\_2017\_P1", id=\>"dedfbfed5c89bb7d190b704562aee8ecf4fd3d77-3", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_baa9df5b-6785-49a7-8e27-e6b0bc4bfe89", enable\_metric=\>true, charset=\>"UTF-8"\>, workers=\>1, manage\_template=\>true, template\_name=\>"logstash", template\_overwrite=\>false, idle\_flush\_time=\>1, doc\_as\_upsert=\>false, script\_type=\>"inline", script\_lang=\>"painless", script\_var\_name=\>"event", scripted\_upsert=\>false, retry\_initial\_interval=\>2, retry\_max\_interval=\>64, retry\_on\_conflict=\>1, action=\>"index", ssl\_certificate\_verification=\>true, sniffing=\>false, sniffing\_delay=\>5, timeout=\>60, pool\_max=\>1000, pool\_max\_per\_route=\>100, resurrect\_delay=\>5, validate\_after\_inactivity=\>10000, http\_compression=\>false\>\>, @id="dedfbfed5c89bb7d190b704562aee8ecf4fd3d77-3", @metric\_events=#\<LogStash::Instrument::NamespacedMetric:0x7312d887 @metric=#\<LogStash::Instrument::Metric:0x734937a6 @collector=#\<LogStash::Instrument::Collector:0x6efe61ff @agent=nil, @metric\_store=#\<LogStash::Instrument::MetricStore:0x70f175c2 @store=#\<Concurrent:🗺0x000000000634e0 entries=2 default\_proc=nil\>, @structured\_lookup\_mutex=#Mutex:0x3886239b, @fast\_lookup=#\<Concurrent:🗺0x000000000634e4 entries=50 default\_proc=nil\>\>\>\>, @namespace\_name=[:stats, :pipelines, :main, :plugins, :outputs, :"dedfbfed5c89bb7d190b704562aee8ecf4fd3d77-3", :events]\>, @output\_class=LogStash::Outputs::ElasticSearch\>", :error=\>"SSLConnectionSocketFactory not found in packages org.apache.http.client.methods, org.apache.http.client.entity, org.apache.http.client.config, org.apache.http.config, org.apache.http.conn.socket, org.apache.http.impl, org.apache.http.impl.client, org.apache.http.impl.conn, org.apache.http.impl.auth, org.apache.http.entity, org.apache.http.message, org.apache.http.params, org.apache.http.protocol, org.apache.http.auth, java.util.concurrent, org.apache.http.client.protocol, org.apache.http.conn.ssl, java.security.cert, java.security.spec, java.security, org.apache.http.client.utils; last error: cannot load Java class org.apache.http.client.utils.SSLConnectionSocketFactory"}

Has anyone come across this issue and have resolved it ?  
Thanks.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 19, 2017, 9:18am UTC](https://discuss.elastic.co/t/unable-to-start-logstash-pipeline-error-registering-plugin/101298/2 "2017-10-19T09:18:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
