# Unable to start logstash using docker compose

**URL:** <https://discuss.elastic.co/t/unable-to-start-logstash-using-docker-compose/187651>\
**Category:** Logstash\
**Created:** [June 26, 2019, 6:28pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-using-docker-compose/187651 "2019-06-26T18:28:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![nila](https://avatars.discourse-cdn.com/v4/letter/n/b2d939/32.png) [@nila](https://discuss.elastic.co/u/nila)\
**Post date:** [June 26, 2019, 6:28pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-using-docker-compose/187651/1 "2019-06-26T18:28:53Z")

</div>

Hello,

I am trying to configure logstash with docker compose. Here is my configuration. From the logs, it shows it is bringing up my pipeline but crashes after that. can someone please help what went wrong?

docker-compose:

logstash:  
image: [docker.elastic.co/logstash/logstash:7.1.1](http://docker.elastic.co/logstash/logstash:7.1.1)  
container\_name: Logstash  
ports:  
- 5033:5033  
links:  
- es01  
volumes:  
- /el1/app/elkstack/docker/settings:/usr/share/logstash/config  
command: logstash

$ cat pipelines.yml

- pipeline.id: RP  
pipeline.workers: 3  
pipeline.batch.size: 2  
queue.type: persisted  
path.config: "/usr/share/logstash/config/logstash.conf"

$ cat logstash.conf  
input {  
beats {  
host =\> "205.10.10.1"  
port =\>5033

# type =\> %{log\_type}

```
             }

```

}  
filter {  
}  
output {  
if [fields][log\_type] == "AMS1" {  
elasticsearch {

```
            hosts => ["http://205.10.10.2:9200"]
            index => "ams1_log-%{+YYYY.MM.dd}"
    }
  }
  if [fields][log_type] == "tc_log" {
    elasticsearch {
            hosts => ["http://205.10.10.2:9200"]
            index => "tc-%{+YYYY.MM.dd}"
    }

 }

```

}

Here is the error message: The port is open only.

[2019-06-26T18:19:35,989][INFO][logstash.javapipeline] Pipeline started {"pipeline.id"=\>".monitoring-logstash"}

[2019-06-26T18:19:36,041][INFO][logstash.agent] Pipelines running {:count=\>2, :running\_pipelines=\>[:RP, :".monitoring-logstash"], :non\_running\_pipelines=\>}

warning: thread "Api Webserver" terminated with exception (report\_on\_exception is true):

Errno::EADDRNOTAVAIL: Cannot assign requested address - bind - Cannot assign requested address

```
    initialize at org/jruby/ext/socket/RubyTCPServer.java:127

           new at org/jruby/RubyIO.java:876

```

add\_tcp\_listener at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/puma-2.16.0-java/lib/puma/binder.rb:234

add\_tcp\_listener at (eval):2

start\_webserver at /usr/share/logstash/logstash-core/lib/logstash/webserver.rb:88

```
           run at /usr/share/logstash/logstash-core/lib/logstash/webserver.rb:44

          each at org/jruby/RubyRange.java:511

```

each\_with\_index at org/jruby/RubyEnumerable.java:1194

```
           run at /usr/share/logstash/logstash-core/lib/logstash/webserver.rb:39

```

start\_webserver at /usr/share/logstash/logstash-core/lib/logstash/agent.rb:376

[2019-06-26T18:19:36,678][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<Errno::EADDRNOTAVAIL: Cannot assign requested address - bind - Cannot assign requested address\>, :backtrace=\>["org/jruby/ext/socket/RubyTCPServer.java:127:in `initialize'", "org/jruby/RubyIO.java:876:in`new'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/puma-2.16.0-java/lib/puma/binder.rb:234:in `add_tcp_listener'", "(eval):2:in`add\_tcp\_listener'", "/usr/share/logstash/logstash-core/lib/logstash/webserver.rb:88:in `start_webserver'", "/usr/share/logstash/logstash-core/lib/logstash/webserver.rb:44:in`block in run'", "org/jruby/RubyRange.java:511:in `each'", "org/jruby/RubyEnumerable.java:1194:in`each\_with\_index'", "/usr/share/logstash/logstash-core/lib/logstash/webserver.rb:39:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:376:in`block in start\_webserver'"]}

[2019-06-26T18:19:36,763][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [June 26, 2019, 7:42pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-using-docker-compose/187651/2 "2019-06-26T19:42:20Z")

</div>

> [@nila](#):
>
> Errno::EADDRNOTAVAIL: Cannot assign requested address - bind - Cannot assign requested address

I believe the monitoring web server binds to 127.0.0.1 by default. You can set http.host in logstash.yml to change that.

---

<div class="post-metadata">

**Author:** ![nila](https://avatars.discourse-cdn.com/v4/letter/n/b2d939/32.png) [@nila](https://discuss.elastic.co/u/nila)\
**Post date:** [June 26, 2019, 11:10pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-using-docker-compose/187651/3 "2019-06-26T23:10:37Z")

</div>

Thanks Badger! I found the issue with logstash.yml as I defined http.host as my logstash host. it is not required. I kept logstash.yml empty(it needs this empty file. otherwise it is throwing error). After this it worked fine.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 24, 2019, 11:10pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-using-docker-compose/187651/4 "2019-07-24T23:10:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
