# Unable to start Metric beat on Kubenetes

**URL:** https://discuss.elastic.co/t/unable-to-start-metric-beat-on-kubenetes/190076
**Category:** Beats
**Tags:** metricbeat
**Created:** [July 11, 2019, 4:45pm UTC](https://discuss.elastic.co/t/unable-to-start-metric-beat-on-kubenetes/190076 "2019-07-11T16:45:00Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![Senthil\_ak](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@Senthil\_ak](https://discuss.elastic.co/u/Senthil_ak)
#### Post date: [July 11, 2019, 4:45pm UTC](https://discuss.elastic.co/t/unable-to-start-metric-beat-on-kubenetes/190076/1 "2019-07-11T16:45:00Z")

</div>

I am trying to start the metric beat with [https://github.com/elastic/beats/blob/master/deploy/kubernetes/metricbeat-kubernetes.yaml](https://github.com/elastic/beats/blob/master/deploy/kubernetes/metricbeat-kubernetes.yaml) file but it failing with below error. any help will be appriciated.

Version  
Elk - 7.2  
k8s - v1.14.0

```
2019-07-11T16:41:42.165Z INFO add_cloud_metadata/add_cloud_metadata.go:347 add_cloud_metadata: hosting provider type not detected.
2019-07-11T16:41:42.165Z INFO [monitoring] log/log.go:153 Total non-zero metrics {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":20,"time":{"ms":21}},"total":{"ticks":60,"time":{"ms":62},"value":60},"user":{"ticks":40,"time":{"ms":41}}},"handles":{"limit":{"hard":65536,"soft":65536},"open":5},"info":{"ephemeral_id":"8eb35414-e8bd-40d3-ba88-445050a9d2cf","uptime":{"ms":45}},"memstats":{"gc_next":9705504,"memory_alloc":5990496,"memory_total":13242848,"rss":48001024},"runtime":{"goroutines":17}},"libbeat":{"config":{"module":{"running":0}},"output":{"type":"elasticsearch"},"pipeline":{"clients":0,"events":{"active":0}}},"system":{"cpu":{"cores":4},"load":{"1":0.01,"15":0.26,"5":0.12,"norm":{"1":0.0025,"15":0.065,"5":0.03}}}}}}
2019-07-11T16:41:42.165Z INFO [monitoring] log/log.go:154 Uptime: 47.423406ms
2019-07-11T16:41:42.165Z INFO [monitoring] log/log.go:131 Stopping metrics logging.
2019-07-11T16:41:42.165Z INFO instance/beat.go:431 metricbeat stopped.
2019-07-11T16:41:42.165Z ERROR instance/beat.go:877 Exiting: 1 error: metricset 'kubernetes/proxy' is not registered, metricset not found
Exiting: 1 error: metricset 'kubernetes/proxy' is not registered, metricset not found
```

---

<div class="post-metadata">

### Author: ![Kaiyan\_Sheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kaiyan_sheng/32/38247_2.png) [@Kaiyan\_Sheng](https://discuss.elastic.co/u/Kaiyan_Sheng)
#### Post date: [July 12, 2019, 4:11am UTC](https://discuss.elastic.co/t/unable-to-start-metric-beat-on-kubenetes/190076/2 "2019-07-12T04:11:33Z")

</div>

Hmm what docker image are you using for metricbeat?

---

<div class="post-metadata">

### Author: ![Senthil\_ak](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@Senthil\_ak](https://discuss.elastic.co/u/Senthil_ak)
#### Post date: [July 12, 2019, 1:04pm UTC](https://discuss.elastic.co/t/unable-to-start-metric-beat-on-kubenetes/190076/3 "2019-07-12T13:04:38Z")

</div>

`docker.elastic.co/beats/metricbeat:7.2.0`

---

<div class="post-metadata">

### Author: ![Kaiyan\_Sheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kaiyan_sheng/32/38247_2.png) [@Kaiyan\_Sheng](https://discuss.elastic.co/u/Kaiyan_Sheng)
#### Post date: [July 12, 2019, 2:04pm UTC](https://discuss.elastic.co/t/unable-to-start-metric-beat-on-kubenetes/190076/4 "2019-07-12T14:04:24Z")

</div>

Thanks, are you trying to use kubernetes/proxy metricset with 7.2 docker image? I believe kubernetes/proxy will be available in 7.3 so that's why you are getting this error.

---

<div class="post-metadata">

### Author: ![Senthil\_ak](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@Senthil\_ak](https://discuss.elastic.co/u/Senthil_ak)
#### Post date: [July 12, 2019, 2:15pm UTC](https://discuss.elastic.co/t/unable-to-start-metric-beat-on-kubenetes/190076/5 "2019-07-12T14:15:01Z")

</div>

Thanks, so my elk is in 7.2 is it fine to run the metric beat on 7.3 ? However 7.3 is not there.

```
docker pull docker.elastic.co/beats/metricbeat:7.3.0
Trying to pull repository docker.elastic.co/beats/metricbeat ...
manifest for docker.elastic.co/beats/metricbeat:7.3.0 not found
```

---

<div class="post-metadata">

### Author: ![Kaiyan\_Sheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kaiyan_sheng/32/38247_2.png) [@Kaiyan\_Sheng](https://discuss.elastic.co/u/Kaiyan_Sheng)
#### Post date: [July 12, 2019, 2:39pm UTC](https://discuss.elastic.co/t/unable-to-start-metric-beat-on-kubenetes/190076/6 "2019-07-12T14:39:06Z")

</div>

🙂 yeah, we are still in the process of releasing 7.3. We don't have a known date, but it will probably be released in a few weeks! Sorry about the inconvenience!

---

<div class="post-metadata">

### Author: ![Senthil\_ak](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@Senthil\_ak](https://discuss.elastic.co/u/Senthil_ak)
#### Post date: [July 12, 2019, 2:50pm UTC](https://discuss.elastic.co/t/unable-to-start-metric-beat-on-kubenetes/190076/7 "2019-07-12T14:50:43Z")

</div>

No Problem, I just commented out the proxy related config and able to start the metric beat without any errors. thanks for your help.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 9, 2019, 2:50pm UTC](https://discuss.elastic.co/t/unable-to-start-metric-beat-on-kubenetes/190076/8 "2019-08-09T14:50:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
