# Unable to start metricbeat

**URL:** <https://discuss.elastic.co/t/unable-to-start-metricbeat/382633>\
**Category:** Beats\
**Created:** [October 13, 2025, 12:21pm UTC](https://discuss.elastic.co/t/unable-to-start-metricbeat/382633 "2025-10-13T12:21:09Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![vikramaddagulla](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vikramaddagulla/32/139858_2.png) [@vikramaddagulla](https://discuss.elastic.co/u/vikramaddagulla)\
**Post date:** [October 13, 2025, 12:21pm UTC](https://discuss.elastic.co/t/unable-to-start-metricbeat/382633/1 "2025-10-13T12:21:09Z")

</div>

I am trying to start up metricbeat and I see the below error

`"log.level":"debug","@timestamptimestamp":"2025-10-10T08:00:01.260-0400","log.logger":"system.process","log.origin":{"function":"``github.com/elastic/elastic-agent-system-metrics/metric/system/process``.(`_`Stats).pidIter","file.name":"process/process.go","file.line":221},"message":"` **`non`** _`* fatal error; reporting partial metrics: /io unavailable; if running inside a container, use SYS_PTRACE: error fetching IO metrics: open /proc/48825/io: permission denied**","service.name":"metricbeat","ecs.version":"1.6.0.version":"1.6.0"}`

I am starting the service as application user. I do not have root access on this machine.

How can I fix this error ?
