# Unable to start process

**URL:** <https://discuss.elastic.co/t/unable-to-start-process/144637>\
**Category:** Elasticsearch\
**Created:** [August 16, 2018, 7:12am UTC](https://discuss.elastic.co/t/unable-to-start-process/144637 "2018-08-16T07:12:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![warhol](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warhol/32/34530_2.png) [@warhol](https://discuss.elastic.co/u/warhol)\
**Post date:** [August 16, 2018, 7:12am UTC](https://discuss.elastic.co/t/unable-to-start-process/144637/1 "2018-08-16T07:12:08Z")

</div>

**Hi, I have installed elasticsearch on a computer running CentOS. When I try to start it I get the following output:**

_[root@localhost ~]# sudo systemctl start elasticsearch_  
_Job for elasticsearch.service failed because the control process exited with error code. See "systemctl status elasticsearch.service" and "journalctl -xe" for details._  
_[root@localhost ~]#_  
_[root@localhost ~]# sudo systemctl status elasticsearch_  
_● elasticsearch.service - Elasticsearch_  
\_ Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)\_  
\_ Active: failed (Result: exit-code) since Thu 2018-08-16 09:04:00 CEST; 3s ago\_  
\_ Docs: http://www.elastic.co\_  
\_ Process: 7437 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=203/EXEC)\_  
\_ Main PID: 6579 (code=exited, status=1/FAILURE)\_

_Aug 16 09:04:00 localhost.localdomain systemd[1]: Starting Elasticsearch..._  
_Aug 16 09:04:00 localhost.localdomain systemd[7437]: Failed at step EXEC spawning /usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec: No such file or directory_  
_Aug 16 09:04:00 localhost.localdomain systemd[1]: elasticsearch.service: control process exited, code=exited status=203_  
_Aug 16 09:04:00 localhost.localdomain systemd[1]: Failed to start Elasticsearch._  
_Aug 16 09:04:00 localhost.localdomain systemd[1]: Unit elasticsearch.service entered failed state._  
_Aug 16 09:04:00 localhost.localdomain systemd[1]: elasticsearch.service failed._

**If I run "journalctl -xe" I get the following result:**  
_Aug 16 09:09:24 localhost.localdomain sudo[7719]: root : TTY=pts/1 ; PWD=/root ; USER=root ; COMMAND=/bin/systemctl start elasticsearch_  
_Aug 16 09:09:24 localhost.localdomain polkitd[784]: Registered Authentication Agent for unix-process:7720:17038275 (system bus name :1.840 [/usr/bin/pkttyagent --notify-fd 5 --fallback], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en\_US.UTF-8)_  
_Aug 16 09:09:24 localhost.localdomain systemd[1]: Starting Elasticsearch..._  
_-- Subject: Unit elasticsearch.service has begun start-up_  
_-- Defined-By: systemd_  
_-- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)_  
_--_  
_-- Unit elasticsearch.service has begun starting up._  
_Aug 16 09:09:24 localhost.localdomain systemd[7726]: Failed at step EXEC spawning /usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec: No such file or directory_  
_-- Subject: Process /usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec could not be executed_  
_-- Defined-By: systemd_  
_-- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)_  
_--_  
_-- The process /usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec could not be executed and failed._  
_--_  
_-- The error number returned by this process is 2._  
_Aug 16 09:09:24 localhost.localdomain systemd[1]: elasticsearch.service: control process exited, code=exited status=203_  
_Aug 16 09:09:24 localhost.localdomain systemd[1]: Failed to start Elasticsearch._  
_-- Subject: Unit elasticsearch.service has failed_  
_-- Defined-By: systemd_  
_-- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)_  
_--_  
_-- Unit elasticsearch.service has failed._  
_--_  
_-- The result is failed._  
_Aug 16 09:09:24 localhost.localdomain systemd[1]: Unit elasticsearch.service entered failed state._  
_Aug 16 09:09:24 localhost.localdomain systemd[1]: elasticsearch.service failed._  
_Aug 16 09:09:24 localhost.localdomain polkitd[784]: Unregistered Authentication Agent for unix-process:7720:17038275 (system bus name :1.840, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en\_US.UTF-8) (disconnected from bus)_

**What am I missing?**

---

<div class="post-metadata">

**Author:** ![warhol](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warhol/32/34530_2.png) [@warhol](https://discuss.elastic.co/u/warhol)\
**Post date:** [August 16, 2018, 9:44am UTC](https://discuss.elastic.co/t/unable-to-start-process/144637/2 "2018-08-16T09:44:46Z")

</div>

Problem solved. I don't know the cause but after reinstallation it now works fine.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 13, 2018, 9:44am UTC](https://discuss.elastic.co/t/unable-to-start-process/144637/3 "2018-09-13T09:44:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
