# Unable to start the elastic search in centos 7

**URL:** <https://discuss.elastic.co/t/unable-to-start-the-elastic-search-in-centos-7/226039>\
**Category:** Elasticsearch\
**Created:** [April 1, 2020, 12:01pm UTC](https://discuss.elastic.co/t/unable-to-start-the-elastic-search-in-centos-7/226039 "2020-04-01T12:01:18Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![vikas2](https://avatars.discourse-cdn.com/v4/letter/v/db5fbb/32.png) [@vikas2](https://discuss.elastic.co/u/vikas2)\
**Post date:** [April 1, 2020, 12:01pm UTC](https://discuss.elastic.co/t/unable-to-start-the-elastic-search-in-centos-7/226039/1 "2020-04-01T12:01:19Z")

</div>

Hi Team am setting up Elasticsearch kibana instance to setup Wazuh . I am facing the below error while checking the status of service. Please let me know where I went wrong.

I have modified  
**/etc/elasticsearch/elasticsearch.yml** and **network.host** to my Machine IP and change **node.name** to my system name.

[root@localhost vd]# systemctl status elasticsearch.service  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Wed 2020-04-01 16:22:36 IST; 16min ago  
Docs: [http://www.elastic.co](http://www.elastic.co/)  
Process: 31846 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 31846 (code=exited, status=1/FAILURE)

April01 16:22:36 elk elasticsearch[31846]: Caused by: ParsingExcept...  
April01 16:22:36 elk elasticsearch[31846]: at [org.elasticsearch.com](http://org.elasticsearch.com)...  
April01 16:22:36 elk elasticsearch[31846]: at [org.elasticsearch.com](http://org.elasticsearch.com)...  
April01 16:22:36 elk elasticsearch[31846]: at [org.elasticsearch.com](http://org.elasticsearch.com)...  
April01 16:22:36 elk elasticsearch[31846]: at [org.elasticsearch.com](http://org.elasticsearch.com)...  
April01 16:22:36 elk elasticsearch[31846]: ... 9 more  
April01 16:22:36 elk systemd[1]: elasticsearch.service: main proce...E  
April01 16:22:36 elk systemd[1]: Failed to start Elasticsearch.  
April01 16:22:36 elk systemd[1]: Unit elasticsearch.service entere....  
April01 16:22:36 elk systemd[1]: elasticsearch.service failed.  
Hint: Some lines were ellipsized, use -l to show in full.

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [April 3, 2020, 2:27pm UTC](https://discuss.elastic.co/t/unable-to-start-the-elastic-search-in-centos-7/226039/2 "2020-04-03T14:27:28Z")

</div>

Hey,

can you check the Elasticsearch logfiles or the `journalctl` logfiles, put them in pastebin and link them here?

See [https://www.elastic.co/guide/en/elasticsearch/reference/7.6/starting-elasticsearch.html#start-es-deb-systemd](https://www.elastic.co/guide/en/elasticsearch/reference/7.6/starting-elasticsearch.html#start-es-deb-systemd)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 1, 2020, 2:27pm UTC](https://discuss.elastic.co/t/unable-to-start-the-elastic-search-in-centos-7/226039/3 "2020-05-01T14:27:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
