# Unable to start the elasticsearch.service

**URL:** <https://discuss.elastic.co/t/unable-to-start-the-elasticsearch-service/308065>\
**Category:** Elasticsearch\
**Created:** [June 24, 2022, 2:05am UTC](https://discuss.elastic.co/t/unable-to-start-the-elasticsearch-service/308065 "2022-06-24T02:05:19Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![rrrrrrrrrrr](https://avatars.discourse-cdn.com/v4/letter/r/50afbb/32.png) [@rrrrrrrrrrr](https://discuss.elastic.co/u/rrrrrrrrrrr)\
**Post date:** [June 24, 2022, 2:05am UTC](https://discuss.elastic.co/t/unable-to-start-the-elasticsearch-service/308065/1 "2022-06-24T02:05:19Z")

</div>

Hello,

I'm trying to start my Elasticsearch servcie on RHEL Environment but I'm unable to start it after N days of not monitoring it. With this, I'm unable to access the Kibana dashboard.

```auto
[2022-06-24T09:34:05,594][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [devnode] fatal error in thread [Thread-3], exiting
java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
        at org.elasticsearch.systemd.Libsystemd.lambda$static$0(Libsystemd.java:23) ~[?:?]
        at java.security.AccessController.doPrivileged(AccessController.java:318) ~[?:?]
        at org.elasticsearch.systemd.Libsystemd.<clinit>(Libsystemd.java:22) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.sd_notify(SystemdPlugin.java:115) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.close(SystemdPlugin.java:141) ~[?:?]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:74) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:116) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:99) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.node.Node.close(Node.java:1120) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:74) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:116) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:66) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Bootstrap$4.run(Bootstrap.java:184) ~[elasticsearch-7.15.2.jar:7.15.2]

```

Thank you in advanced.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [June 24, 2022, 2:15am UTC](https://discuss.elastic.co/t/unable-to-start-the-elasticsearch-service/308065/2 "2022-06-24T02:15:52Z")

</div>

Please share more of your log.

---

<div class="post-metadata">

**Author:** ![rrrrrrrrrrr](https://avatars.discourse-cdn.com/v4/letter/r/50afbb/32.png) [@rrrrrrrrrrr](https://discuss.elastic.co/u/rrrrrrrrrrr)\
**Post date:** [June 24, 2022, 2:27am UTC](https://discuss.elastic.co/t/unable-to-start-the-elasticsearch-service/308065/4 "2022-06-24T02:27:47Z")

</div>

```auto
[2022-06-24T09:25:30,823][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [devnode] fatal error in thread [Thread-3], exiting
java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
        at org.elasticsearch.systemd.Libsystemd.lambda$static$0(Libsystemd.java:23) ~[?:?]
        at java.security.AccessController.doPrivileged(AccessController.java:318) ~[?:?]
        at org.elasticsearch.systemd.Libsystemd.<clinit>(Libsystemd.java:22) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.sd_notify(SystemdPlugin.java:115) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.close(SystemdPlugin.java:141) ~[?:?]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:74) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:116) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:99) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.node.Node.close(Node.java:1120) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:74) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:116) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:66) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Bootstrap$4.run(Bootstrap.java:184) ~[elasticsearch-7.15.2.jar:7.15.2]
[2022-06-24T09:33:51,322][WARN][o.e.b.Natives] [devnode] unable to load JNA native support library, native methods will be disabled.
java.lang.UnsatisfiedLinkError: /tmp/elasticsearch-7821483053189598030/jna741215918081038594.tmp: /tmp/elasticsearch-7821483053189598030/jna741215918081038594.tmp: failed to map segment from shared object
        at jdk.internal.loader.NativeLibraries.load(Native Method) ~[?:?]
        at jdk.internal.loader.NativeLibraries$NativeLibraryImpl.open(NativeLibraries.java:384) ~[?:?]
        at jdk.internal.loader.NativeLibraries.loadLibrary(NativeLibraries.java:228) ~[?:?]
        at jdk.internal.loader.NativeLibraries.loadLibrary(NativeLibraries.java:170) ~[?:?]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:2389) ~[?:?]
        at java.lang.Runtime.load0(Runtime.java:755) ~[?:?]
        at java.lang.System.load(System.java:1953) ~[?:?]
        at com.sun.jna.Native.loadNativeDispatchLibraryFromClasspath(Native.java:1019) ~[jna-5.7.0-1.jar:5.7.0 (b0)]
        at com.sun.jna.Native.loadNativeDispatchLibrary(Native.java:989) ~[jna-5.7.0-1.jar:5.7.0 (b0)]
        at com.sun.jna.Native.<clinit>(Native.java:195) ~[jna-5.7.0-1.jar:5.7.0 (b0)]
        at java.lang.Class.forName0(Native Method) ~[?:?]
        at java.lang.Class.forName(Class.java:375) ~[?:?]
        at org.elasticsearch.bootstrap.Natives.<clinit>(Natives.java:34) [elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:102) [elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:170) [elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:399) [elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:167) [elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:158) [elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:75) [elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:114) [elasticsearch-cli-7.15.2.jar:7.15.2]
        at org.elasticsearch.cli.Command.main(Command.java:79) [elasticsearch-cli-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:123) [elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:81) [elasticsearch-7.15.2.jar:7.15.2]
[2022-06-24T09:33:51,335][WARN][o.e.b.Natives] [devnode] cannot check if running as root because JNA is not available
[2022-06-24T09:33:51,335][WARN][o.e.b.Natives] [devnode] cannot install system call filter because JNA is not available
[2022-06-24T09:33:51,335][WARN][o.e.b.Natives] [devnode] cannot register console handler because JNA is not available
[2022-06-24T09:33:51,337][WARN][o.e.b.Natives] [devnode] cannot getrlimit RLIMIT_NPROC because JNA is not available
[2022-06-24T09:33:51,337][WARN][o.e.b.Natives] [devnode] cannot getrlimit RLIMIT_AS because JNA is not available
[2022-06-24T09:33:51,337][WARN][o.e.b.Natives] [devnode] cannot getrlimit RLIMIT_FSIZE because JNA is not available
[2022-06-24T09:33:51,742][INFO][o.e.n.Node] [devnode] version[7.15.2], pid[1726847], build[default/rpm/93d5a7f6192e8a1a12e154a2b81bf6fa7309da0c/2021-11-04T14:04:42.515624022Z], OS[Linux/4.18.0-305.19.1.el8_4.x86_64/amd64], JVM[Eclipse Adoptium/OpenJDK 64-Bit Server VM/17.0.1/17.0.1+12]
[2022-06-24T09:33:51,743][INFO][o.e.n.Node] [devnode] JVM home [/usr/share/elasticsearch/jdk], using bundled JDK [true]
[2022-06-24T09:33:51,744][INFO][o.e.n.Node] [devnode] JVM arguments [-Xshare:auto, -Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -XX:+ShowCodeDetailsInExceptionMessages, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dio.netty.allocator.numDirectArenas=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Djava.locale.providers=SPI,COMPAT, --add-opens=java.base/java.io=ALL-UNNAMED, -XX:+UseG1GC, -Djava.io.tmpdir=/tmp/elasticsearch-7821483053189598030, -Dlog4j2.formatMsgNoLookups=true, -XX:+HeapDumpOnOutOfMemoryError, -XX:HeapDumpPath=/var/lib/elasticsearch, -XX:ErrorFile=/var/log/elasticsearch/hs_err_pid%p.log, -Xlog:gc*,gc+age=trace,safepoint:file=/var/log/elasticsearch/gc.log:utctime,pid,tags:filecount=32,filesize=64m, -Xms3980m, -Xmx3980m, -XX:MaxDirectMemorySize=2086666240, -XX:G1HeapRegionSize=4m, -XX:InitiatingHeapOccupancyPercent=30, -XX:G1ReservePercent=15, -Des.path.home=/usr/share/elasticsearch, -Des.path.conf=/etc/elasticsearch, -Des.distribution.flavor=default, -Des.distribution.type=rpm, -Des.bundled_jdk=true]
[2022-06-24T09:33:54,512][INFO][o.e.p.PluginsService] [devnode] loaded module [aggs-matrix-stats]
[2022-06-24T09:33:54,513][INFO][o.e.p.PluginsService] [devnode] loaded module [analysis-common]
[2022-06-24T09:33:54,513][INFO][o.e.p.PluginsService] [devnode] loaded module [constant-keyword]
[2022-06-24T09:33:54,513][INFO][o.e.p.PluginsService] [devnode] loaded module [frozen-indices]
[2022-06-24T09:33:54,513][INFO][o.e.p.PluginsService] [devnode] loaded module [ingest-common]
[2022-06-24T09:33:54,513][INFO][o.e.p.PluginsService] [devnode] loaded module [ingest-geoip]
[2022-06-24T09:33:54,514][INFO][o.e.p.PluginsService] [devnode] loaded module [ingest-user-agent]
[2022-06-24T09:33:54,514][INFO][o.e.p.PluginsService] [devnode] loaded module [kibana]
[2022-06-24T09:33:54,514][INFO][o.e.p.PluginsService] [devnode] loaded module [lang-expression]
[2022-06-24T09:33:54,514][INFO][o.e.p.PluginsService] [devnode] loaded module [lang-mustache]
[2022-06-24T09:33:54,514][INFO][o.e.p.PluginsService] [devnode] loaded module [lang-painless]
[2022-06-24T09:33:54,514][INFO][o.e.p.PluginsService] [devnode] loaded module [mapper-extras]
[2022-06-24T09:33:54,515][INFO][o.e.p.PluginsService] [devnode] loaded module [mapper-version]
[2022-06-24T09:33:54,515][INFO][o.e.p.PluginsService] [devnode] loaded module [parent-join]
[2022-06-24T09:33:54,515][INFO][o.e.p.PluginsService] [devnode] loaded module [percolator]
[2022-06-24T09:33:54,515][INFO][o.e.p.PluginsService] [devnode] loaded module [rank-eval]
[2022-06-24T09:33:54,515][INFO][o.e.p.PluginsService] [devnode] loaded module [reindex]
[2022-06-24T09:33:54,515][INFO][o.e.p.PluginsService] [devnode] loaded module [repositories-metering-api]
[2022-06-24T09:33:54,516][INFO][o.e.p.PluginsService] [devnode] loaded module [repository-encrypted]
[2022-06-24T09:33:54,516][INFO][o.e.p.PluginsService] [devnode] loaded module [repository-url]
[2022-06-24T09:33:54,516][INFO][o.e.p.PluginsService] [devnode] loaded module [runtime-fields-common]
[2022-06-24T09:33:54,516][INFO][o.e.p.PluginsService] [devnode] loaded module [search-business-rules]
[2022-06-24T09:33:54,516][INFO][o.e.p.PluginsService] [devnode] loaded module [searchable-snapshots]
[2022-06-24T09:33:54,517][INFO][o.e.p.PluginsService] [devnode] loaded module [snapshot-repo-test-kit]
[2022-06-24T09:33:54,517][INFO][o.e.p.PluginsService] [devnode] loaded module [spatial]
[2022-06-24T09:33:54,517][INFO][o.e.p.PluginsService] [devnode] loaded module [systemd]
[2022-06-24T09:33:54,517][INFO][o.e.p.PluginsService] [devnode] loaded module [transform]
[2022-06-24T09:33:54,517][INFO][o.e.p.PluginsService] [devnode] loaded module [transport-netty4]
[2022-06-24T09:33:54,517][INFO][o.e.p.PluginsService] [devnode] loaded module [unsigned-long]
[2022-06-24T09:33:54,518][INFO][o.e.p.PluginsService] [devnode] loaded module [vector-tile]
[2022-06-24T09:33:54,518][INFO][o.e.p.PluginsService] [devnode] loaded module [vectors]
[2022-06-24T09:33:54,518][INFO][o.e.p.PluginsService] [devnode] loaded module [wildcard]
[2022-06-24T09:33:54,518][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-aggregate-metric]
[2022-06-24T09:33:54,518][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-analytics]
[2022-06-24T09:33:54,518][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-async]
[2022-06-24T09:33:54,519][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-async-search]
[2022-06-24T09:33:54,519][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-autoscaling]
[2022-06-24T09:33:54,519][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-ccr]
[2022-06-24T09:33:54,520][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-core]
[2022-06-24T09:33:54,520][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-data-streams]
[2022-06-24T09:33:54,520][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-deprecation]
[2022-06-24T09:33:54,520][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-enrich]
[2022-06-24T09:33:54,520][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-eql]
[2022-06-24T09:33:54,521][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-fleet]
[2022-06-24T09:33:54,521][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-graph]
[2022-06-24T09:33:54,521][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-identity-provider]
[2022-06-24T09:33:54,521][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-ilm]
[2022-06-24T09:33:54,521][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-logstash]
[2022-06-24T09:33:54,521][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-ml]
[2022-06-24T09:33:54,522][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-monitoring]
[2022-06-24T09:33:54,522][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-ql]
[2022-06-24T09:33:54,522][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-rollup]
[2022-06-24T09:33:54,522][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-security]
[2022-06-24T09:33:54,522][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-shutdown]
[2022-06-24T09:33:54,522][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-sql]
[2022-06-24T09:33:54,523][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-stack]
[2022-06-24T09:33:54,523][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-text-structure]
[2022-06-24T09:33:54,523][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-voting-only-node]
[2022-06-24T09:33:54,523][INFO][o.e.p.PluginsService] [devnode] loaded module [x-pack-watcher]
[2022-06-24T09:33:54,524][INFO][o.e.p.PluginsService] [devnode] no plugins loaded
[2022-06-24T09:33:54,598][INFO][o.e.e.NodeEnvironment] [devnode] using [1] data paths, mounts [[/var (/dev/mapper/rhel-var)]], net usable_space [2.1gb], net total_space [4.9gb], types [xfs]
[2022-06-24T09:33:54,599][INFO][o.e.e.NodeEnvironment] [devnode] heap size [3.8gb], compressed ordinary object pointers [true]
[2022-06-24T09:33:54,782][INFO][o.e.n.Node] [devnode] node name [devnode], node ID [3CE5kAlvThOw74egj_ixCg], cluster name [dev-elk-nehr], roles [transform, data_frozen, master, remote_cluster_client, data, ml, data_content, data_hot, data_warm, data_cold, ingest]
[2022-06-24T09:33:59,809][INFO][o.e.x.m.p.l.CppLogMessageHandler] [devnode] [controller/1727044] [Main.cc@122] controller (64 bit): Version 7.15.2 (Build 65497bb5299534) Copyright (c) 2021 Elasticsearch BV
[2022-06-24T09:34:00,301][INFO][o.e.x.s.a.Realms] [devnode] license mode is [trial], currently licensed security realms are [reserved/reserved,file/default_file,native/default_native]
[2022-06-24T09:34:00,310][INFO][o.e.x.s.a.s.FileRolesStore] [devnode] parsed [0] roles from file [/etc/elasticsearch/roles.yml]
[2022-06-24T09:34:01,107][INFO][o.e.i.g.LocalDatabases] [devnode] initialized default databases [[GeoLite2-Country.mmdb, GeoLite2-City.mmdb, GeoLite2-ASN.mmdb]], config databases [[]] and watching [/etc/elasticsearch/ingest-geoip] for changes
[2022-06-24T09:34:01,108][INFO][o.e.i.g.DatabaseRegistry] [devnode] initialized database registry, using geoip-databases directory [/tmp/elasticsearch-7821483053189598030/geoip-databases/3CE5kAlvThOw74egj_ixCg]
[2022-06-24T09:34:01,763][INFO][o.e.t.NettyAllocator] [devnode] creating NettyAllocator with the following configs: [name=elasticsearch_configured, chunk_size=1mb, suggested_max_allocation_size=1mb, factors={es.unsafe.use_netty_default_chunk_and_page_size=false, g1gc_enabled=true, g1gc_region_size=4mb}]
[2022-06-24T09:34:01,830][INFO][o.e.d.DiscoveryModule] [devnode] using discovery type [zen] and seed hosts providers [settings]
[2022-06-24T09:34:02,314][INFO][o.e.g.DanglingIndicesState] [devnode] gateway.auto_import_dangling_indices is disabled, dangling indices will not be automatically detected or imported and must be managed manually
[2022-06-24T09:34:02,791][INFO][o.e.n.Node] [devnode] initialized
[2022-06-24T09:34:02,792][INFO][o.e.n.Node] [devnode] starting ...
[2022-06-24T09:34:02,809][INFO][o.e.x.s.c.f.PersistentCache] [devnode] persistent cache index loaded
[2022-06-24T09:34:02,908][INFO][o.e.t.TransportService] [devnode] publish_address {IPADDRESS:9300}, bound_addresses {0.0.0.0:9300}
[2022-06-24T09:34:05,516][INFO][o.e.b.BootstrapChecks] [devnode] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2022-06-24T09:34:05,519][ERROR][o.e.b.Bootstrap] [devnode] node validation exception
[1] bootstrap checks failed. You must address the points described in the following [1] lines before starting Elasticsearch.
bootstrap check failure [1] of [1]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
[2022-06-24T09:34:05,550][INFO][o.e.n.Node] [devnode] stopping ...
[2022-06-24T09:34:05,586][INFO][o.e.n.Node] [devnode] stopped
[2022-06-24T09:34:05,586][INFO][o.e.n.Node] [devnode] closing ...
[2022-06-24T09:34:05,594][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [devnode] fatal error in thread [Thread-3], exiting
java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
        at org.elasticsearch.systemd.Libsystemd.lambda$static$0(Libsystemd.java:23) ~[?:?]
        at java.security.AccessController.doPrivileged(AccessController.java:318) ~[?:?]
        at org.elasticsearch.systemd.Libsystemd.<clinit>(Libsystemd.java:22) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.sd_notify(SystemdPlugin.java:115) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.close(SystemdPlugin.java:141) ~[?:?]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:74) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:116) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:99) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.node.Node.close(Node.java:1120) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:74) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:116) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:66) ~[elasticsearch-core-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Bootstrap$4.run(Bootstrap.java:184) ~[elasticsearch-7.15.2.jar:7.15.2]

```

I hope this helps.

Thank you @warkolm 🙂

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [June 24, 2022, 2:38am UTC](https://discuss.elastic.co/t/unable-to-start-the-elasticsearch-service/308065/5 "2022-06-24T02:38:28Z")

</div>

> [@rrrrrrrrrrr](#):
>
> ```auto
> [2022-06-24T09:34:05,519][ERROR][o.e.b.Bootstrap] [devnode] node validation exception
> [1] bootstrap checks failed. You must address the points described in the following [1] lines before starting Elasticsearch.
> bootstrap check failure [1] of [1]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
> 
> ```

You should check this - [System call filter check | Elasticsearch Guide [8.11] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/_system_call_filter_check.html)

---

<div class="post-metadata">

**Author:** ![rrrrrrrrrrr](https://avatars.discourse-cdn.com/v4/letter/r/50afbb/32.png) [@rrrrrrrrrrr](https://discuss.elastic.co/u/rrrrrrrrrrr)\
**Post date:** [June 28, 2022, 9:12am UTC](https://discuss.elastic.co/t/unable-to-start-the-elasticsearch-service/308065/6 "2022-06-28T09:12:18Z")

</div>

Hi @warkolm thank you for sharing the reference. However, upon checking even though its not recommended, I've tried to set the `bootstrap.system_call_filter: false` but elasticsearch cannot be started. To give you a brief background, the elasticsearch has been working for N months. Is it possible that it was affected by the upgrades in the environment if there's any?

---

<div class="post-metadata">

**Author:** ![rrrrrrrrrrr](https://avatars.discourse-cdn.com/v4/letter/r/50afbb/32.png) [@rrrrrrrrrrr](https://discuss.elastic.co/u/rrrrrrrrrrr)\
**Post date:** [July 1, 2022, 1:25am UTC](https://discuss.elastic.co/t/unable-to-start-the-elasticsearch-service/308065/7 "2022-07-01T01:25:25Z")

</div>

I was able to resolve the issue by temporary disabling the `bootstrap.system_call_filter` on elasticsearch.yml. After that I've tried to start and look at the logs again and resolve the new error by following this steps. [Install Elasticsearch in Cpanel – CentOS / java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native – Mellowhost Blog](https://mellowhost.com/blog/install-elasticsearch-in-cpanel-centos-java-lang-noclassdeffounderror-could-not-initialize-class-com-sun-jna-native.html)

```auto
[2022-06-30T10:05:42,241][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [devnode] fatal error in thread [main], exiting
java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
        at org.elasticsearch.systemd.Libsystemd.lambda$static$0(Libsystemd.java:23) ~[?:?]
        at java.security.AccessController.doPrivileged(AccessController.java:318) ~[?:?]
        at org.elasticsearch.systemd.Libsystemd.<clinit>(Libsystemd.java:22) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.sd_notify(SystemdPlugin.java:115) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.onNodeStarted(SystemdPlugin.java:126) ~[?:?]
        at java.util.ArrayList.forEach(ArrayList.java:1511) ~[?:?]
        at org.elasticsearch.node.Node.start(Node.java:998) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:313) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:408) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:167) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:158) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:75) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:114) ~[elasticsearch-cli-7.15.2.jar:7.15.2]
        at org.elasticsearch.cli.Command.main(Command.java:79) ~[elasticsearch-cli-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:123) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:81) ~[elasticsearch-7.15.2.jar:7.15.2]

```

Thank you!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 29, 2022, 1:26am UTC](https://discuss.elastic.co/t/unable-to-start-the-elasticsearch-service/308065/8 "2022-07-29T01:26:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
