# Unable to take snapshot on S3

**URL:** <https://discuss.elastic.co/t/unable-to-take-snapshot-on-s3/107880>\
**Category:** Elasticsearch\
**Created:** [November 16, 2017, 8:30am UTC](https://discuss.elastic.co/t/unable-to-take-snapshot-on-s3/107880 "2017-11-16T08:30:41Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![jogaco](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jogaco/32/4722_2.png) [@jogaco](https://discuss.elastic.co/u/jogaco)\
**Post date:** [November 16, 2017, 8:30am UTC](https://discuss.elastic.co/t/unable-to-take-snapshot-on-s3/107880/1 "2017-11-16T08:30:41Z")

</div>

Latests days I am getting this error while running a snapshot on S3 repository:

```
	{
  "error" : {
	"root_cause" : [
	  {
		"type" : "amazon_client_exception",
		"reason" : "Unable to execute HTTP request: connect timed out"
	  }
	],
	"type" : "amazon_client_exception",
	"reason" : "Unable to execute HTTP request: connect timed out",
	"caused_by" : {
	  "type" : "socket_timeout_exception",
	  "reason" : "connect timed out"
	}
  },
  "status" : 500
}

```

I found some other people getting this error worked around it by setting buffer\_size snapshot repository param to small size (eg: 5mb).

I tried to set this param but got this:

```
	{
   "error": {
	  "root_cause": [
		 {
			"type": "process_cluster_event_timeout_exception",
			"reason": "failed to process cluster event (put_repository [s3-backup]) within 30s"
		 }
	  ],
	  "type": "process_cluster_event_timeout_exception",
	  "reason": "failed to process cluster event (put_repository [s3-backup]) within 30s"
   },
   "status": 503
}

```

In fact, I am getting similar errors when I try to create new snapshot repository:

```
	{
   "error": {
	  "root_cause": [
		 {
			"type": "repository_exception",
			"reason": "[s3-backup-1] failed to create repository"
		 }
	  ],
	  "type": "repository_exception",
	  "reason": "[s3-backup-1] failed to create repository",
	  "caused_by": {
		 "type": "amazon_client_exception",
		 "reason": "Unable to execute HTTP request: connect timed out",
		 "caused_by": {
			"type": "socket_timeout_exception",
			"reason": "connect timed out"
		 }
	  }
   },
   "status": 500
}

```

Any suggestions?

I'm running 5.3.0 single node.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 16, 2017, 9:16am UTC](https://discuss.elastic.co/t/unable-to-take-snapshot-on-s3/107880/2 "2017-11-16T09:16:24Z")

</div>

How many shards in your cluster?

---

<div class="post-metadata">

**Author:** ![jogaco](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jogaco/32/4722_2.png) [@jogaco](https://discuss.elastic.co/u/jogaco)\
**Post date:** [November 16, 2017, 10:05am UTC](https://discuss.elastic.co/t/unable-to-take-snapshot-on-s3/107880/3 "2017-11-16T10:05:45Z")

</div>

Single shard.  
Around 8 million docs, 26 GB size store.

---

<div class="post-metadata">

**Author:** ![jogaco](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jogaco/32/4722_2.png) [@jogaco](https://discuss.elastic.co/u/jogaco)\
**Post date:** [November 19, 2017, 10:08am UTC](https://discuss.elastic.co/t/unable-to-take-snapshot-on-s3/107880/4 "2017-11-19T10:08:21Z")

</div>

Solved by restarting service.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 17, 2017, 10:08am UTC](https://discuss.elastic.co/t/unable-to-take-snapshot-on-s3/107880/5 "2017-12-17T10:08:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
