# Unable to update the index.mapping.total\_fields.limit value

**URL:** https://discuss.elastic.co/t/unable-to-update-the-index-mapping-total-fields-limit-value/311795
**Category:** Elasticsearch
**Created:** [August 10, 2022, 6:38am UTC](https://discuss.elastic.co/t/unable-to-update-the-index-mapping-total-fields-limit-value/311795 "2022-08-10T06:38:00Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Maruthappan\_Muthu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/maruthappan_muthu/32/100807_2.png) [@Maruthappan\_Muthu](https://discuss.elastic.co/u/Maruthappan_Muthu)
#### Post date: [August 10, 2022, 6:38am UTC](https://discuss.elastic.co/t/unable-to-update-the-index-mapping-total-fields-limit-value/311795/1 "2022-08-10T06:38:00Z")

</div>

We are trying to poll the data from a device (PDU) through SNMP Input Plugin. The device MIB file has been imported to ELK logstash, as per [SNMP input plugin | Logstash Reference [8.3] | Elastic](https://www.elastic.co/guide/en/logstash/current/plugins-inputs-snmp.html).  
When executing the snmp.conf by ( /usr/share/logstash/bin/logstash -f /etc/logstash/conf.d/logstash-snmp.conf) getting an error - 'Could not index event to Elasticsearch - Limit of total fields [1000] has been exceeded while adding new fields'.

```auto
[WARN] 2022-08-09 06:05:19.081 [[main]>worker6] elasticsearch - Could not index event to Elasticsearch. {:status=>400, :action=>["index", {:_id=>nil, :_index=>"snmp", :routing=>nil}, {"cpiPduBranchPower.3.12.48.48.48.69.68.51.48.48.70.69.54.48" => 0
:response=>{"index"=>{"_index"=>"snmp", "_id"=>"nh4QgoIBizjuIP1-21th", "status"=>400, "error"=>{"type"=>"mapper_parsing_exception",
"reason"=>"failed to parse", "caused_by"=>{"type"=>"illegal_argument_exception",
"reason"=>"Limit of total fields [1000] has been exceeded while adding new fields [169]"}}}}}

```

Trying to update the default value (1000) to 2000 by using the below command, but the value is not updating.. How do I update this value.

```auto
curl -s -XPUT https://elasticsearchIP/snmp/_settings -H 'Content-Type: application/json' -d '{"index.mapping.total_fields.limit": 2000}'

```

More conversation about this topic on - [Elasticsearch - Could not index event to Elasticsearch status=\>400](https://discuss.elastic.co/t/elasticsearch-could-not-index-event-to-elasticsearch-status-400/311101)  
Please suggest.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [August 10, 2022, 8:26am UTC](https://discuss.elastic.co/t/unable-to-update-the-index-mapping-total-fields-limit-value/311795/2 "2022-08-10T08:26:33Z")

</div>

What happens when you run the curl?

---

<div class="post-metadata">

### Author: ![Maruthappan\_Muthu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/maruthappan_muthu/32/100807_2.png) [@Maruthappan\_Muthu](https://discuss.elastic.co/u/Maruthappan_Muthu)
#### Post date: [August 10, 2022, 9:30am UTC](https://discuss.elastic.co/t/unable-to-update-the-index-mapping-total-fields-limit-value/311795/3 "2022-08-10T09:30:27Z")

</div>

I don't see any error when I run curl. Its just executing smoothly but the value didn't get update.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [August 10, 2022, 9:40am UTC](https://discuss.elastic.co/t/unable-to-update-the-index-mapping-total-fields-limit-value/311795/4 "2022-08-10T09:40:14Z")

</div>

Ok but what happens, please post the command and the output you are seeing. Please do not post an image of it either 🙂

---

<div class="post-metadata">

### Author: ![Maruthappan\_Muthu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/maruthappan_muthu/32/100807_2.png) [@Maruthappan\_Muthu](https://discuss.elastic.co/u/Maruthappan_Muthu)
#### Post date: [August 10, 2022, 10:22am UTC](https://discuss.elastic.co/t/unable-to-update-the-index-mapping-total-fields-limit-value/311795/5 "2022-08-10T10:22:37Z")

</div>

I am able to update the value through Dev Tools on Kibana as below,

```auto
PUT (IndicesName*)/_settings 
{
  "index.mapping.total_fields.limit": 2000
}

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 7, 2022, 10:23am UTC](https://discuss.elastic.co/t/unable-to-update-the-index-mapping-total-fields-limit-value/311795/6 "2022-09-07T10:23:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
