# Unable to upgrade platinum license on elasticsearch 6.3.0

**URL:** https://discuss.elastic.co/t/unable-to-upgrade-platinum-license-on-elasticsearch-6-3-0/163516
**Category:** Elasticsearch
**Tags:** elastic-stack-security
**Created:** [January 9, 2019, 11:17am UTC](https://discuss.elastic.co/t/unable-to-upgrade-platinum-license-on-elasticsearch-6-3-0/163516 "2019-01-09T11:17:32Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Ronnie16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ronnie16/32/66399_2.png) [@Ronnie16](https://discuss.elastic.co/u/Ronnie16)
#### Post date: [January 9, 2019, 11:17am UTC](https://discuss.elastic.co/t/unable-to-upgrade-platinum-license-on-elasticsearch-6-3-0/163516/1 "2019-01-09T11:17:32Z")

</div>

I was trying to upgrade to platinum license for my non prod elk cluster but it threw an error saying either TLS has to be configured or security should be disabled.

But even after disabling the security, I'm not able to update the license under kibana license manager. It shows the same error mentioned above

{  
"name" : "es-coordinating",  
"cluster\_name" : "gbi-cluster",  
"cluster\_uuid" : "z8xmWVSoQWGvtnWWTOFWAQ",  
"version" : {  
"number" : "6.3.0",  
"build\_flavor" : "default",  
"build\_type" : "tar",  
"build\_hash" : "424e937",  
"build\_date" : "2018-06-11T23:38:03.357887Z",  
"build\_snapshot" : false,  
"lucene\_version" : "7.3.1",  
"minimum\_wire\_compatibility\_version" : "5.6.0",  
"minimum\_index\_compatibility\_version" : "5.0.0"  
},  
"tagline" : "You Know, for Search"  
}

---

<div class="post-metadata">

### Author: ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)
#### Post date: [January 9, 2019, 12:26pm UTC](https://discuss.elastic.co/t/unable-to-upgrade-platinum-license-on-elasticsearch-6-3-0/163516/2 "2019-01-09T12:26:29Z")

</div>

> [@Ronnie16](#):
>
> But even after disabling the security,

How did you disable security ? Did you add

```auto
xpack.security.enabled: false

```

to all your nodes' configuration and restarted your cluster?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 6, 2019, 12:26pm UTC](https://discuss.elastic.co/t/unable-to-upgrade-platinum-license-on-elasticsearch-6-3-0/163516/3 "2019-02-06T12:26:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
