# Unable to view or read logs in Kibana

**URL:** <https://discuss.elastic.co/t/unable-to-view-or-read-logs-in-kibana/180564>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [May 10, 2019, 1:17pm UTC](https://discuss.elastic.co/t/unable-to-view-or-read-logs-in-kibana/180564 "2019-05-10T13:17:34Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![krajapraveen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krajapraveen/32/45708_2.png) [@krajapraveen](https://discuss.elastic.co/u/krajapraveen)\
**Post date:** [May 10, 2019, 1:17pm UTC](https://discuss.elastic.co/t/unable-to-view-or-read-logs-in-kibana/180564/1 "2019-05-10T13:17:34Z")

</div>

Hi

I want to display logs in Kibana on Red Hat Enterprise Linux 7.

I have elasticsearch-6.4.0.rpm, kibana-6.4.0-x86\_64.rpm, logstash-6.4.1 and filebeat-5.6.4-x86\_64.rpm installed on Red Hat Enterprise Linux 7.

In /usr/share I have kibana folder in which I have the files/folders as below:  
bin LICENSE.txt node node\_modules NOTICE.txt optimize package.json plugins README.txt src webpackShims yarn.lock

In /etc I have kibana file/folder in which I have one file as below:  
kibana.yml

I have opened the kibana.yml file and uncommented for some content. The uncommented contents are as follows:  
elasticsearch.url: "[http://localhost:9200](http://localhost:9200/)"  
logging.dest: stdout

In /usr/share I have elasticsearch folder in which I have the files/folders as below:  
bin lib LICENSE.txt modules NOTICE.txt plugins README.textile

In /etc I have elasticsearch folder in which I have files/folders as below:  
elasticsearch.keystore elasticsearch.yml jvm.options log4j2.properties role\_mapping.yml roles.yml users users\_roles

* * *

My filebeat.yml is very simple and is as follows:

filebeat.inputs:

- type: log  
enabled: true  
paths:
  - /var/log/sample.log  
output.elasticsearch:  
hosts: ["localhost:9200"]

* * *

To run:

I am running elasticsearch by giving the following command:  
sudo /etc/init.d/elasticsearch start

I am running kibana by giving the following command:  
sudo /etc/init.d/kibana start

I am running filebeat by giving the command as follows:  
./filebeat -c /etc/filebeat/filebeat.yml -e -d "\*"

I am getting errors as below:

2019/05/10 13:04:26.850636 beat.go:297: INFO Home path: [/usr/share/filebeat/bin] Config path: [/usr/share/filebeat/bin] Data path: [/usr/share/filebeat/bin/data] Logs path: [/usr/share/filebeat/bin/logs]  
2019/05/10 13:04:26.850677 beat.go:192: INFO Setup Beat: filebeat; Version: 5.6.4  
2019/05/10 13:04:26.850689 processor.go:44: DBG Processors:  
2019/05/10 13:04:26.850700 beat.go:198: DBG Initializing output plugins  
2019/05/10 13:04:26.850842 output.go:258: INFO Loading template enabled. Reading template file: /usr/share/filebeat/bin/filebeat.template.json  
2019/05/10 13:04:26.851095 outputs.go:102: ERR failed to initialize elasticsearch plugin as output: Error loading template /usr/share/filebeat/bin/filebeat.template.json: EOF  
2019/05/10 13:04:26.851112 beat.go:346: CRIT Exiting: error initializing publisher: Error loading template /usr/share/filebeat/bin/filebeat.template.json: EOF  
Exiting: error initializing publisher: Error loading template /usr/share/filebeat/bin/filebeat.template.json: EOF

Can you please help me on this.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 7, 2019, 1:17pm UTC](https://discuss.elastic.co/t/unable-to-view-or-read-logs-in-kibana/180564/2 "2019-06-07T13:17:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
