# Unassigned ilm-history shard cluster in RED state

**URL:** <https://discuss.elastic.co/t/unassigned-ilm-history-shard-cluster-in-red-state/246970>\
**Category:** Elasticsearch\
**Tags:** ilm-index-lifecycle-management\
**Created:** [August 31, 2020, 2:22pm UTC](https://discuss.elastic.co/t/unassigned-ilm-history-shard-cluster-in-red-state/246970 "2020-08-31T14:22:30Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Petr.Simik](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/petr.simik/32/38082_2.png) [@Petr.Simik](https://discuss.elastic.co/u/Petr.Simik)\
**Post date:** [August 31, 2020, 2:22pm UTC](https://discuss.elastic.co/t/unassigned-ilm-history-shard-cluster-in-red-state/246970/1 "2020-08-31T14:22:30Z")

</div>

dufing upgrade 7.4.2 -\> 7.9 I received an error

```auto
"failed shard on node [GnAJTEqpTeyawpDyUli4Aw]: failed to create index, failure IllegalArgumentException[unknown setting [index.hidden] please check that any required plugins are installed, or check the breaking changes documentation for removed settings]",

shard has exceeded the maximum number of retries [5] on failed allocation attempts - manually call [/_cluster/reroute?retry_failed=true]

```

so I executed recommended command:

```auto
 curl -X POST -u elastic:xxxxxxx "http://localhost:9200/_cluster/reroute?retry_failed=true"

```

but cluster become RED state!!!

```auto
curl -XGET -u elastic:xxxxxx "http://localhost:9200/_cat/health"
1598883387 14:16:27 corp-cz-cem red 21 17 1336 711 0 0 2 0 - 99.9%

```

I found this shards are unallocated

```auto
curl -s -XGET -u elastic:xxxxxx "http://localhost:9200/_cat/shards" |grep -v STARTED
ilm-history-2-000001 0 p UNASSIGNED
ilm-history-2-000001 0 r UNASSIGNED

```

please could you help?  
my production cluster is down and I am looking for any solution

---

<div class="post-metadata">

**Author:** ![Petr.Simik](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/petr.simik/32/38082_2.png) [@Petr.Simik](https://discuss.elastic.co/u/Petr.Simik)\
**Post date:** [August 31, 2020, 5:49pm UTC](https://discuss.elastic.co/t/unassigned-ilm-history-shard-cluster-in-red-state/246970/2 "2020-08-31T17:49:13Z")

</div>

resolved by  
i do not know why this has happended byt  
I could just delete the shards and problem resolved.

DELETE ilm-history-2-000001

> [@Ilm-history-2-000001 UNASSIGNED, primary shard for this replica is not yet active](https://discuss.elastic.co/t/ilm-history-2-000001-unassigned-primary-shard-for-this-replica-is-not-yet-active/246978):
>
> Please I need critical help with cluster in state RED after upgrade 7.4.2-\>7.9 during upgrade of 5th node of 15 it did not recover it health to 100% but 99% all indices are green except 2 shards index shard prirep state docs store ip node ilm-history-2-000001 0 p UNASSIGNED ilm-history-2-000001 0 r UNASSIGNED primary shard for this replica is not yet active {…

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 28, 2020, 5:49pm UTC](https://discuss.elastic.co/t/unassigned-ilm-history-shard-cluster-in-red-state/246970/3 "2020-09-28T17:49:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
