# Undefined method \`sanitized'

**URL:** https://discuss.elastic.co/t/undefined-method-sanitized/100588
**Category:** Logstash
**Created:** [September 14, 2017, 6:37pm UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588 "2017-09-14T18:37:05Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![feijiangnan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/feijiangnan/32/20893_2.png) [@feijiangnan](https://discuss.elastic.co/u/feijiangnan)
#### Post date: [September 14, 2017, 6:37pm UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588/1 "2017-09-14T18:37:05Z")

</div>

Hi there,  
I upgraded ELK from 5.5. to 5.6, and logstash received the log, parsed, but didn't write to elasticsearch. From log, it complains ""undefined method `sanitized' ", logstash-output-elasticsearch version is 7.4.0

Please help.

Thanks and Regards,  
Fei

[2017-09-14T14:30:11,367][DEBUG][logstash.pipeline] output received {"event"=\>{"@timestamp"=\>2017-09-14T18:30:05.000Z, "offset"=\>9574607, "apache2"=\>{"access"=\>{"referrer"=\>"-", "response\_code"=\>"200", "remote\_ip"=\>"13.115.21.9", "geoip"=\>{"timezone"=\>"America/Toronto", "ip"=\>"13.115.21.9", "latitude"=\>43.7334, "continent\_code"=\>"NA", "city\_name"=\>"Toronto", "country\_name"=\>"Canada", "country\_code2"=\>"CA", "country\_code3"=\>"CA", "region\_name"=\>"Ontario", "location"=\>{"lon"=\>-79.3329, "lat"=\>43.7334}, "postal\_code"=\>"m3c 3n3", "region\_code"=\>"ON", "longitude"=\>-79.3329}, "method"=\>"LOCK", "user\_name"=\>"ykozhem", "http\_version"=\>"1.1", "body\_sent"=\>{"bytes"=\>"378"}, "url"=\>"/csis/trunk/ddl\_applications/CSISPROD/Functions/get\_future\_date.sql", "user\_agent"=\>{"name"=\>"Other", "os\_name"=\>"Other", "os"=\>"Other", "device"=\>"Other", "build"=\>""}}}, "@version"=\>"1", "input\_type"=\>"log", "beat"=\>{"name"=\>"jenkins", "hostname"=\>"jenkins", "version"=\>"5.5.2"}, "host"=\>"jenkins", "read\_timestamp"=\>"2017-09-14T18:30:08.222Z", "source"=\>"/var/log/httpd/access\_log", "fields"=\>{"document\_type"=\>"svn\_access\_log"}, "type"=\>"log", "tags"=\>["beats\_input\_codec\_plain\_applied"]}}  
[2017-09-14T14:30:14,092][DEBUG][logstash.pipeline] Pushing flush onto pipeline  
[2017-09-14T14:30:15,742][ERROR][logstash.outputs.elasticsearch] Encountered an unexpected error submitting a bulk request! Will retry. {:error\_message=\>"undefined method `sanitized' for #<String:0x3145e6f7>", :class=>"NoMethodError", :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:249:in`safe\_bulk'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:222:in `safe_bulk'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:119:in`submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:87:in `retrying_submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:38:in`multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output\_delegator\_strategies/shared.rb:13:in `multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output_delegator.rb:49:in`multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:436:in `output_batch'", "org/jruby/RubyHash.java:1342:in`each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:435:in `output_batch'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:381:in`worker\_loop'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:342:in `start\_workers'"]}

---

<div class="post-metadata">

### Author: ![Erik\_Mathis](https://avatars.discourse-cdn.com/v4/letter/e/65b543/32.png) [@Erik\_Mathis](https://discuss.elastic.co/u/Erik_Mathis)
#### Post date: [September 14, 2017, 8:23pm UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588/2 "2017-09-14T20:23:51Z")

</div>

I started getting that error also today after I installed x-pack. I removed and that seems to have fixed the problem.

I guess I'll look into x-pack more tomorrow.

---

<div class="post-metadata">

### Author: ![feijiangnan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/feijiangnan/32/20893_2.png) [@feijiangnan](https://discuss.elastic.co/u/feijiangnan)
#### Post date: [September 15, 2017, 11:47am UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588/3 "2017-09-15T11:47:52Z")

</div>

I updated all Logstash plugins, logstash-output-elasticsearch (8.1.1)

now got below error:  
undefined method `body'

[2017-09-15T07:39:08,104][ERROR][logstash.outputs.elasticsearch] Encountered an unexpected error submitting a bulk request! Will retry. {:error\_message=\>"undefined method `body' for #<LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError:0x7bf1351>", :class=>"NoMethodError", :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-8.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:251:in`safe\_bulk'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-8.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:223:in `safe_bulk'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-8.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:113:in`submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-8.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:81:in `retrying_submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-8.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:33:in`multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output\_delegator\_strategies/shared.rb:13:in `multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output_delegator.rb:49:in`multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:436:in `output_batch'", "org/jruby/RubyHash.java:1342:in`each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:435:in `output_batch'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:381:in`worker\_loop'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:342:in `start\_workers'"]}

---

<div class="post-metadata">

### Author: ![feijiangnan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/feijiangnan/32/20893_2.png) [@feijiangnan](https://discuss.elastic.co/u/feijiangnan)
#### Post date: [September 15, 2017, 3:32pm UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588/4 "2017-09-15T15:32:37Z")

</div>

After removed x-pack, got infinite loop like below:

[2017-09-15T07:36:27,607][DEBUG][logstash.plugins.registry] Adding plugin to the registry {:name=\>"fb\_apache", :type=\>:modules, :class=\>#\<LogStash::Modules::Scaffold:0x30f9a63b @kibana\_version\_parts=["5", "6", "0"], @module\_name="fb\_apache", @directory="/usr/share/logstash/modules/fb\_apache/configuration"\>}  
[2017-09-15T07:36:27,608][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"netflow", :directory=\>"/usr/share/logstash/modules/netflow/configuration"}

---

<div class="post-metadata">

### Author: ![PhaedrusTheGreek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phaedrusthegreek/32/4884_2.png) [@PhaedrusTheGreek](https://discuss.elastic.co/u/PhaedrusTheGreek)
#### Post date: [September 22, 2017, 2:56pm UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588/5 "2017-09-22T14:56:25Z")

</div>

This error is due to a security permissions problem with the user configured in the output. The error message displayed is obviously a mistake, and has been fixed in version 7.4.2 of the output plugin:

$ bin/logstash-plugin update logstash-output-elasticsearch  
Updating logstash-output-elasticsearch  
Updated logstash-output-elasticsearch 7.4.1 to 7.4.2

Now you should receive a sane error,

```auto
[2017-09-22T10:43:56,826][ERROR][logstash.outputs.elasticsearch] Encountered a retryable error. Will Retry with exponential backoff {:code=>403, :url=>"http://127.0.0.1:9200/_bulk"}

```

, which indicates that the user does not have permission to index data. In order to create a dedicated logstash write user, see [this guide](https://www.elastic.co/guide/en/x-pack/current/logstash.html#ls-http-auth-basic), or use the **elastic** superuser while testing.

---

<div class="post-metadata">

### Author: ![feijiangnan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/feijiangnan/32/20893_2.png) [@feijiangnan](https://discuss.elastic.co/u/feijiangnan)
#### Post date: [September 22, 2017, 7:05pm UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588/6 "2017-09-22T19:05:31Z")

</div>

Thanks, I will try it and update you.

---

<div class="post-metadata">

### Author: ![Hush077](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hush077/32/22500_2.png) [@Hush077](https://discuss.elastic.co/u/Hush077)
#### Post date: [September 25, 2017, 8:47pm UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588/7 "2017-09-25T20:47:58Z")

</div>

I'm getting this error after a clean install of 5.6.1. I updated the plugins and now I'm getting the issue I posted about here. [Logstash 5.6.1 inifinite loop? Encountered a retryable error](https://discuss.elastic.co/t/logstash-5-6-1-inifinite-loop-encountered-a-retryable-error/101753/3)

@PhaedrusTheGreek any help would be appreciated.

---

<div class="post-metadata">

### Author: ![Nitin\_Yadav](https://avatars.discourse-cdn.com/v4/letter/n/4af34b/32.png) [@Nitin\_Yadav](https://discuss.elastic.co/u/Nitin_Yadav)
#### Post date: [October 11, 2017, 7:27am UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588/8 "2017-10-11T07:27:38Z")

</div>

I could not find the solution but have a workaround for this. I have fresh installation of logstash 5.6.3 and using logstash-output-elasticsearch plugin version 9.0.0(upgraded from 7.4.2)

Error:  
[2017-10-11T06:52:46,492][ERROR][logstash.outputs.elasticsearch] Encountered an unexpected error submitting a bulk request! Will retry. {:error\_message=\>"undefined method `sanitized' for \"/_bulk\":String", :cl ass=>"NoMethodError", :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-9.0.0-java/lib/logstash/outputs/elasticsearch/common.rb:250:in`safe\_bulk'", "/usr/share/logsta  
sh/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-9.0.0-java/lib/logstash/outputs/elasticsearch/common.rb:113:in `submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elastics earch-9.0.0-java/lib/logstash/outputs/elasticsearch/common.rb:81:in`retrying\_submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-9.0.0-java/lib/logstash/outputs/elasticsea  
rch/common.rb:33:in `multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output_delegator_strategies/shared.rb:13:in`multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output\_delegat  
or.rb:49:in `multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:434:in`output\_batch'", "org/jruby/RubyHash.java:1342:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeli ne.rb:433:in`output\_batch'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:381:in `worker_loop'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:342:in`start\_workers'"]}

This occurs during error handling and url sanitisation method in mentioned ruby file common.rb line 250:  
Changed  
log\_hash = {:code =\> e.response\_code, :url =\> e.url.sanitized.to\_s}  
to  
log\_hash = {:code =\> e.response\_code, :url =\> e.url, :body =\> e.response\_body }

Now that I am not sanitizing url, hence getting below appropriate message in logs:  
[2017-10-11T07:14:25,097][ERROR][logstash.outputs.elasticsearch] Encountered a retryable error. Will Retry with exponential backoff {:code=\>404, :url=\>"/\_bulk", :body=\>"{"error":{"root\_cause":[{"type":"index\_not\_found\_exception","reason":"no such index and [action.auto\_create\_index] ([prod\*,.security,.monitoring\*,.watches,.triggered\_watches,.watcher-history\*]) doesn't match","index\_uuid":"_na_","index":"logstash-2017.10.11"}],"type":"index\_not\_found\_exception","reason":"no such index and [action.auto\_create\_index] ([prod\*,.security,.monitoring\*,.watches,.triggered\_watches,.watcher-history\*]) doesn't match","index\_uuid":"_na_","index":"logstash-2017.10.11"},"status":404}"}

This was the error due to configuration in elasticsearch.yml file which allowed only certain index pattern to be created automatically. Changed configuration in yml and finally index was created.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 8, 2017, 7:27am UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588/9 "2017-11-08T07:27:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
