# Undefined method \`sanitized'

**URL:** <https://discuss.elastic.co/t/undefined-method-sanitized/100588>\
**Category:** Logstash\
**Created:** [September 14, 2017, 6:37pm UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588 "2017-09-14T18:37:05Z")\
**Posts on this page:** 1\
**Showing post:** 5

<div class="post-metadata">

**Author:** ![PhaedrusTheGreek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phaedrusthegreek/32/4884_2.png) [@PhaedrusTheGreek](https://discuss.elastic.co/u/PhaedrusTheGreek)\
**Post date:** [September 22, 2017, 2:56pm UTC](https://discuss.elastic.co/t/undefined-method-sanitized/100588/5 "2017-09-22T14:56:25Z")

</div>

This error is due to a security permissions problem with the user configured in the output. The error message displayed is obviously a mistake, and has been fixed in version 7.4.2 of the output plugin:

$ bin/logstash-plugin update logstash-output-elasticsearch  
Updating logstash-output-elasticsearch  
Updated logstash-output-elasticsearch 7.4.1 to 7.4.2

Now you should receive a sane error,

```auto
[2017-09-22T10:43:56,826][ERROR][logstash.outputs.elasticsearch] Encountered a retryable error. Will Retry with exponential backoff {:code=>403, :url=>"http://127.0.0.1:9200/_bulk"}

```

, which indicates that the user does not have permission to index data. In order to create a dedicated logstash write user, see [this guide](https://www.elastic.co/guide/en/x-pack/current/logstash.html#ls-http-auth-basic), or use the **elastic** superuser while testing.

---

_[View the full topic](https://discuss.elastic.co/t/undefined-method-sanitized/100588)._
