# Unexpected error while indexing monitoring document with 7.0

**URL:** https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document-with-7-0/176463
**Category:** Elasticsearch
**Created:** [April 11, 2019, 5:12pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document-with-7-0/176463 "2019-04-11T17:12:14Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![opoplawski](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/opoplawski/32/40442_2.png) [@opoplawski](https://discuss.elastic.co/u/opoplawski)
#### Post date: [April 11, 2019, 5:12pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document-with-7-0/176463/1 "2019-04-11T17:12:14Z")

</div>

I'm trying to update to 7.0.0, and I'm getting _lots_ of these:

```
[2019-04-11T09:05:47,285][WARN][o.e.x.m.e.l.LocalExporter] [elk.nwra.com] unexpected error while indexing monitoring document
org.elasticsearch.xpack.monitoring.exporter.ExportException: [.monitoring-es-7-2019.04.11] IndexCreationException[failed to create index [.monitoring-es-7-2019.04.11]]; nested: ValidationException[Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2683]/[1000] maximum shards open;];
        at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.lambda$throwExportException$2(LocalBulk.java:128) ~[x-pack-monitoring-7.0.0.jar:7.0.0]

```

I know I have too many shards, and I have:

elasticsearch.yml:cluster.max\_shards\_per\_node: 10000

to try to deal with it temporarily - but it seems that this setting isn't taking effect, at least not for this application?

---

<div class="post-metadata">

### Author: ![opoplawski](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/opoplawski/32/40442_2.png) [@opoplawski](https://discuss.elastic.co/u/opoplawski)
#### Post date: [April 11, 2019, 5:40pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document-with-7-0/176463/2 "2019-04-11T17:40:45Z")

</div>

For now I've disabled monitoring with:

```
xpack.monitoring.enabled: false

```

in elasticsearch.yml and that has gotten rid of the flood of errors.

---

<div class="post-metadata">

### Author: ![opoplawski](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/opoplawski/32/40442_2.png) [@opoplawski](https://discuss.elastic.co/u/opoplawski)
#### Post date: [April 11, 2019, 5:43pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document-with-7-0/176463/3 "2019-04-11T17:43:17Z")

</div>

But now kibana will not start for the same reason:

```
kibana[28944]: FATAL [index_creation_exception] failed to create index [.kibana_5]
\"validation_exception\",\"reason\":\"Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2683]/[1000] maximum shards open;\"}
```

---

<div class="post-metadata">

### Author: ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)
#### Post date: [April 11, 2019, 6:28pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document-with-7-0/176463/4 "2019-04-11T18:28:29Z")

</div>

This is a known [bug](https://github.com/elastic/elasticsearch/issues/40803).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 9, 2019, 6:28pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document-with-7-0/176463/5 "2019-05-09T18:28:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
