# Unexpected error while indexing monitoring document

**URL:** <https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document/86259>\
**Category:** Elasticsearch\
**Created:** [May 18, 2017, 12:46pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document/86259 "2017-05-18T12:46:48Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![dodegaard](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dodegaard/32/18177_2.png) [@dodegaard](https://discuss.elastic.co/u/dodegaard)\
**Post date:** [May 18, 2017, 12:46pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document/86259/1 "2017-05-18T12:46:48Z")

</div>

Yesterday I installed X-Pack on an existing one node dev install on OSX (es 5.4.0, kibana 5.4.0, ls 5.4.0). Worked wonderfully until this morning my machine froze and had to hard boot it. After the reboot (ES was running at the time of the freeze) I cannot get ES going again. Cycles over and over with this java dump.

I am in my trial period in proof of concept to see if this will be beneficial to license.

If I must uninstall and reinstall I can but any simple commands to get it back would be great. Thanks so much!

```
... 10 more

```

[2017-05-18T07:38:41,042][WARN][o.e.x.m.e.l.LocalExporter] unexpected error while indexing monitoring document  
org.elasticsearch.xpack.monitoring.exporter.ExportException: NodeClosedException[node closed {hvK7SwX}{hvK7SwX1RASbDO4R6Eckqw}{TiIbzSf6RMyW8wY4k0J7zg}{127.0.0.1}{127.0.0.1:9300}{ml.enabled=true}]  
at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.lambda$throwExportException$2(LocalBulk.java:131) ~[?:?]  
at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:193) ~[?:1.8.0\_131]  
at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:175) ~[?:1.8.0\_131]  
at java.util.Spliterators$ArraySpliterator.forEachRemaining(Spliterators.java:948) ~[?:1.8.0\_131]  
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481) ~[?:1.8.0\_131]  
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471) ~[?:1.8.0\_131]  
at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151) ~[?:1.8.0\_131]  
at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174) ~[?:1.8.0\_131]  
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:1.8.0\_131]  
at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:418) ~[?:1.8.0\_131]  
at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.throwExportException(LocalBulk.java:132) ~[?:?]  
at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.lambda$doFlush$0(LocalBulk.java:115) ~[?:?]  
at org.elasticsearch.action.ActionListener$1.onResponse(ActionListener.java:59) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.support.ContextPreservingActionListener.onResponse(ContextPreservingActionListener.java:43) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.support.TransportAction$1.onResponse(TransportAction.java:88) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.support.TransportAction$1.onResponse(TransportAction.java:84) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.xpack.security.action.filter.SecurityActionFilter.lambda$apply$0(SecurityActionFilter.java:122) ~[?:?]  
at org.elasticsearch.action.ActionListener$1.onResponse(ActionListener.java:59) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.support.ContextPreservingActionListener.onResponse(ContextPreservingActionListener.java:43) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.bulk.TransportBulkAction$BulkRequestModifier.lambda$wrapActionListenerIfNeeded$0(TransportBulkAction.java:583) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.ActionListener$1.onResponse(ActionListener.java:59) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.bulk.TransportBulkAction$BulkOperation$1.finishHim(TransportBulkAction.java:389) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.bulk.TransportBulkAction$BulkOperation$1.onFailure(TransportBulkAction.java:384) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.support.TransportAction$1.onFailure(TransportAction.java:94) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.ActionListener$1.onFailure(ActionListener.java:67) [elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.support.ContextPreservingActionListener.onFailure(ContextPreservingActionListener.java:50) [elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.support.replication.TransportReplicationAction$ReroutePhase.finishAsFailed(TransportReplicationAction.java:827) [elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.action.support.replication.TransportReplicationAction$ReroutePhase$2.onClusterServiceClose(TransportReplicationAction.java:810) [elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.cluster.ClusterStateObserver$ContextPreservingListener.onClusterServiceClose(ClusterStateObserver.java:304) [elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.cluster.ClusterStateObserver$ObserverClusterStateListener.onClose(ClusterStateObserver.java:224) [elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.cluster.service.ClusterService.doStop(ClusterService.java:229) [elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.stop(AbstractLifecycleComponent.java:88) [elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.node.Node.stop(Node.java:782) [elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.node.Node.close(Node.java:805) [elasticsearch-5.4.0.jar:5.4.0]  
at org.apache.lucene.util.IOUtils.close(IOUtils.java:89) [lucene-core-6.5.0.jar:6.5.0 4b16c9a10c3c00cafaf1fc92ec3276a7bc7b8c95 - jimczi - 2017-03-21 20:40:22]  
at org.apache.lucene.util.IOUtils.close(IOUtils.java:76) [lucene-core-6.5.0.jar:6.5.0 4b16c9a10c3c00cafaf1fc92ec3276a7bc7b8c95 - jimczi - 2017-03-21 20:40:22]  
at org.elasticsearch.bootstrap.Bootstrap$5.run(Bootstrap.java:218) [elasticsearch-5.4.0.jar:5.4.0]  
Caused by: org.elasticsearch.node.NodeClosedException: node closed {hvK7SwX}{hvK7SwX1RASbDO4R6Eckqw}{TiIbzSf6RMyW8wY4k0J7zg}{127.0.0.1}{127.0.0.1:9300}{ml.enabled=true}

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 20, 2017, 11:29pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document/86259/2 "2017-05-20T23:29:34Z")

</div>

Interestingly it's saying that the node cannot contact itself!

What does `_cat/plugins` and `_cat/health` return?

---

<div class="post-metadata">

**Author:** ![dodegaard](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dodegaard/32/18177_2.png) [@dodegaard](https://discuss.elastic.co/u/dodegaard)\
**Post date:** [May 22, 2017, 4:37pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document/86259/3 "2017-05-22T16:37:35Z")

</div>

I uninstalled X-Pack plug in and still not a working es instance. Is there a page that describes completely uninstalling and reinstalling es only as I think the rest of the stack is ok. Thanks.

---

<div class="post-metadata">

**Author:** ![dodegaard](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dodegaard/32/18177_2.png) [@dodegaard](https://discuss.elastic.co/u/dodegaard)\
**Post date:** [May 22, 2017, 4:51pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document/86259/4 "2017-05-22T16:51:50Z")

</div>

Thanks for the reply @warkolm. I just removed ES and reinstalled. All seems to be right with the world again.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 19, 2017, 4:52pm UTC](https://discuss.elastic.co/t/unexpected-error-while-indexing-monitoring-document/86259/5 "2017-06-19T16:52:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
