# Unit logstash.service entered failed state

**URL:** <https://discuss.elastic.co/t/unit-logstash-service-entered-failed-state/292848>\
**Category:** Вопросы на русском языке\
**Created:** [December 23, 2021, 10:38pm UTC](https://discuss.elastic.co/t/unit-logstash-service-entered-failed-state/292848 "2021-12-23T22:38:16Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![cva](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cva/32/85514_2.png) [@cva](https://discuss.elastic.co/u/cva)\
**Post date:** [December 23, 2021, 10:38pm UTC](https://discuss.elastic.co/t/unit-logstash-service-entered-failed-state/292848/1 "2021-12-23T22:38:16Z")

</div>

OS Centos 7.  
Обновил версию logstash до 7.16.2, теперь при запуске получаю следующее  
systemctl status logstash:

```auto
Dec 24 01:27:08 elk systemd[1]: Unit logstash.service entered failed state.
Dec 24 01:27:08 elk systemd[1]: logstash.service failed.
Dec 24 01:27:08 elk systemd[1]: logstash.service holdoff time over, scheduling restart.
Dec 24 01:27:08 elk systemd[1]: Stopped logstash.
Dec 24 01:27:08 elk systemd[1]: start request repeated too quickly for logstash.service
Dec 24 01:27:08 elk systemd[1]: Failed to start logstash.
Dec 24 01:27:08 elk systemd[1]: Unit logstash.service entered failed state.
Dec 24 01:27:08 elk systemd[1]: logstash.service failed.

```

Выполнение команды:

```auto
/usr/share/logstash/bin/system-install /etc/logstash/startup.options systemd

```

результата не дало.

В ручную стартует без ошибок:

```auto
/usr/share/logstash/bin/logstash
Using bundled JDK: /usr/share/logstash/jdk
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties
[2021-12-24T01:01:11,737][INFO][logstash.runner] Log4j configuration path used is: /usr/share/logstash/config/log4j2.properties
[2021-12-24T01:01:11,778][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.16.2", "jruby.version"=>"jruby 9.2.20.1 (2.5.8) 2021-11-30 2a2962fbd1 OpenJDK 64-Bit Server VM 11.0.13+8 on 11.0.13+8 +indy +jit [linux-x86_64]"}
[2021-12-24T01:01:14,170][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600, :ssl_enabled=>false}

```

Почему не хочет запускаться как сервис?

---

<div class="post-metadata">

**Author:** ![cva](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cva/32/85514_2.png) [@cva](https://discuss.elastic.co/u/cva)\
**Post date:** [December 23, 2021, 11:09pm UTC](https://discuss.elastic.co/t/unit-logstash-service-entered-failed-state/292848/2 "2021-12-23T23:09:04Z")

</div>

Запуск с такими параметрами:

```auto
/usr/share/logstash/bin/logstash --path.settings /etc/logstash

```

Выдает ошибку:

```auto
[FATAL] 2021-12-24 02:05:16.675 [main] Logstash - Logstash stopped processing because of an error: (NameError) cannot link Java class org.apache.http.conn.ssl.SSLConnectionSocketFactory, probable missing dependency: 'boolean org.apache.logging.log4j.spi.LoggerContextFactory.isClassLoaderDependent()'

```

---

<div class="post-metadata">

**Author:** ![cva](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cva/32/85514_2.png) [@cva](https://discuss.elastic.co/u/cva)\
**Post date:** [December 23, 2021, 11:36pm UTC](https://discuss.elastic.co/t/unit-logstash-service-entered-failed-state/292848/3 "2021-12-23T23:36:15Z")

</div>

java -version  
openjdk version "1.8.0\_252"

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 20, 2022, 11:36pm UTC](https://discuss.elastic.co/t/unit-logstash-service-entered-failed-state/292848/4 "2022-01-20T23:36:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
