# Unit logstash.service entered failed state

**URL:** https://discuss.elastic.co/t/unit-logstash-service-entered-failed-state/292865
**Category:** Logstash
**Created:** [December 24, 2021, 6:02am UTC](https://discuss.elastic.co/t/unit-logstash-service-entered-failed-state/292865 "2021-12-24T06:02:28Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![cva](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cva/32/85514_2.png) [@cva](https://discuss.elastic.co/u/cva)
#### Post date: [December 24, 2021, 6:02am UTC](https://discuss.elastic.co/t/unit-logstash-service-entered-failed-state/292865/1 "2021-12-24T06:02:28Z")

</div>

Hi!  
OS Centos 7, java -version openjdk version "1.8.0\_252"  
Updated the version of logstash to 7.16.2, now at startup I get the following  
systemctl status logstash:

```auto
Dec 24 01:27:08 elk systemd[1]: Unit logstash.service entered failed state.
Dec 24 01:27:08 elk systemd[1]: logstash.service failed.
Dec 24 01:27:08 elk systemd[1]: logstash.service holdoff time over, scheduling restart.
Dec 24 01:27:08 elk systemd[1]: Stopped logstash.
Dec 24 01:27:08 elk systemd[1]: start request repeated too quickly for logstash.service
Dec 24 01:27:08 elk systemd[1]: Failed to start logstash.
Dec 24 01:27:08 elk systemd[1]: Unit logstash.service entered failed state.
Dec 24 01:27:08 elk systemd[1]: logstash.service failed.

```

Executing the command:

```auto
/usr/share/logstash/bin/system-install /etc/logstash/startup.options systemd

```

did not give the result.

Manually starts without errors:

```auto
/usr/share/logstash/bin/logstash
Using bundled JDK: /usr/share/logstash/jdk
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties
[2021-12-24T01:01:11,737][INFO][logstash.runner] Log4j configuration path used is: /usr/share/logstash/config/log4j2.properties
[2021-12-24T01:01:11,778][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.16.2", "jruby.version"=>"jruby 9.2.20.1 (2.5.8) 2021-11-30 2a2962fbd1 OpenJDK 64-Bit Server VM 11.0.13+8 on 11.0.13+8 +indy +jit [linux-x86_64]"}
[2021-12-24T01:01:14,170][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600, :ssl_enabled=>false}

```

Why doesn't it want to run as a service?

Run with parameters:

```auto
/usr/share/logstash/bin/logstash --path.settings /etc/logstash

```

Gives an error message:

```auto
[FATAL] 2021-12-24 02:05:16.675 [main] Logstash - Logstash stopped processing because of an error: (NameError) cannot link Java class org.apache.http.conn.ssl.SSLConnectionSocketFactory, probable missing dependency: 'boolean org.apache.logging.log4j.spi.LoggerContextFactory.isClassLoaderDependent()'

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 21, 2022, 6:03am UTC](https://discuss.elastic.co/t/unit-logstash-service-entered-failed-state/292865/2 "2022-01-21T06:03:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
