# Unknown error connecting with elasticsearch when using ipv6

**URL:** <https://discuss.elastic.co/t/unknown-error-connecting-with-elasticsearch-when-using-ipv6/171404>\
**Category:** Kibana\
**Created:** [March 8, 2019, 12:17am UTC](https://discuss.elastic.co/t/unknown-error-connecting-with-elasticsearch-when-using-ipv6/171404 "2019-03-08T00:17:00Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![fragatina](https://avatars.discourse-cdn.com/v4/letter/f/ccd318/32.png) [@fragatina](https://discuss.elastic.co/u/fragatina)\
**Post date:** [March 8, 2019, 12:17am UTC](https://discuss.elastic.co/t/unknown-error-connecting-with-elasticsearch-when-using-ipv6/171404/1 "2019-03-08T00:17:00Z")

</div>

Hi, I'm using kibana 6.0 version. I'm using kibana with reverse proxy to convert ipv6 queries to ipv4. Hence kibana and elasticsearch are in localhost (127.0.0.1) but clients can reach kibana using IPv6 queries.

I've tried to remove the reverse proxy and use purely ipv6 but I still have issues.

It seems that kibana is able to display the dashboards (hence it can display the data for the .kibana elasticsearch index) but when I tried to get data from any other index, it displays "Error: unknown error" messages.

When I try to query kibana using IPv4 only, I can get all info fine.

Can somebody suggest something here? Thanks in advance.

I'll provide a picture of the errors and the kibana logs for it in the following posts.

---

<div class="post-metadata">

**Author:** ![fragatina](https://avatars.discourse-cdn.com/v4/letter/f/ccd318/32.png) [@fragatina](https://discuss.elastic.co/u/fragatina)\
**Post date:** [March 8, 2019, 12:31am UTC](https://discuss.elastic.co/t/unknown-error-connecting-with-elasticsearch-when-using-ipv6/171404/2 "2019-03-08T00:31:31Z")

</div>

![kibana_error](https://us1.discourse-cdn.com/elastic/original/3X/9/c/9c12f304a317960d0570b062d57e6290a6e4f67d.png)

This is the kibana error:

---

<div class="post-metadata">

**Author:** ![fragatina](https://avatars.discourse-cdn.com/v4/letter/f/ccd318/32.png) [@fragatina](https://discuss.elastic.co/u/fragatina)\
**Post date:** [March 8, 2019, 12:41am UTC](https://discuss.elastic.co/t/unknown-error-connecting-with-elasticsearch-when-using-ipv6/171404/3 "2019-03-08T00:41:07Z")

</div>

and this is the logs I get from kibana:

```
{"type":"response","@timestamp":"2019-03-07T23:54:33Z","tags":[],"pid":37,"method":"get","statusCode":200,"req":{"url":"/api/saved_objects/?type=dashboard&per_page=1000&page=1&search_fields=title%5E3&search_fields=description","method":"get","headers":{"host":"localhost:5601","accept-language":"en-us","accept-encoding":"br, gzip, deflate","kbn-version":"6.0.0","accept":"application/json, text/plain, */*","user-agent":"Mozilla/5.0","referer":"https://[20<valid_ip_address_here>0]:5601/app/kibana","dnt":"1","x-forwarded-for":"20<valid_ip_address_here>e","x-forwarded-host":"[20<valid_ip_address_here>0]:5601","x-forwarded-server":"elk-host","connection":"Keep-Alive"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1","referer":"https://[20<valid_ip_address_here>0]:5601/app/kibana"},"res":{"statusCode":200,"responseTime":9,"contentLength":9},"message":"GET /api/saved_objects/?type=dashboard&per_page=1000&page=1&search_fields=title%5E3&search_fields=description 200 9ms - 9.0B"}

```

{"type":"response","@timestamp":"2019-03-07T23:54:35Z","tags":,"pid":37,"method":"post","statusCode":200,"req":{"url":"/api/saved\_objects/bulk\_get","method":"post","headers":{"host":"localhost:5601","accept":"application/json, text/plain, _/_","kbn-version":"6.0.0","accept-language":"en-us","accept-encoding":"br, gzip, deflate","content-type":"application/json;charset=UTF-8","origin":"https://[2\<valid\_ip\_address\_here\>0]:5601","user-agent":"Mozilla/5.0","referer":"https://[20\<valid\_ip\_address\_here\>0]:5601/app/kibana","dnt":"1","x-forwarded-for":"20\<valid\_ip\_address\_here\>e","x-forwarded-host":"[20\<valid\_ip\_address\_here\>0]:5601","x-forwarded-server":"elk-host","connection":"Keep-Alive","content-length":"66"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1","referer":"https://[20\<valid\_ip\_address\_here\>0]:5601/app/kibana"},"res":{"statusCode":200,"responseTime":8,"contentLength":9},"message":"POST /api/saved\_objects/bulk\_get 200 8ms - 9.0B"}

No error is displayed in elasticsearch.

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [March 8, 2019, 7:03pm UTC](https://discuss.elastic.co/t/unknown-error-connecting-with-elasticsearch-when-using-ipv6/171404/4 "2019-03-08T19:03:42Z")

</div>

@dover or @tylersmalley - can you please shed some light here?

---

<div class="post-metadata">

**Author:** ![fragatina](https://avatars.discourse-cdn.com/v4/letter/f/ccd318/32.png) [@fragatina](https://discuss.elastic.co/u/fragatina)\
**Post date:** [April 1, 2019, 11:19am UTC](https://discuss.elastic.co/t/unknown-error-connecting-with-elasticsearch-when-using-ipv6/171404/5 "2019-04-01T11:19:23Z")

</div>

do you have any suggestion on this?

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [April 17, 2019, 2:18pm UTC](https://discuss.elastic.co/t/unknown-error-connecting-with-elasticsearch-when-using-ipv6/171404/6 "2019-04-17T14:18:36Z")

</div>

Can you please show us more verbose logs from Kibana ? And also share your config ?

Thanks  
Rashmi

---

<div class="post-metadata">

**Author:** ![fragatina](https://avatars.discourse-cdn.com/v4/letter/f/ccd318/32.png) [@fragatina](https://discuss.elastic.co/u/fragatina)\
**Post date:** [April 29, 2019, 3:14am UTC](https://discuss.elastic.co/t/unknown-error-connecting-with-elasticsearch-when-using-ipv6/171404/7 "2019-04-29T03:14:21Z")

</div>

Hi Rashmi,

thanks for your response. I don't have a kibana 6.x anymore. If it's useful, I found out that the issue was when kibana communicates the IPv6 to elasticsearch. My suspiction is something to do with the [] to the IPv6 address on the url that elasticsearch received.

Since that time I noticed that this issue is fixed with 7.0.0. Not sure if you can point out what fixed this issue but it's gone with latest release.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 27, 2019, 3:14am UTC](https://discuss.elastic.co/t/unknown-error-connecting-with-elasticsearch-when-using-ipv6/171404/8 "2019-05-27T03:14:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
