# Unknown secure setting \[secure\_bind\_password\] please check that any required plugins are installed

**URL:** https://discuss.elastic.co/t/unknown-secure-setting-secure-bind-password-please-check-that-any-required-plugins-are-installed/199329
**Category:** Elastic Cloud on Kubernetes (ECK)
**Created:** [September 12, 2019, 10:00pm UTC](https://discuss.elastic.co/t/unknown-secure-setting-secure-bind-password-please-check-that-any-required-plugins-are-installed/199329 "2019-09-12T22:00:14Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![sfgroups1](https://avatars.discourse-cdn.com/v4/letter/s/b77776/32.png) [@sfgroups1](https://discuss.elastic.co/u/sfgroups1)
#### Post date: [September 12, 2019, 10:00pm UTC](https://discuss.elastic.co/t/unknown-secure-setting-secure-bind-password-please-check-that-any-required-plugins-are-installed/199329/1 "2019-09-12T22:00:15Z")

</div>

Hi,  
when I deploy below in my kubernetes cluster 1.15.3. POD is failing with secure setting error message.

How to fix this error?

```
apiVersion: v1
kind: Secret
metadata:
  name: secure-bind-password
type: Opaque
data:
  xpack.security.authc.realms.ldap.ldap1.secure_bind_password: XXXXXXaW4=
---
apiVersion: elasticsearch.k8s.elastic.co/v1alpha1
kind: Elasticsearch
metadata:
  name: quickstart
spec:
  version: 7.2.0
  secureSettings:
    secretName: secure-bind-password  
  image: docker.elastic.co/elasticsearch/elasticsearch:7.3.1 
  nodes:
  - nodeCount: 1
    config:
      node.master: true
      node.data: true
      node.ingest: true
      xpack.security.authc.realms: &xpack-realms
        # explicitly enable file and native realm, otherwise it's disabled implicitly when other realms are used.
        file.file1: { order: 0 }
        native.native1: { order: 1 }
        ldap.ldap1:
          order: 2
          url: "ldap://example:389"
          bind_dn: ""
          secure_bind_password: xpack.security.authc.realms.ldap.ldap1.secure_bind_password		  
---

```

**error messae**

```
"stacktrace": ["org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown secure setting [secure_bind_password] please check that any required plugins are installed, or check the breaking changes documentation for removed settings",
"at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-7.3.1.jar:7.3.1]",
"at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-7.3.1.jar:7.3.1]",
"at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.3.1.jar:7.3.1]",
"at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-7.3.1.jar:7.3.1]",
"at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.3.1.jar:7.3.1]",
"at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.3.1.jar:7.3.1]",
"at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.3.1.jar:7.3.1]",
"Caused by: java.lang.IllegalArgumentException: unknown secure setting [secure_bind_password] please check that any required plugins are installed, or check the breaking changes documentation for removed settings",
"at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:531) ~[elasticsearch-7.3.1.jar:7.3.1]",
"at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:476) ~[elasticsearch-7.3.1.jar:7.3.1]",
"at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:447) ~[elasticsearch-7.3.1.jar:7.3.1]",
"at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:418) ~[elasticsearch-7.3.1.jar:7.3.1]",
```

---

<div class="post-metadata">

### Author: ![sebgl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sebgl/32/48702_2.png) [@sebgl](https://discuss.elastic.co/u/sebgl)
#### Post date: [September 13, 2019, 10:59am UTC](https://discuss.elastic.co/t/unknown-secure-setting-secure-bind-password-please-check-that-any-required-plugins-are-installed/199329/2 "2019-09-13T10:59:24Z")

</div>

Hi @sfgroups1,

Looking at the [ES doc](https://www.elastic.co/guide/en/elasticsearch/reference/master/configuring-ldap-realm.html), I think the secure setting name must be "xpack.security.authc.realms.ldap.ldap1.secure\_bind\_password". The log error seems to indicate you set "secure\_bind\_password". Can you double-check your secret named "secure-bind-password" correctly has a key named "xpack.security.authc.realms.ldap.ldap1.secure\_bind\_password"?

---

<div class="post-metadata">

### Author: ![sfgroups1](https://avatars.discourse-cdn.com/v4/letter/s/b77776/32.png) [@sfgroups1](https://discuss.elastic.co/u/sfgroups1)
#### Post date: [September 13, 2019, 1:54pm UTC](https://discuss.elastic.co/t/unknown-secure-setting-secure-bind-password-please-check-that-any-required-plugins-are-installed/199329/3 "2019-09-13T13:54:09Z")

</div>

> [@sebgl](#):
>
> xpack.security.authc.realms.ldap.ldap1.secure\_bind\_password

Thanks for the tips, I had duplicate entry in the secret. now it works.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 4, 2022, 7:25am UTC](https://discuss.elastic.co/t/unknown-secure-setting-secure-bind-password-please-check-that-any-required-plugins-are-installed/199329/4 "2022-11-04T07:25:13Z")

</div>


