# Unknown setting \[archived.xpack.monitoring.collection.enabled\]

**URL:** <https://discuss.elastic.co/t/unknown-setting-archived-xpack-monitoring-collection-enabled/155979>\
**Category:** Kibana\
**Tags:** elastic-stack-monitoring\
**Created:** [November 9, 2018, 5:47am UTC](https://discuss.elastic.co/t/unknown-setting-archived-xpack-monitoring-collection-enabled/155979 "2018-11-09T05:47:08Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![vivektsb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vivektsb/32/49029_2.png) [@vivektsb](https://discuss.elastic.co/u/vivektsb)\
**Post date:** [November 9, 2018, 5:47am UTC](https://discuss.elastic.co/t/unknown-setting-archived-xpack-monitoring-collection-enabled/155979/1 "2018-11-09T05:47:08Z")

</div>

Hi,

We have installed ELK 6.2.1 using Docker.When we tried to disable the shards allocation using we are getting following erro.How can we resolve this..?

PUT \_cluster/settings  
{  
"persistent": {  
"cluster.routing.allocation.enable": "none"  
}  
}

{  
"error": {  
"root\_cause": [  
{  
"type": "illegal\_argument\_exception",  
"reason": "unknown setting [archived.xpack.monitoring.collection.enabled] please check that any required plugins are installed, or check the breaking changes documentation for removed settings"  
}  
],  
"type": "illegal\_argument\_exception",  
"reason": "unknown setting [archived.xpack.monitoring.collection.enabled] please check that any required plugins are installed, or check the breaking changes documentation for removed settings"  
},  
"status": 400  
}

---

<div class="post-metadata">

**Author:** ![jen-huang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jen-huang/32/74327_2.png) [@jen-huang](https://discuss.elastic.co/u/jen-huang)\
**Post date:** [November 9, 2018, 10:35pm UTC](https://discuss.elastic.co/t/unknown-setting-archived-xpack-monitoring-collection-enabled/155979/2 "2018-11-09T22:35:20Z")

</div>

Hello, can you paste the results of `GET /_cluster/settings`? The error is referring to a setting that is no longer supported, so it may need to be removed.

---

<div class="post-metadata">

**Author:** ![vivektsb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vivektsb/32/49029_2.png) [@vivektsb](https://discuss.elastic.co/u/vivektsb)\
**Post date:** [November 12, 2018, 3:42am UTC](https://discuss.elastic.co/t/unknown-setting-archived-xpack-monitoring-collection-enabled/155979/3 "2018-11-12T03:42:01Z")

</div>

Please find the response for

GET /\_cluster/settings  
{  
"persistent": {  
"archived": {  
"xpack": {  
"monitoring": {  
"collection": {  
"enabled": "true"  
}  
}  
}  
},  
"search": {  
"remote": {  
"node name": {  
"seeds": [  
"xx.xx.xx.xx:9300"  
]  
},  
"storagenodename": {  
"skip\_unavailable": "true",  
"seeds": [  
":50000"  
]  
}  
}  
}  
},  
"transient": {}  
}

We tried to disable this setting like

PUT \_cluster/settings  
{  
"persistent": {  
"archived.xpack.monitoring.collection.enabled": "false"  
}  
}

but getting error like

{  
"error": {  
"root\_cause": [  
{  
"type": "illegal\_argument\_exception",  
"reason": "persistent setting [archived.xpack.monitoring.collection.enabled], not recognized"  
}  
],  
"type": "illegal\_argument\_exception",  
"reason": "persistent setting [archived.xpack.monitoring.collection.enabled], not recognized"  
},  
"status": 400  
}

---

<div class="post-metadata">

**Author:** ![rajisankar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rajisankar/32/43250_2.png) [@rajisankar](https://discuss.elastic.co/u/rajisankar)\
**Post date:** [November 30, 2018, 4:55am UTC](https://discuss.elastic.co/t/unknown-setting-archived-xpack-monitoring-collection-enabled/155979/4 "2018-11-30T04:55:04Z")

</div>

I am facing the same issue with Elasticsearch 6.3 OSS docker image. Is there a fix or workaround for this?

---

<div class="post-metadata">

**Author:** ![rajisankar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rajisankar/32/43250_2.png) [@rajisankar](https://discuss.elastic.co/u/rajisankar)\
**Post date:** [December 3, 2018, 12:53am UTC](https://discuss.elastic.co/t/unknown-setting-archived-xpack-monitoring-collection-enabled/155979/5 "2018-12-03T00:53:38Z")

</div>

I installed Elasticsearch 6.3 with x-pack installed and still got the same error.

## Workflow:

- Start 3 Elasticsearch 6.3 (with x-pack) nodes as docker containers. Make them part of a 3-node cluster.

- Start a 4th container and add it to the cluster

- Try removing the 4th node using the curl command below.

The REST call fails with the following error

`{"error":{"root_cause":[{"type":"remote_transport_exception","reason":"[es-node-1][172.18.0.2:9300][cluster:admin/settings/update]"}],"type":"illegal_argument_exception","reason":"unknown setting [archived.xpack.monitoring.collection.enabled] did you mean [xpack.monitoring.collection.enabled]?"},"status":400}`

- The get cluster settings provides the following response. I do not know what set the archived.xpack.monitoring.collection.enabled=true.

curl "10.76.144.18:9200/\_cluster/settings?pretty"

```
{
  "persistent" : {
    "archived" : {
      "xpack" : {
        "monitoring" : {
          "collection" : {
            "enabled" : "true"
          }
        }
      }
    }
  },
  "transient" : { }
}

```

Any pointers to fixing this is highly appreciated!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 31, 2018, 12:53am UTC](https://discuss.elastic.co/t/unknown-setting-archived-xpack-monitoring-collection-enabled/155979/6 "2018-12-31T00:53:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
