# Unknown setting 'jass\_path' for kafka in kafka input

**URL:** https://discuss.elastic.co/t/unknown-setting-jass-path-for-kafka-in-kafka-input/184953
**Category:** Logstash
**Created:** [June 10, 2019, 9:01am UTC](https://discuss.elastic.co/t/unknown-setting-jass-path-for-kafka-in-kafka-input/184953 "2019-06-10T09:01:08Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Sharon\_Abu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sharon_abu/32/47792_2.png) [@Sharon\_Abu](https://discuss.elastic.co/u/Sharon_Abu)
#### Post date: [June 10, 2019, 9:01am UTC](https://discuss.elastic.co/t/unknown-setting-jass-path-for-kafka-in-kafka-input/184953/1 "2019-06-10T09:01:08Z")

</div>

Hi,

I'm trying to configure logstash to connect to confluent cloud kafka using input configuration a jaas file

using docker compose with logstash image version 6.0.1 (also tried with v6.8)

my docker service looks like this

logstash:  
image: [docker.elastic.co/logstash/logstash:6.0.1](http://docker.elastic.co/logstash/logstash:6.0.1)  
container\_name: logstash--dev  
volumes:  
- ./logstash/config/logstash.yml:/usr/share/logstash/config/logstash.yml:ro  
- ./logstash/config/confluent\_jass.conf:/usr/share/logstash/config/confluent\_jass.conf:ro  
- ./logstash/config/pipelines.yml:/usr/share/logstash/config/pipelines.yml:ro  
- ./logstash/pipeline:/usr/share/logstash/pipeline:ro

```
environment:
  LS_JAVA_OPTS: "-Xmx256m -Xms256m"
ports:
  - "5000:5000"
depends_on: 
  - elasticsearch
  - broker

```

my jaas files configuration looks like this:

KafkaClient {  
org.apache.kafka.common.security.plain.PlainLoginModule required  
serviceName="Logatsh"  
username="some username"  
password="some pass";  
};

And My input configuration looks like this:

kafka {

```
	group_id => "my-lgstash-consumers"
	topics => ["topic1", "topic2"]
	bootstrap_servers => "myserverdomain:9092"
	security_protocol => "SASL_SSL"
	sasl_mechanism => "PLAIN"		
	jass_path => "/usr/share/logstash/config/confluent_jass.conf"
	 codec => json {
	 	charset => "UTF-8"
	 }
}

```

However when I run it I get an error log:

[ERROR][logstash.inputs.kafka] **Unknown setting 'jass\_path' for kafka**  
[2019-06-10T08:43:07,788][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:events-pipeline, :exception=\>"LogStash::ConfigurationError", :message=\>"Something is wrong with your configuration.", :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/config/mixin.rb:86:in `config_init'", "/usr/share/logstash/logstash-core/lib/logstash/inputs/base.rb:60:in`initialize'", "org/logstash/plugins/PluginFactoryExt.java:255:in `plugin'", "org/logstash/plugins/PluginFactoryExt.java:184:in`plugin'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:71:in `plugin'", "(eval):24:in`initialize'", "org/jruby/RubyKernel.java:1061:in `eval'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:49:in`initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:90:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline_action/create.rb:43:in`block in execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:96:in `block in exclusive'", "org/jruby/ext/thread/Mutex.java:165:in`synchronize'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:96:in `exclusive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline_action/create.rb:39:in`execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:334:in `block in converge\_state'"]}

---

<div class="post-metadata">

### Author: ![Sharon\_Abu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sharon_abu/32/47792_2.png) [@Sharon\_Abu](https://discuss.elastic.co/u/Sharon_Abu)
#### Post date: [June 10, 2019, 12:38pm UTC](https://discuss.elastic.co/t/unknown-setting-jass-path-for-kafka-in-kafka-input/184953/2 "2019-06-10T12:38:11Z")

</div>

solved , it was a typo in the name

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 8, 2019, 12:38pm UTC](https://discuss.elastic.co/t/unknown-setting-jass-path-for-kafka-in-kafka-input/184953/3 "2019-07-08T12:38:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
