# Unrecognized VM option 'UseConcMarkSweepGC'

**URL:** <https://discuss.elastic.co/t/unrecognized-vm-option-useconcmarksweepgc/251109>\
**Category:** Elasticsearch\
**Created:** [October 6, 2020, 11:24am UTC](https://discuss.elastic.co/t/unrecognized-vm-option-useconcmarksweepgc/251109 "2020-10-06T11:24:51Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![dewell](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dewell/32/84214_2.png) [@dewell](https://discuss.elastic.co/u/dewell)\
**Post date:** [October 6, 2020, 11:24am UTC](https://discuss.elastic.co/t/unrecognized-vm-option-useconcmarksweepgc/251109/1 "2020-10-06T11:24:51Z")

</div>

Hello,  
in my work I got access to a virtual machine with elasticsearch. It used to be running so I didn't have to change something myself. For some reason it stopped and when I try to restart it I get the following error message:

> Exception in thread "main" java.lang.RuntimeException: starting java failed with [1]  
> output:
> 
> error:  
> Unrecognized VM option 'UseConcMarkSweepGC'  
> Error: Could not create the Java Virtual Machine.  
> Error: A fatal exception has occurred. Program will exit.  
> at org.elasticsearch.tools.launchers.JvmErgonomics.flagsFinal(JvmErgonomics.java:126)  
> at org.elasticsearch.tools.launchers.JvmErgonomics.finalJvmOptions(JvmErgonomics.java:88)  
> at org.elasticsearch.tools.launchers.JvmErgonomics.choose(JvmErgonomics.java:59)  
> at org.elasticsearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:137)  
> at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:95)

java -version output:

> openjdk version "1.8.0\_265"  
> OpenJDK Runtime Environment (build 1.8.0\_265-8u265-b01-0ubuntu2~18.04-b01)  
> OpenJDK 64-Bit Server VM (build 25.265-b01, mixed mode)

Any idea how to solve this? I'm not sure what changed within the last days, maybe someone changed the global java installation?

Thanks in advance and let me know if I need to provide more information

---

<div class="post-metadata">

**Author:** ![kavierkoo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kavierkoo/32/86555_2.png) [@kavierkoo](https://discuss.elastic.co/u/kavierkoo)\
**Post date:** [October 6, 2020, 2:30pm UTC](https://discuss.elastic.co/t/unrecognized-vm-option-useconcmarksweepgc/251109/2 "2020-10-06T14:30:07Z")

</div>

What is your elasticsearch and OS version ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 3, 2020, 2:30pm UTC](https://discuss.elastic.co/t/unrecognized-vm-option-useconcmarksweepgc/251109/3 "2020-11-03T14:30:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
