# Unresolved or ambiguous specs during Gem::Specification.reset: date (\>= 0), but cannot run gem command to resolve

**URL:** <https://discuss.elastic.co/t/unresolved-or-ambiguous-specs-during-gem-specification-reset-date-0-but-cannot-run-gem-command-to-resolve/351931>\
**Category:** Logstash\
**Created:** [January 28, 2024, 7:53am UTC](https://discuss.elastic.co/t/unresolved-or-ambiguous-specs-during-gem-specification-reset-date-0-but-cannot-run-gem-command-to-resolve/351931 "2024-01-28T07:53:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![hughjarse](https://avatars.discourse-cdn.com/v4/letter/h/47e85d/32.png) [@hughjarse](https://discuss.elastic.co/u/hughjarse)\
**Post date:** [January 28, 2024, 7:53am UTC](https://discuss.elastic.co/t/unresolved-or-ambiguous-specs-during-gem-specification-reset-date-0-but-cannot-run-gem-command-to-resolve/351931/1 "2024-01-28T07:53:53Z")

</div>

Running the `logstash-plugin list` or `logstash-plugin install` commands cause the following error. How can I troubleshoot and resolve this problem with the `gem` command that is built into Logstash?

```auto
WARN: Unresolved or ambiguous specs during Gem::Specification.reset:
      date (>= 0)
      Available/installed versions of this gem:
      - 3.3.4
      - 3.3.3
WARN: Clearing out unresolved specs. Try 'gem cleanup <gem>'
Please report a bug if this causes problems.

```

The `gem` command is not installed at the OS-level, but does appear to exist within Logstash's own directory structure, however running that `gem` executable causes the following error.

```auto
[root@server-hostname ~]# find /usr/share/logstash/* -name "gem" -print
/usr/share/logstash/vendor/jruby/bin/gem
[root@server-hostname ~]# cd /usr/share/logstash/vendor/jruby/bin/
[root@server-hostname bin]# ./gem list
/usr/bin/env: jruby: No such file or directory
[root@server-hostname bin]#

```

Logstash v8.12.0-1 installed via the official Elastic rpm repo. OS is Amazon Linux.

---

<div class="post-metadata">

**Author:** ![derekorr](https://avatars.discourse-cdn.com/v4/letter/d/a698b9/32.png) [@derekorr](https://discuss.elastic.co/u/derekorr)\
**Post date:** [February 14, 2024, 3:49pm UTC](https://discuss.elastic.co/t/unresolved-or-ambiguous-specs-during-gem-specification-reset-date-0-but-cannot-run-gem-command-to-resolve/351931/2 "2024-02-14T15:49:23Z")

</div>

Was this ever resolved?

---

<div class="post-metadata">

**Author:** ![hughjarse](https://avatars.discourse-cdn.com/v4/letter/h/47e85d/32.png) [@hughjarse](https://discuss.elastic.co/u/hughjarse)\
**Post date:** [February 15, 2024, 1:17am UTC](https://discuss.elastic.co/t/unresolved-or-ambiguous-specs-during-gem-specification-reset-date-0-but-cannot-run-gem-command-to-resolve/351931/3 "2024-02-15T01:17:52Z")

</div>

Unfortunately, no. We still get the same error, even after updating our logstash package.

As an aside, we also have reason to believe that this error is related to an issue we are experiencing where the `logstash-filter-tld` plugin cannot be properly installed. The install appears to complete, but the plugin is not listed anywhere within the output of `bin/logstash-plugin update` (the plugin was either updated or not).

If anyone has any insight, we'd appreciate if you could share.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 14, 2024, 1:18am UTC](https://discuss.elastic.co/t/unresolved-or-ambiguous-specs-during-gem-specification-reset-date-0-but-cannot-run-gem-command-to-resolve/351931/4 "2024-03-14T01:18:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
