# Update script fail

**URL:** https://discuss.elastic.co/t/update-script-fail/82800
**Category:** Elasticsearch
**Created:** [April 19, 2017, 1:23am UTC](https://discuss.elastic.co/t/update-script-fail/82800 "2017-04-19T01:23:44Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![orange-jacky](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/orange-jacky/32/34416_2.png) [@orange-jacky](https://discuss.elastic.co/u/orange-jacky)
#### Post date: [April 19, 2017, 1:23am UTC](https://discuss.elastic.co/t/update-script-fail/82800/1 "2017-04-19T01:23:44Z")

</div>

Elasticsearch version:  
elasticsearch-2.3.5.tar.gz

Plugins installed: []  
modules [reindex, lang-expression, lang-groovy], plugins [license, delete-by-query], sites []

JVM version:  
java version "1.8.0\_65"  
Java(TM) SE Runtime Environment (build 1.8.0\_65-b17)  
Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode)

OS version:  
[search@search-02 es1]$ lsb\_release -a  
LSB Version: :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch  
Distributor ID: CentOS  
Description: CentOS release 6.5 (Final)  
Release: 6.5  
Codename: Final

[search@search-02 es1]$ uname -a  
Linux search-02.cloud.mos 2.6.32-431.1.2.0.1.el6.x86\_64 #1 SMP Fri Dec 13 13:06:13 UTC 2013 x86\_64 x86\_64 x86\_64 GNU/Linux

Description of the problem including expected versus actual behavior:  
PUT test/type1/1  
{  
"counter" : 1,  
"tags" : ["red"]  
}  
it ok

POST test/type1/1/\_update  
{  
"script" : {  
"inline": "ctx.\_source.counter += count",  
"params" : {  
"count" : 4  
}  
}  
}

it fail.

error info:

"error": {  
"root\_cause": [  
{  
"type": "remote\_transport\_exception",  
"reason": "[node-3][172.16.8.145:9300][indices:data/write/update[s]]"  
}  
],  
"type": "illegal\_argument\_exception",  
"reason": "failed to execute script",  
"caused\_by": {  
"type": "script\_exception",  
"reason": "failed to run inline script [ctx.\_source.counter += count] using lang [groovy]",  
"caused\_by": {  
"type": "no\_class\_def\_found\_error",  
"reason": "Could not initialize class org.codehaus.groovy.vmplugin.v7.IndyGuardsFiltersAndSignatures"  
}  
}  
},  
"status": 400  
}

you will find configures and logs by the flowing url.

> <https://github.com/elastic/elasticsearch/issues/24153>

￼

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 17, 2017, 1:27am UTC](https://discuss.elastic.co/t/update-script-fail/82800/2 "2017-05-17T01:27:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
