# Update to 8.2.2 showing error in keystore-init

**URL:** https://discuss.elastic.co/t/update-to-8-2-2-showing-error-in-keystore-init/307076
**Category:** Elasticsearch
**Tags:** docker
**Created:** [June 13, 2022, 9:37pm UTC](https://discuss.elastic.co/t/update-to-8-2-2-showing-error-in-keystore-init/307076 "2022-06-13T21:37:12Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Dxnium](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dxnium/32/106957_2.png) [@Dxnium](https://discuss.elastic.co/u/Dxnium)
#### Post date: [June 13, 2022, 9:37pm UTC](https://discuss.elastic.co/t/update-to-8-2-2-showing-error-in-keystore-init/307076/1 "2022-06-13T21:37:12Z")

</div>

Currently testing to update elastic from 8.1.3 to 8.2.2, but when i tried to deploy with the latest version I'm getting this error.

Also getting the same error with version 8.2.0

I'm using the same cofiguration from 8.1.3, the only change is the docker image now is pointing to Elasticsearch:8.2.x

```auto
Exception in thread "main" org.elasticsearch.ElasticsearchParseException: null-valued setting found for key [path.repo] found at line number [19], column number [8]
	at org.elasticsearch.common.settings.Settings.validateValue(Settings.java:767)
	at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:743)
	at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:724)
	at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:687)
	at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1189)
	at org.elasticsearch.node.InternalSettingsPreparer.loadConfigWithSubstitutions(InternalSettingsPreparer.java:140)
	at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:54)
	at org.elasticsearch.common.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:95)
	at org.elasticsearch.common.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:86)
	at org.elasticsearch.common.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:81)
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112)
	at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:95)
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112)
	at org.elasticsearch.cli.Command.main(Command.java:77)
	at org.elasticsearch.cli.keystore.KeyStoreCli.main(KeyStoreCli.java:33)

```

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [June 14, 2022, 12:55am UTC](https://discuss.elastic.co/t/update-to-8-2-2-showing-error-in-keystore-init/307076/2 "2022-06-14T00:55:19Z")

</div>

Welcome to our community! 😃

Please share the entire error, as well as your Elasticsearch.yml.

---

<div class="post-metadata">

### Author: ![Dxnium](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dxnium/32/106957_2.png) [@Dxnium](https://discuss.elastic.co/u/Dxnium)
#### Post date: [June 21, 2022, 4:26pm UTC](https://discuss.elastic.co/t/update-to-8-2-2-showing-error-in-keystore-init/307076/3 "2022-06-21T16:26:14Z")

</div>

I remove the path.repo from the values.yaml and then this start happening.

This errors are only happening in elastic 8.2.x

```auto
Exception in thread "main" org.elasticsearch.common.settings.SettingsException: Failed to load settings from [elasticsearch.yml]
	at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1193)
	at org.elasticsearch.node.InternalSettingsPreparer.loadConfigWithSubstitutions(InternalSettingsPreparer.java:140)
	at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:54)
	at org.elasticsearch.common.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:95)
	at org.elasticsearch.common.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:86)
	at org.elasticsearch.common.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:81)
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112)
	at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:95)
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112)
	at org.elasticsearch.cli.Command.main(Command.java:77)
	at org.elasticsearch.cli.keystore.KeyStoreCli.main(KeyStoreCli.java:33)
Caused by: org.elasticsearch.xcontent.XContentParseException: [29:17] while scanning an alias
 in 'reader', line 29, column 19:
        allow-origin: *
                      ^
unexpected character found

```

Also I guess is related to the update elastic apply to the:

**Upgrade jackson for x-content to 2.13.2**

> <https://github.com/elastic/elasticsearch/pull/84905/files>
>
> This commit upgrades Jackson used in x-content. It does not affect
> Jackson used… in modules or plugins.

---

<div class="post-metadata">

### Author: ![Dxnium](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dxnium/32/106957_2.png) [@Dxnium](https://discuss.elastic.co/u/Dxnium)
#### Post date: [June 21, 2022, 4:28pm UTC](https://discuss.elastic.co/t/update-to-8-2-2-showing-error-in-keystore-init/307076/5 "2022-06-21T16:28:17Z")

</div>

After the upgrade of the jackson in release 8.2.0, errors with yaml parser start happening

---

<div class="post-metadata">

### Author: ![Dxnium](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dxnium/32/106957_2.png) [@Dxnium](https://discuss.elastic.co/u/Dxnium)
#### Post date: [June 24, 2022, 5:07pm UTC](https://discuss.elastic.co/t/update-to-8-2-2-showing-error-in-keystore-init/307076/6 "2022-06-24T17:07:09Z")

</div>

this solved the issue for me.  
add this double quotes: **"\*"**  
allow-origin: "\*"

```auto
http:
  enabled: true
  compression: true
  cors:
    enabled: true
    allow-origin: "*"

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 22, 2022, 5:07pm UTC](https://discuss.elastic.co/t/update-to-8-2-2-showing-error-in-keystore-init/307076/7 "2022-07-22T17:07:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
