# Updating to version 7.17.15 caused the 'Failed to publish events' issue caused connection reset by peer

**URL:** https://discuss.elastic.co/t/updating-to-version-7-17-15-caused-the-failed-to-publish-events-issue-caused-connection-reset-by-peer/348740
**Category:** Elasticsearch
**Tags:** elastic-stack-monitoring
**Created:** [December 6, 2023, 4:10pm UTC](https://discuss.elastic.co/t/updating-to-version-7-17-15-caused-the-failed-to-publish-events-issue-caused-connection-reset-by-peer/348740 "2023-12-06T16:10:49Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Saleh\_Houshangi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saleh_houshangi/32/120645_2.png) [@Saleh\_Houshangi](https://discuss.elastic.co/u/Saleh_Houshangi)
#### Post date: [December 6, 2023, 4:10pm UTC](https://discuss.elastic.co/t/updating-to-version-7-17-15-caused-the-failed-to-publish-events-issue-caused-connection-reset-by-peer/348740/1 "2023-12-06T16:10:49Z")

</div>

After updating Elasticsearch and Logstash from version 7.17.5 to 7.17.15, all Filebeat instances sporadically encounter the following error in the log file:

```auto
caa27ea3-c641-4ad2-9f03-578f008a4013'} 2023-12-06T16:06:56.260Z ERROR [logstash] logstash/async.go:280 Failed to publish events caused by: write tcp 10.84.x.x:62882->10.77.x.x:5044: write: connection reset by peer 2023-12-06T16:06:56.260Z INFO [publisher] pipeline/retry.go:219 retryer: send unwait signal to consumer 2023-12-06T16:06:56.260Z INFO [publisher] pipeline/retry.go:223 done 2023-12-06T16:06:57.935Z ERROR [publisher_pipeline_output] pipeline/output.go:180 failed to publish events: write tcp 10.84.x.x:62882->10.77.x.x:5044: write: connection reset by peer 2023-12-06T16:06:57.935Z INFO [publisher_pipeline_output] pipeline/output.go:143 Connecting to backoff(async(tcp://itxxx-oxlogstash-bs-qa-01.server.lan:5044)) 2023-12-06T16:06:57.936Z INFO [publisher] pipeline/retry.go:219 retryer: send unwait signal to consumer 2023-12-06T16:06:57.936Z INFO [publisher] pipeline/retry.go:223 done 2023-12-06T16:06:57.937Z INFO [publisher_pipeline_output] pipeline/output.go:151 Connection to backoff(async(tcp://itxxx-oxlogstash-bs-qa-01.server.lan:5044)) established

```

I updated Filebeat from version 7.17.1 to 7.17.15, but the problem still exists

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 3, 2024, 4:11pm UTC](https://discuss.elastic.co/t/updating-to-version-7-17-15-caused-the-failed-to-publish-events-issue-caused-connection-reset-by-peer/348740/2 "2024-01-03T16:11:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
