# Upgrade 1.0.3 to 6.3.1

**URL:** <https://discuss.elastic.co/t/upgrade-1-0-3-to-6-3-1/139848>\
**Category:** Elasticsearch\
**Created:** [July 12, 2018, 10:39pm UTC](https://discuss.elastic.co/t/upgrade-1-0-3-to-6-3-1/139848 "2018-07-12T22:39:49Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![jettro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jettro/32/3418_2.png) [@jettro](https://discuss.elastic.co/u/jettro)\
**Post date:** [July 12, 2018, 10:39pm UTC](https://discuss.elastic.co/t/upgrade-1-0-3-to-6-3-1/139848/1 "2018-07-12T22:39:49Z")

</div>

Hi,  
I am at a customer with an older version of elasticsearch (1.0.3). One of those versions without documentation. I cannot seem to figure out the right syntax for this version. Does someone have an idea about the best way to migrate the content from the old version to a new 6.3.1 version. I don't mind doing stuff like intermediate versions in a file based record, if necessary I might be able to upgrade to 1.7 first. Does someone have experience with that?

Thanks for thinking with me

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 13, 2018, 5:53am UTC](https://discuss.elastic.co/t/upgrade-1-0-3-to-6-3-1/139848/2 "2018-07-13T05:53:21Z")

</div>

I'd reindex.

May be with logstash with an elasticsearch input and an elasticsearch output.

---

<div class="post-metadata">

**Author:** ![jettro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jettro/32/3418_2.png) [@jettro](https://discuss.elastic.co/u/jettro)\
**Post date:** [July 13, 2018, 7:37am UTC](https://discuss.elastic.co/t/upgrade-1-0-3-to-6-3-1/139848/3 "2018-07-13T07:37:38Z")

</div>

Using logstash is of course possible, it seems I am running into the same issue as with python. The scroll\_id gives me issues. I see this in the logstash log and it seems that the scan starts at the beginning each time:

```
Error: [400] {"error":"ElasticsearchIllegalArgumentException[Failed to decode scrollId]; nested: IOException[Bad Base64 input character decimal 123 in array position 0]; ","status":400}
  Exception: Elasticsearch::Transport::Transport::Errors::BadRequest
  Stack: /Users/jettrocoenradie/Development/elastic/logstash/logstash-6.2.3/vendor/bundle/jruby/2.3.0/gems/elasticsearch-transport-5.0.4/lib/elasticsearch/transport/transport/base.rb:202:in `__raise_transport_error'

```

Any other tips?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 13, 2018, 7:49am UTC](https://discuss.elastic.co/t/upgrade-1-0-3-to-6-3-1/139848/4 "2018-07-13T07:49:54Z")

</div>

I'm suprised by `elasticsearch-transport-5.0.4`. Does it mean that you are using the Transport layer?

---

<div class="post-metadata">

**Author:** ![jettro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jettro/32/3418_2.png) [@jettro](https://discuss.elastic.co/u/jettro)\
**Post date:** [July 13, 2018, 12:16pm UTC](https://discuss.elastic.co/t/upgrade-1-0-3-to-6-3-1/139848/5 "2018-07-13T12:16:21Z")

</div>

No, now I am using plain elasticsearch input as well as output adapter.

Tried it with the latest logstash version, though I can imagine it has problems with the old elasticsearch version. This is part of the error I get now.

```
  Pipeline_id:main
  Plugin: <LogStash::Inputs::Elasticsearch hosts=>["localhost:29200"], index=>"logstash-2017.05.24", id=>"d380546ebd5a12c31600fd24d91c287dddbf8ac05c4e6de4fa37804724e28fdd", enable_metric=>true, codec=><LogStash::Codecs::JSON id=>"json_d22276ad-e391-4322-9f52-23d60d0d90c9", enable_metric=>true, charset=>"UTF-8">, query=>"{ \"sort\": [\"_doc\"] }", size=>1000, scroll=>"1m", docinfo=>false, docinfo_target=>"@metadata", docinfo_fields=>["_index", "_type", "_id"], ssl=>false>
  Error: [400] {"error":"ElasticsearchIllegalArgumentException[Failed to decode scrollId]; nested: IOException[Bad Base64 input character decimal 123 in array position 0]; ","status":400}
  Exception: Elasticsearch::Transport::Transport::Errors::BadRequest

```

Could be related to the problem in this issue:

> <https://github.com/elastic/elasticsearch-net/issues/326>

So maybe I need to use an older logstash version

---

<div class="post-metadata">

**Author:** ![jettro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jettro/32/3418_2.png) [@jettro](https://discuss.elastic.co/u/jettro)\
**Post date:** [July 13, 2018, 12:18pm UTC](https://discuss.elastic.co/t/upgrade-1-0-3-to-6-3-1/139848/6 "2018-07-13T12:18:43Z")

</div>

There are more questions reporting this, now that I search using the message from the error.

> [@Scroll Failure \[Solved\]](https://discuss.elastic.co/t/scroll-failure-solved/52966):
>
> ES 1.7 When trying to scroll, I get the following: {"error":"ElasticsearchIllegalArgumentException[Failed to decode scrollId]; nested: IOException[Bad Base64 input character decimal 123 in array position 0]; ","status":400} Is there any simple way to work around this?

---

<div class="post-metadata">

**Author:** ![jettro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jettro/32/3418_2.png) [@jettro](https://discuss.elastic.co/u/jettro)\
**Post date:** [July 13, 2018, 2:21pm UTC](https://discuss.elastic.co/t/upgrade-1-0-3-to-6-3-1/139848/7 "2018-07-13T14:21:30Z")

</div>

The logstash path seems hard with this version, however, it turns out I made a mistake in the url when using python. SO it works now using python.

Thanks for thinking with me

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 10, 2018, 2:21pm UTC](https://discuss.elastic.co/t/upgrade-1-0-3-to-6-3-1/139848/8 "2018-08-10T14:21:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
